]> git.pld-linux.org Git - packages/libgda4.git/blob - libgda4.spec
3936106f7d4ffc27693fdf8ce3287e50e41275dc
[packages/libgda4.git] / libgda4.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static libraries build
5 %bcond_without  vala            # Vala support
6 # - database plugins:
7 %bcond_without  dbsql           # BerkeleyDB SQL plugin
8 %bcond_without  jdbc            # JDBC plugin
9 %bcond_without  ldap            # LDAP plugin
10 %bcond_without  mdb             # MDB plugin
11 %bcond_without  mysql           # MySQL plugin
12 %bcond_with     oci             # Oracle DB plugin
13 %bcond_without  pgsql           # PostgreSQL plugin
14 #
15 %ifnarch i486 i586 i686 pentium3 pentium4 athlon %{x8664}
16 %undefine       with_jdbc
17 %endif
18 %define vala_ver        0.24
19
20 Summary:        GNU Data Access library
21 Summary(pl.UTF-8):      Biblioteka GNU Data Access
22 Name:           libgda4
23 Version:        4.2.13
24 Release:        2
25 License:        LGPL v2+/GPL v2+
26 Group:          Libraries
27 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libgda/4.2/libgda-%{version}.tar.xz
28 # Source0-md5:  d9a69fd4c08469c072c588ae9e73800b
29 Patch0:         %{name}-configure.patch
30 Patch1:         %{name}-gir.patch
31 Patch2:         %{name}-graphviz.patch
32 URL:            http://www.gnome-db.org/
33 BuildRequires:  autoconf >= 2.59
34 BuildRequires:  automake >= 1:1.8
35 BuildRequires:  bison
36 BuildRequires:  db-devel
37 %{?with_dbsql:BuildRequires:    db-sql-devel}
38 BuildRequires:  docbook-dtd412-xml
39 BuildRequires:  flex
40 BuildRequires:  gettext-devel
41 BuildRequires:  glib2-devel >= 1:2.18.0
42 BuildRequires:  glibc-misc
43 BuildRequires:  gnome-doc-utils >= 0.9.0
44 BuildRequires:  gobject-introspection-devel >= 0.6.5
45 BuildRequires:  goocanvas-devel
46 BuildRequires:  graphviz-devel
47 BuildRequires:  gtk+2-devel >= 2:2.12.0
48 BuildRequires:  gtk-doc >= 1.6
49 BuildRequires:  gtksourceview2-devel
50 BuildRequires:  intltool >= 0.40.0
51 BuildRequires:  iso-codes
52 %{?with_jdbc:BuildRequires:     jdk}
53 BuildRequires:  json-glib-devel
54 BuildRequires:  libgcrypt-devel >= 1.1.42
55 BuildRequires:  libgnome-keyring-devel
56 BuildRequires:  libsoup-devel >= 2.24.0
57 BuildRequires:  libtool
58 BuildRequires:  libunique-devel
59 BuildRequires:  libxml2-devel >= 1:2.6.26
60 BuildRequires:  libxslt-devel >= 1.1.17
61 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6-0.pre1.7}
62 %{?with_mysql:BuildRequires:    mysql-devel}
63 %{?with_ldap:BuildRequires:     openldap-devel}
64 BuildRequires:  openssl-devel
65 %{?with_oci:BuildRequires:      oracle-instantclient-devel}
66 BuildRequires:  perl-base
67 BuildRequires:  pkgconfig >= 1:0.18
68 %{?with_pgsql:BuildRequires:    postgresql-devel}
69 BuildRequires:  python
70 BuildRequires:  readline-devel >= 5.0
71 BuildRequires:  rpmbuild(macros) >= 1.601
72 BuildRequires:  sed >= 4.0
73 BuildRequires:  sqlite3-devel >= 3.6.11
74 BuildRequires:  tar >= 1:1.22
75 %{?with_vala:BuildRequires:     vala >= 2:%{vala_ver}}
76 BuildRequires:  xz
77 Requires:       glib2 >= 1:2.18.0
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %define         libgdadir       libgda-4.0
81 %define         providersdir    %{_libdir}/%{libgdadir}/providers
82
83 %description
84 GNU Data Access is an attempt to provide uniform access to different
85 kinds of data sources (databases, information servers, mail spools,
86 etc). It is a complete architecture that provides all you need to
87 access your data.
88
89 libgda was part of the GNOME-DB project but has been separated from it
90 to allow non-GNOME applications to be developed based on it.
91
92 %description -l pl.UTF-8
93 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
94 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
95 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
96 potrzebujesz do dostępu do danych.
97
98 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
99 pozwolić na używanie przez niegnomowe aplikacje.
100
101 %package devel
102 Summary:        GNU Data Access development files
103 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
104 Group:          Development/Libraries
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       glib2-devel >= 1:2.18.0
107 Requires:       libxml2-devel >= 1:2.6.26
108 Requires:       libxslt-devel >= 1.1.17
109
110 %description devel
111 GNU Data Access is an attempt to provide uniform access to different
112 kinds of data sources (databases, information servers, mail spools,
113 etc). It is a complete architecture that provides all you need to
114 access your data. This subpackage contains development files.
115
116 %description devel -l pl.UTF-8
117 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
118 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
119 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
120 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
121 programistów używających libgda.
122
123 %package static
124 Summary:        GNU Data Access static libraries
125 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128
129 %description static
130 GNU Data Access static libraries.
131
132 %description static -l pl.UTF-8
133 Statyczne biblioteki GNU Data Access.
134
135 %package -n vala-libgda4
136 Summary:        libgda 4.x API for Vala language
137 Summary(pl.UTF-8):      API libgda 4.x dla języka Vala
138 Group:          Development/Libraries
139 Requires:       %{name}-devel = %{version}-%{release}
140 Requires:       vala >= 2:%{vala_ver}
141
142 %description -n vala-libgda4
143 libgda 4.x API for Vala language.
144
145 %description -n vala-libgda4 -l pl.UTF-8
146 API libgda 4.x dla języka Vala.
147
148 %package ui
149 Summary:        GNU Data Access UI library
150 Summary(pl.UTF-8):      Biblioteka GNU Data Access UI
151 Group:          Libraries
152 Requires:       %{name} = %{version}-%{release}
153 Requires:       gtk+2 >= 2:2.12.0
154
155 %description ui
156 GNU Data Access UI library.
157
158 %description ui -l pl.UTF-8
159 Biblioteka GNU Data Access UI.
160
161 %package ui-devel
162 Summary:        Development files for GNU Data Access UI library
163 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access UI
164 Group:          Development/Libraries
165 Requires:       %{name}-ui = %{version}-%{release}
166 Requires:       gtk+2-devel >= 2:2.12.0
167
168 %description ui-devel
169 Development files for GNU Data Access UI library.
170
171 %description ui-devel -l pl.UTF-8
172 Pliki programistyczne biblioteki GNU Data Access UI.
173
174 %package ui-static
175 Summary:        GNU Data Access UI static library
176 Summary(pl.UTF-8):      Statyczna biblioteka GNU Data Access UI
177 Group:          Development/Libraries
178 Requires:       %{name}-ui-devel = %{version}-%{release}
179
180 %description ui-static
181 GNU Data Access UI static library.
182
183 %description ui-static -l pl.UTF-8
184 Statyczna biblioteka GNU Data Access UI.
185
186 %package apidocs
187 Summary:        GNU Data Access API documentation
188 Summary(pl.UTF-8):      Dokumentacja API GNU Data Access
189 Group:          Documentation
190 Requires:       gtk-doc-common
191
192 %description apidocs
193 GNU Data Access API documentation.
194
195 %description apidocs -l pl.UTF-8
196 Dokumentacja API GNU Data Access.
197
198 %package provider-db
199 Summary:        GDA Berkeley DB provider
200 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
201 Group:          Libraries
202 Requires:       %{name} = %{version}-%{release}
203
204 %description provider-db
205 This package contains the GDA Berkeley DB provider.
206
207 %description provider-db -l pl.UTF-8
208 Pakiet dostaczający dane z Berkeley DB dla GDA.
209
210 %package provider-dbsql
211 Summary:        GDA Berkeley DB SQL provider
212 Summary(pl.UTF-8):      Źródło danych Berkeley DB SQL dla GDA
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description provider-dbsql
217 This package contains the GDA Berkeley DB SQL provider.
218
219 %description provider-dbsql -l pl.UTF-8
220 Pakiet dostaczający dane z Berkeley DB SQL dla GDA.
221
222 %package provider-jdbc
223 Summary:        GDA JDBC provider
224 Summary(pl.UTF-8):      Źródło danych JDBC dla GDA
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227
228 %description provider-jdbc
229 This package contains the GDA JDBC provider.
230
231 %description provider-jdbc -l pl.UTF-8
232 Pakiet dostaczający dane z JDBC dla GDA.
233
234 %package provider-ldap
235 Summary:        GDA LDAP provider
236 Summary(pl.UTF-8):      Źródło danych LDAP
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239
240 %description provider-ldap
241 This package contains the GDA LDAP provider.
242
243 %description provider-ldap -l pl.UTF-8
244 Pakiet dostarczający dane z LDAP dla GDA.
245
246 %package provider-mdb
247 Summary:        GDA MDB provider
248 Summary(pl.UTF-8):      Źródło danych MDB
249 Group:          Libraries
250 Requires:       %{name} = %{version}-%{release}
251 Requires:       mdbtools-libs >= 0.6
252
253 %description provider-mdb
254 This package contains the GDA MDB provider.
255
256 %description provider-mdb -l pl.UTF-8
257 Pakiet dostarczający dane z MDB dla GDA.
258
259 %package provider-mysql
260 Summary:        GDA MySQL provider
261 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
262 Group:          Libraries
263 Requires:       %{name} = %{version}-%{release}
264
265 %description provider-mysql
266 This package contains the GDA MySQL provider.
267
268 %description provider-mysql -l pl.UTF-8
269 Pakiet dostarczający dane z MySQL dla GDA.
270
271 %package provider-oracle
272 Summary:        GDA Oracle provider
273 Summary(pl.UTF-8):      Źródło danych Oracle dla GDA
274 Group:          Libraries
275 Requires:       %{name} = %{version}-%{release}
276
277 %description provider-oracle
278 This package contains the GDA Oracle provider.
279
280 %description provider-oracle -l pl.UTF-8
281 Pakiet dostarczający dane z bazy Oracle dla GDA.
282
283 %package provider-postgres
284 Summary:        GDA PostgreSQL provider
285 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description provider-postgres
290 This package contains the GDA PostgreSQL provider.
291
292 %description provider-postgres -l pl.UTF-8
293 Pakiet dostarczający dane z PostgreSQL dla GDA.
294
295 %package provider-sqlcipher
296 Summary:        GDA SQLCipher provider
297 Summary(pl.UTF-8):      Źródło danych SQLCipher dla GDA
298 Group:          Libraries
299 Requires:       %{name} = %{version}-%{release}
300
301 %description provider-sqlcipher
302 This package contains the GDA SQLCipher provider.
303
304 %description provider-sqlcipher -l pl.UTF-8
305 Pakiet dostarczający dane z SQLCipher dla GDA.
306
307 %package provider-sqlite
308 Summary:        GDA SQLite provider
309 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
310 Group:          Libraries
311 Requires:       %{name} = %{version}-%{release}
312
313 %description provider-sqlite
314 This package contains the GDA SQLite provider.
315
316 %description provider-sqlite -l pl.UTF-8
317 Pakiet dostarczający dane z SQLite dla GDA.
318
319 %package provider-web
320 Summary:        GDA Web provider
321 Summary(pl.UTF-8):      Źródło danych Web dla GDA
322 Group:          Libraries
323 Requires:       %{name} = %{version}-%{release}
324
325 %description provider-web
326 This package contains the GDA Web provider.
327
328 %description provider-web -l pl.UTF-8
329 Pakiet dostarczający dane z Web dla GDA.
330
331 %package tools
332 Summary:        Graphical tools for GDA
333 Summary(pl.UTF-8):      Narzędzia graficzne dla GDA
334 Group:          X11/Applications
335 Requires:       gtk-update-icon-cache
336 Requires:       hicolor-icon-theme
337 Requires:       %{name}-ui = %{version}-%{release}
338
339 %description tools
340 Graphical tools for GDA.
341
342 %description tools -l pl.UTF-8
343 Narzędzia graficzne dla GDA.
344
345 %prep
346 %setup -q -n libgda-%{version}
347 %patch0 -p1
348 %patch1 -p1
349 %patch2 -p1
350
351 %{__sed} -i -e 's/libvala-0.14 >= 0.14/libvala-%{vala_ver}/' configure.ac
352
353 %build
354 # included version is bash-specific, use system file
355 cp -f %{_aclocaldir}/introspection.m4 m4/introspection.m4
356 %if %{with jdbc}
357 export JAVA_HOME="%{java_home}"
358 %endif
359 %{__gtkdocize}
360 %{__intltoolize}
361 %{__libtoolize}
362 %{__aclocal} -I m4
363 %{__autoconf}
364 %{__automake}
365 %configure \
366         --disable-default-binary \
367         --disable-silent-rules \
368         %{!?with_static_libs:--disable-static} \
369         %{!?with_vala:--disable-vala} \
370         --enable-system-sqlite \
371         --enable-gtk-doc%{!?with_apidocs:=no} \
372         --with-html-dir=%{_gtkdocdir} \
373         --with-bdb=/usr \
374         --with-bdb-libdir-name=%{_lib} \
375         --with-java%{!?with_jdbc:=no} \
376         --with-mdb%{!?with_mdb:=no} \
377         --with-mysql%{!?with_mysql:=no} \
378         --with-oracle%{!?with_oci:=no} \
379         --with-postgres%{!?with_pgsql:=no}
380
381 %{__make} -j1
382
383 %install
384 rm -rf $RPM_BUILD_ROOT
385
386 %{__make} install \
387         DESTDIR=$RPM_BUILD_ROOT \
388         VALA_VAPIDIR=%{_datadir}/vala/vapi
389
390 # modules dlopened by *.so through libgmodule
391 %{__rm} $RPM_BUILD_ROOT%{providersdir}/*.{a,la}
392 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{libgdadir}/plugins/*.{a,la}
393
394 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
395
396 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
397
398 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{sr@Latn,sr@latin}
399
400 %py_comp $RPM_BUILD_ROOT%{_datadir}/libgda-4.0/gda_trml2html
401 %py_comp $RPM_BUILD_ROOT%{_datadir}/libgda-4.0/gda_trml2pdf
402 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/libgda-4.0/gda_trml2html
403 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/libgda-4.0/gda_trml2pdf
404
405 %find_lang libgda-4.0
406 %find_lang gda-browser --with-gnome
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post   -p /sbin/ldconfig
412 %postun -p /sbin/ldconfig
413
414 %post tools
415 %update_icon_cache hicolor
416
417 %postun tools
418 %update_icon_cache hicolor
419
420 %files -f libgda-4.0.lang
421 %defattr(644,root,root,755)
422 %doc AUTHORS ChangeLog NEWS README
423 %attr(755,root,root) %{_bindir}/gda-list-config-4.0
424 %attr(755,root,root) %{_bindir}/gda-list-server-op-4.0
425 %attr(755,root,root) %{_bindir}/gda-sql-4.0
426 %attr(755,root,root) %{_bindir}/gda-test-connection-4.0
427 %attr(755,root,root) %{_libdir}/libgda-4.0.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libgda-4.0.so.4
429 %attr(755,root,root) %{_libdir}/libgda-report-4.0.so.*.*.*
430 %attr(755,root,root) %ghost %{_libdir}/libgda-report-4.0.so.4
431 %attr(755,root,root) %{_libdir}/libgda-xslt-4.0.so.*.*.*
432 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-4.0.so.4
433 %{_libdir}/girepository-1.0/Gda-4.0.typelib
434 %dir %{_libdir}/%{libgdadir}
435 %dir %{providersdir}
436 %dir %{_datadir}/libgda-4.0
437 %{_datadir}/libgda-4.0/demo
438 %{_datadir}/libgda-4.0/dtd
439 %{_datadir}/libgda-4.0/icons
440 %{_datadir}/libgda-4.0/pixmaps
441 %{_datadir}/libgda-4.0/import_encodings.xml
442 %{_datadir}/libgda-4.0/information_schema.xml
443 %{_datadir}/libgda-4.0/language-specs
444 %{_datadir}/libgda-4.0/server_operation.glade
445 # used by libgda-report
446 %{_datadir}/libgda-4.0/gda_trml2html
447 %{_datadir}/libgda-4.0/gda_trml2pdf
448 %dir %{_sysconfdir}/libgda-4.0
449 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-4.0/config
450 %{_sysconfdir}/libgda-4.0/sales_test.db
451 %{_mandir}/man1/gda-sql-4.0.1*
452
453 %files devel
454 %defattr(644,root,root,755)
455 %attr(755,root,root) %{_libdir}/libgda-4.0.so
456 %attr(755,root,root) %{_libdir}/libgda-report-4.0.so
457 %attr(755,root,root) %{_libdir}/libgda-xslt-4.0.so
458 %{_datadir}/gir-1.0/Gda-4.0.gir
459 %{_includedir}/libgda-4.0
460 %{_pkgconfigdir}/libgda-4.0.pc
461 %{_pkgconfigdir}/libgda-bdb-4.0.pc
462 %{?with_dbsql:%{_pkgconfigdir}/libgda-bdbsql-4.0.pc}
463 %{?with_jdbc:%{_pkgconfigdir}/libgda-jdbc-4.0.pc}
464 %{?with_ldap:%{_pkgconfigdir}/libgda-ldap-4.0.pc}
465 %{?with_mdb:%{_pkgconfigdir}/libgda-mdb-4.0.pc}
466 %{?with_mysql:%{_pkgconfigdir}/libgda-mysql-4.0.pc}
467 %{?with_oci:%{_pkgconfigdir}/libgda-oracle-4.0.pc}
468 %{?with_pgsql:%{_pkgconfigdir}/libgda-postgres-4.0.pc}
469 %{_pkgconfigdir}/libgda-report-4.0.pc
470 %{_pkgconfigdir}/libgda-sqlcipher-4.0.pc
471 %{_pkgconfigdir}/libgda-sqlite-4.0.pc
472 %{_pkgconfigdir}/libgda-xslt-4.0.pc
473 %{_pkgconfigdir}/libgda-web-4.0.pc
474
475 %if %{with static_libs}
476 %files static
477 %defattr(644,root,root,755)
478 %{_libdir}/libgda-4.0.a
479 %{_libdir}/libgda-report-4.0.a
480 %{_libdir}/libgda-xslt-4.0.a
481 %endif
482
483 %if %{with vala}
484 %files -n vala-libgda4
485 %defattr(644,root,root,755)
486 %{_datadir}/vala/vapi/libgda-4.0.vapi
487 %endif
488
489 %files ui
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_bindir}/gdaui-demo-4.0
492 %attr(755,root,root) %{_libdir}/libgda-ui-4.0.so.*.*.*
493 %attr(755,root,root) %ghost %{_libdir}/libgda-ui-4.0.so.4
494 %attr(755,root,root) %{_libdir}/%{libgdadir}/plugins/libgda-ui-plugins.so
495 %dir %{_libdir}/%{libgdadir}/plugins
496 %{_libdir}/%{libgdadir}/plugins/gdaui-*.xml
497 %{_libdir}/girepository-1.0/Gdaui-4.0.typelib
498 %{_datadir}/libgda-4.0/ui
499
500 %files ui-devel
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_libdir}/libgda-ui-4.0.so
503 %{_datadir}/gir-1.0/Gdaui-4.0.gir
504 %{_pkgconfigdir}/libgda-ui-4.0.pc
505
506 %if %{with static_libs}
507 %files ui-static
508 %defattr(644,root,root,755)
509 %{_libdir}/libgda-ui-4.0.a
510 %endif
511
512 %if %{with apidocs}
513 %files apidocs
514 %defattr(644,root,root,755)
515 %{_gtkdocdir}/gda-browser
516 %{_gtkdocdir}/libgda-4.0
517 %endif
518
519 %files provider-db
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{providersdir}/libgda-bdb.so
522 %{_datadir}/libgda-4.0/bdb_specs_*.xml
523
524 %if %{with dbsql}
525 %files provider-dbsql
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_libdir}/libgda-4.0/providers/libgda-bdbsql.so
528 %{_datadir}/libgda-4.0/bdbsql_specs_*.xml
529 %endif
530
531 %if %{with jdbc}
532 %files provider-jdbc
533 %defattr(644,root,root,755)
534 %attr(755,root,root) %{_bindir}/gda-list-jdbc-providers-4.0
535 %attr(755,root,root) %{providersdir}/libgda-jdbc.so
536 %{providersdir}/gdaprovider-4.0.jar
537 %{_datadir}/libgda-4.0/jdbc_specs_*.xml
538 %endif
539
540 %if %{with ldap}
541 %files provider-ldap
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{providersdir}/libgda-ldap.so
544 %{_datadir}/libgda-4.0/ldap_specs_*.xml
545 %endif
546
547 %if %{with mdb}
548 %files provider-mdb
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{providersdir}/libgda-mdb.so
551 %{_datadir}/libgda-4.0/mdb_specs_*.xml
552 %endif
553
554 %if %{with mysql}
555 %files provider-mysql
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{providersdir}/libgda-mysql.so
558 %{_datadir}/libgda-4.0/mysql_specs_*.xml
559 %endif
560
561 %if %{with oci}
562 %files provider-oracle
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_libdir}/libgda-4.0/providers/libgda-oracle.so
565 %{_datadir}/libgda-4.0/oracle_specs_*.xml
566 %endif
567
568 %if %{with pgsql}
569 %files provider-postgres
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{providersdir}/libgda-postgres.so
572 %{_datadir}/libgda-4.0/postgres_specs_*.xml
573 %endif
574
575 %files provider-sqlcipher
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{providersdir}/libgda-sqlcipher.so
578 %{_datadir}/libgda-4.0/sqlcipher_specs_*.xml
579
580 %files provider-sqlite
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{providersdir}/libgda-sqlite.so
583 %{_datadir}/libgda-4.0/sqlite_specs_*.xml
584
585 %files provider-web
586 %defattr(644,root,root,755)
587 %doc providers/web/README
588 %attr(755,root,root) %{providersdir}/libgda-web.so
589 %{_datadir}/libgda-4.0/php
590 %{_datadir}/libgda-4.0/web
591 %{_datadir}/libgda-4.0/web_specs_*.xml
592
593 %files tools -f gda-browser.lang
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_bindir}/gda-browser-4.0
596 %attr(755,root,root) %{_bindir}/gda-control-center-4.0
597 %{_desktopdir}/gda-browser-4.0.desktop
598 %{_desktopdir}/gda-control-center-4.0.desktop
599 %{_pixmapsdir}/gda-browser-4.0.png
600 %{_iconsdir}/hicolor/*/apps/gda-control-center.png
This page took 0.144277 seconds and 2 git commands to generate.