]> git.pld-linux.org Git - packages/libgav1.git/blob - libgav1.spec
- up to 0.17.0, absl wants -std=c++11 aka cxx17 standard
[packages/libgav1.git] / libgav1.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # tests building
4
5 Summary:        AV1 decoder library (10-bit)
6 Summary(pl.UTF-8):      Biblioteka dekodera AV1 (10-bitowego)
7 Name:           libgav1
8 Version:        0.17.0
9 %define gitref  ac9e35a6a5030fc8f26dcfde24ec8bc19ac12a94
10 Release:        1
11 License:        Apache v2.0
12 Group:          Libraries
13 #Source0Download: https://chromium.googlesource.com/codecs/libgav1
14 #Source0:       https://chromium.googlesource.com/codecs/libgav1/+archive/%{gitref}.tar.gz?/%{name}-%{version}.tar.gz
15 # tarball is recreated on each download, so upload via dropin
16 Source0:        %{name}-%{version}.tar.gz
17 # Source0-md5:  b4eca44acc66970b90a0465240c0d51f
18 Patch0:         %{name}-system-libs.patch
19 Patch1:         cxx17.patch
20 URL:            https://chromium.googlesource.com/codecs/libgav1
21 BuildRequires:  abseil-cpp-devel
22 BuildRequires:  cmake >= 3.7.1
23 BuildRequires:  gtest-devel
24 BuildRequires:  libstdc++-devel >= 6:5
25 BuildRequires:  rpmbuild(macros) >= 1.605
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libgav1 is a Main profile (0) & High profile (1) compliant AV1
30 decoder.
31
32 %description -l pl.UTF-8
33 libgav1 to dekoder AV1 zgodny z profilami Main (0) i High (1).
34
35 %package devel
36 Summary:        Header files for libgav1 library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgav1
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       libstdc++-devel >= 6:5
41
42 %description devel
43 Header files for libgav1 library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki libgav1.
47
48 %package static
49 Summary:        Static libgav1 library
50 Summary(pl.UTF-8):      Statyczna biblioteka libgav1
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static libgav1 library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libgav1.
59
60 %prep
61 %setup -q -c
62 %patch0 -p1
63 %patch1 -p1
64
65 %build
66 install -d build
67 cd build
68 %cmake .. \
69         -DCMAKE_INSTALL_BINDIR=bin \
70         -DCMAKE_INSTALL_DATAROOTDIR=share \
71         -DCMAKE_INSTALL_INCLUDEDIR=include \
72         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
73         %{!?with_tests:-DLIBGAV1_ENABLE_TESTS=OFF}
74
75 %{__make}
76
77 %if %{with tests}
78 # how to execute all automatically?
79 for f in $(echo ./*_test) ; do
80         $f
81 done
82 %endif
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} -C build install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc AUTHORS README.md
99 %attr(755,root,root) %{_bindir}/gav1_decode
100 %attr(755,root,root) %{_libdir}/libgav1.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libgav1.so.0
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libgav1.so
106 %{_includedir}/gav1
107 %{_pkgconfigdir}/libgav1.pc
108 %{_datadir}/cmake/libgav1-config.cmake
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/libgav1.a
This page took 0.056017 seconds and 3 git commands to generate.