]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
6d3ce692372ee73172874460f40e60d3ea71572c
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 %define         libver  34
8 #
9 Summary:        Library for high-performing platform-independent programs
10 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
11 Name:           libfilezilla
12 Version:        0.41.0
13 Release:        1
14 License:        GPL v2+
15 Group:          Libraries
16 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
17 # Source0-md5:  086b98901658f9f0a379254201a222f2
18 URL:            https://lib.filezilla-project.org/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  gettext-tools >= 0.11.0
24 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
25 BuildRequires:  glibc-localedb-all
26 %endif
27 BuildRequires:  gmp-devel
28 BuildRequires:  gnutls-devel >= 3.7.0
29 # -std=c++17
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  nettle-devel >= 3.3
33 BuildRequires:  pkgconfig >= 1:0.7
34 BuildRequires:  rpmbuild(macros) >= 1.583
35 Requires:       gnutls-libs >= 3.7.0
36 Requires:       nettle >= 3.3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 libfilezilla is a free, open source C++ library, offering some basic
41 functionality to build high-performing, platform-independent programs.
42 Some of the highlights include:
43
44 - A typesafe, multi-threaded event system that's very simple to use
45   yet extremely efficient
46 - Timers for periodic events
47 - A datetime class that not only tracks timestamp but also their
48   accuracy, which simplifies dealing with timestamps originating from
49   different sources
50 - Simple process handling for spawning child processes with redirected
51   I/O
52
53 %description -l pl.UTF-8
54 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
55 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
56 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
57 - bezpieczny pod względem typów, wielowątkowy system zdarzeń - bardzo
58   prosty w użyciu, a jednocześnie bardzo wydajny
59 - zegary do zdarzeń regularnych
60 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
61   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
62   różnych źródeł
63 - prostą obsługę procesów do tworzenia procesów potomnych z
64   przekierowanym wejściem/wyjściem
65
66 %package devel
67 Summary:        Header files for libfilezilla library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       gnutls-devel >= 3.7.0
72 Requires:       libstdc++-devel >= 6:7
73 Requires:       nettle-devel >= 3.3
74
75 %description devel
76 Header files for libfilezilla library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki libfilezilla.
80
81 %package static
82 Summary:        Static libfilezilla library
83 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86
87 %description static
88 Static libfilezilla library.
89
90 %description static -l pl.UTF-8
91 Statyczna biblioteka libfilezilla.
92
93 %package apidocs
94 Summary:        %{name} API documentation
95 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
96 Group:          Documentation
97
98 %description apidocs
99 API documentation for %{name} library.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API biblioteki %{name}.
103
104 %prep
105 %setup -q
106
107 cd locales
108 %{__mv} bg{_BG,}.po
109 %{__mv} ca{_ES,}@valencia.po
110 %{__mv} cs{_CZ,}.po
111 %{__mv} fa{_IR,}.po
112 %{__mv} fi{_FI,}.po
113 %{__mv} gl{_ES,}.po
114 %{__mv} he{_IL,}.po
115 %{__mv} hu{_HU,}.po
116 %{__mv} id{_ID,}.po
117 %{__mv} ja{_JP,}.po
118 %{__mv} ko{_KR,}.po
119 %{__mv} lo{_LA,}.po
120 %{__mv} lt{_LT,}.po
121 %{__mv} lv{_LV,}.po
122 %{__mv} mk{_MK,}.po
123 %{__mv} nb{_NO,}.po
124 %{__mv} nn{_NO,}.po
125 %{__mv} pl{_PL,}.po
126 %{__mv} pt{_PT,}.po
127 %{__mv} ro{_RO,}.po
128 %{__mv} sk{_SK,}.po
129 %{__mv} sl{_SI,}.po
130 %{__mv} th{_TH,}.po
131 %{__mv} uk{_UA,}.po
132 %{__mv} vi{_VN,}.po
133
134 %build
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         %{!?with_static_libs:--disable-static}
142 %{__make}
143
144 %if %{with tests}
145 # wide char conversion test fails with plain C locale
146 LC_ALL=C.UTF-8 \
147 %{__make} check
148 %endif
149
150 %if %{with apidocs}
151 %{__make} -C doc html
152 %endif
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
161
162 # not supported by glibc (as of 2.25)
163 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
164
165 %find_lang %{name}
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc AUTHORS ChangeLog NEWS README
176 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.%{libver}
178
179 %files devel
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libfilezilla.so
182 %{_includedir}/libfilezilla
183 %{_pkgconfigdir}/libfilezilla.pc
184
185 %if %{with static_libs}
186 %files static
187 %defattr(644,root,root,755)
188 %{_libdir}/libfilezilla.a
189 %endif
190
191 %if %{with apidocs}
192 %files apidocs
193 %defattr(644,root,root,755)
194 %doc doc/doxygen-doc/html/*
195 %endif
This page took 0.063524 seconds and 2 git commands to generate.