]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
0047c13280636c17928de10a5eeb8683bdc792cf
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 %define         libver  22
8 #
9 Summary:        Library for high-performing platform-independent programs
10 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
11 Name:           libfilezilla
12 Version:        0.34.2
13 Release:        1
14 License:        GPL v2+
15 Group:          Libraries
16 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
17 # Source0-md5:  c5cbaafcbf0fb307e30a59cb38a4b98d
18 URL:            https://lib.filezilla-project.org/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  gettext-tools >= 0.11.0
24 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
25 BuildRequires:  glibc-localedb-all
26 %endif
27 BuildRequires:  gnutls-devel >= 3.5.8
28 # -std=c++17
29 BuildRequires:  libstdc++-devel >= 6:7
30 BuildRequires:  libtool >= 2:2
31 BuildRequires:  nettle-devel >= 3.3
32 BuildRequires:  pkgconfig >= 1:0.7
33 BuildRequires:  rpmbuild(macros) >= 1.583
34 Requires:       gnutls-libs >= 3.5.8
35 Requires:       nettle >= 3.3
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 libfilezilla is a free, open source C++ library, offering some basic
40 functionality to build high-performing, platform-independent programs.
41 Some of the highlights include:
42
43 - A typesafe, multi-threaded event system that's very simple to use
44   yet extremely efficient
45 - Timers for periodic events
46 - A datetime class that not only tracks timestamp but also their
47   accuracy, which simplifies dealing with timestamps originating from
48   different sources
49 - Simple process handling for spawning child processes with redirected
50   I/O
51
52 %description -l pl.UTF-8
53 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
54 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
55 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
56 - bezpieczny pod względem typów, wielowątkowy system zdarzeń - bardzo
57   prosty w użyciu, a jednocześnie bardzo wydajny
58 - zegary do zdarzeń regularnych
59 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
60   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
61   różnych źródeł
62 - prostą obsługę procesów do tworzenia procesów potomnych z
63   przekierowanym wejściem/wyjściem
64
65 %package devel
66 Summary:        Header files for libfilezilla library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       gnutls-devel >= 3.5.8
71 Requires:       libstdc++-devel >= 6:7
72 Requires:       nettle-devel >= 3.3
73
74 %description devel
75 Header files for libfilezilla library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki libfilezilla.
79
80 %package static
81 Summary:        Static libfilezilla library
82 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static libfilezilla library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka libfilezilla.
91
92 %package apidocs
93 Summary:        %{name} API documentation
94 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
95 Group:          Documentation
96
97 %description apidocs
98 API documentation for %{name} library.
99
100 %description apidocs -l pl.UTF-8
101 Dokumentacja API biblioteki %{name}.
102
103 %prep
104 %setup -q
105
106 cd locales
107 %{__mv} bg{_BG,}.po
108 %{__mv} ca{_ES,}@valencia.po
109 %{__mv} cs{_CZ,}.po
110 %{__mv} fa{_IR,}.po
111 %{__mv} fi{_FI,}.po
112 %{__mv} gl{_ES,}.po
113 %{__mv} he{_IL,}.po
114 %{__mv} hu{_HU,}.po
115 %{__mv} id{_ID,}.po
116 %{__mv} ja{_JP,}.po
117 %{__mv} ko{_KR,}.po
118 %{__mv} lo{_LA,}.po
119 %{__mv} lt{_LT,}.po
120 %{__mv} lv{_LV,}.po
121 %{__mv} mk{_MK,}.po
122 %{__mv} nb{_NO,}.po
123 %{__mv} nn{_NO,}.po
124 %{__mv} pl{_PL,}.po
125 %{__mv} pt{_PT,}.po
126 %{__mv} ro{_RO,}.po
127 %{__mv} sk{_SK,}.po
128 %{__mv} sl{_SI,}.po
129 %{__mv} th{_TH,}.po
130 %{__mv} uk{_UA,}.po
131 %{__mv} vi{_VN,}.po
132
133 %build
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139 %configure \
140         %{!?with_static_libs:--disable-static}
141 %{__make}
142
143 %if %{with tests}
144 # wide char conversion test fails with plain C locale
145 LC_ALL=C.UTF-8 \
146 %{__make} check
147 %endif
148
149 %if %{with apidocs}
150 %{__make} -C doc html
151 %endif
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
160
161 # not supported by glibc (as of 2.25)
162 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
163
164 %find_lang %{name}
165
166 %clean
167 rm -rf $RPM_BUILD_ROOT
168
169 %post   -p /sbin/ldconfig
170 %postun -p /sbin/ldconfig
171
172 %files -f %{name}.lang
173 %defattr(644,root,root,755)
174 %doc AUTHORS ChangeLog NEWS README
175 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
176 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.%{libver}
177
178 %files devel
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{_libdir}/libfilezilla.so
181 %{_includedir}/libfilezilla
182 %{_pkgconfigdir}/libfilezilla.pc
183
184 %if %{with static_libs}
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libfilezilla.a
188 %endif
189
190 %if %{with apidocs}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %doc doc/doxygen-doc/html/*
194 %endif
This page took 0.0743 seconds and 2 git commands to generate.