]> git.pld-linux.org Git - packages/libfastjson.git/blob - libfastjson.spec
a0ce716bd5cd4e85571046e24b424d4af102f74c
[packages/libfastjson.git] / libfastjson.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        A JSON implementation in C
6 Name:           libfastjson
7 Version:        0.99.8
8 Release:        1
9 License:        MIT
10 Group:          Libraries
11 Source0:        http://download.rsyslog.com/libfastjson/%{name}-%{version}.tar.gz
12 # Source0-md5:  fe7b4eae1bf40499f6f92b51d7e5899e
13 URL:            https://github.com/rsyslog/libfastjson
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 LIBFASTJSON implements a reference counting object model that allows
18 you to easily construct JSON objects in C, output them as JSON
19 formatted strings and parse JSON formatted strings back into the C
20 representation of JSON objects.
21
22 %package devel
23 Summary:        Header files for %{name} library
24 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27
28 %description devel
29 Header files for %{name} library.
30
31 %description devel -l pl.UTF-8
32 Pliki nagłówkowe biblioteki %{name}.
33
34 %package static
35 Summary:        Static %{name} library
36 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
37 Group:          Development/Libraries
38 Requires:       %{name}-devel = %{version}-%{release}
39
40 %description static
41 Static %{name} library.
42
43 %description static -l pl.UTF-8
44 Statyczna biblioteka %{name}.
45
46 %prep
47 %setup -q
48
49 %build
50 %configure \
51         %{!?with_static_libs:--disable-static}
52 %{__make} V=1
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS README
71 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.4
73
74 %files devel
75 %defattr(644,root,root,755)
76 %doc ChangeLog NEWS
77 %attr(755,root,root) %{_libdir}/%{name}.so
78 %{_includedir}/%{name}
79 %{_pkgconfigdir}/%{name}.pc
80
81 %if %{with static_libs}
82 %files static
83 %defattr(644,root,root,755)
84 %{_libdir}/%{name}.a
85 %endif
This page took 0.045551 seconds and 2 git commands to generate.