]> git.pld-linux.org Git - packages/libfabric.git/blob - libfabric.spec
- updated to 1.2.0
[packages/libfabric.git] / libfabric.spec
1 # TODO: proprietary providers (cray/gni, mxm)
2 #
3 # Conditional build:
4 %bcond_with     psm     # infinipath-psm provider
5 #
6 %ifnarch %{ix86} %{x8664}
7 %undefine       with_psm
8 %endif
9 Summary:        User-space RDMA Fabric interface library
10 Summary(pl.UTF-8):      Biblioteka interfejsu przestrzeni użytkownika RDMA Fabric
11 Name:           libfabric
12 Version:        1.2.0
13 Release:        1
14 License:        BSD or GPL v2
15 Group:          Libraries
16 Source0:        https://www.openfabrics.org/downloads/ofi/%{name}-%{version}.tar.bz2
17 # Source0-md5:  e4ccb6b3abc1a9c13e9ad066e6c14dc3
18 Patch0:         %{name}-sh.patch
19 URL:            https://github.com/ofiwg/libfabric
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake >= 1:1.11
22 %{?with_psm:BuildRequires:      infinipath-psm-devel >= 3.1}
23 BuildRequires:  libibverbs-devel
24 BuildRequires:  libnl-devel >= 3.2
25 BuildRequires:  librdmacm-devel
26 BuildRequires:  libtool >= 2:2
27 Conflicts:      fabtests < 1.1.1
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libfabric provides a user-space API to access high-performance fabric
32 services, such as RDMA.
33
34 %description -l pl.UTF-8
35 libfabric dostarcza API przestrzeni użytkownika pozwalające na dostęp
36 do wysoko wydajnych usług sieci typu fabric, takich jak RDMA.
37
38 %package devel
39 Summary:        Development files for libfabric library
40 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libfabric
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       libibverbs-devel
44 Requires:       libnl-devel >= 3.2
45 Requires:       librdmacm-devel
46
47 %description devel
48 Header files for libfabric library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki libfabric.
52
53 %package static
54 Summary:        Static libfabric library
55 Summary(pl.UTF-8):      Statyczna biblioteka libfabric
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static libfabric library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libfabric.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 %{__libtoolize}
71 %{__aclocal} -I config
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         %{!?with_psm:--disable-psm} \
77         --disable-silent-rules
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # obsoleted by pkg-config
87 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libfabric.la
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS COPYING README
98 %attr(755,root,root) %{_bindir}/fi_info
99 %attr(755,root,root) %{_libdir}/libfabric.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libfabric.so.1
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libfabric.so
105 %{_includedir}/rdma/fabric.h
106 %{_includedir}/rdma/fi_*.h
107 %{_pkgconfigdir}/libfabric.pc
108 %{_mandir}/man3/fi_*.3*
109 %{_mandir}/man7/fabric.7*
110 %{_mandir}/man7/fi_*.7*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libfabric.a
This page took 0.083198 seconds and 3 git commands to generate.