]> git.pld-linux.org Git - packages/libewf.git/blob - libewf.spec
- updated to 20230212
[packages/libewf.git] / libewf.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # Python bindings (any)
4 %bcond_without  python2 # CPython 2.x bindings
5 %bcond_without  python3 # CPython 3.x bindings
6 #
7 %if %{without python}
8 %undefine       with_python2
9 %undefine       with_python3
10 %endif
11 # see m4/${libname}.m4 />= for required version of particular library
12 %define         libbfio_ver             20201125
13 %define         libcaes_ver             20220529
14 %define         libcdata_ver            20230108
15 %define         libcdatetime_ver        20141018
16 %define         libcerror_ver           20120425
17 %define         libcfile_ver            20160409
18 %define         libclocale_ver          20120425
19 %define         libcnotify_ver          20120425
20 %define         libcpath_ver            20180716
21 %define         libcsplit_ver           20120701
22 %define         libcthreads_ver         20160404
23 %define         libfcache_ver           20191109
24 %define         libfdata_ver            20201129
25 %define         libfdatetime_ver        20180910
26 %define         libfguid_ver            20120426
27 %define         libfvalue_ver           20200711
28 %define         libhmac_ver             20200104
29 %define         libodraw_ver            20120630
30 %define         libsmdev_ver            20140406
31 %define         libsmraw_ver            20120630
32 %define         libuna_ver              20210801
33 Summary:        Library to support the Expert Witness Compression Format
34 Summary(pl.UTF-8):      Biblioteka obsługująca format Expert Witness Compression Format
35 Name:           libewf
36 Version:        20230212
37 Release:        1
38 License:        LGPL v3+
39 Group:          Libraries
40 #Source0Download: https://github.com/libyal/libewf/releases
41 Source0:        https://github.com/libyal/libewf/releases/download/%{version}/%{name}-experimental-%{version}.tar.gz
42 # Source0-md5:  a3f85c4cefc0b760858ea357093b63a2
43 URL:            https://github.com/libyal/libewf/
44 BuildRequires:  autoconf >= 2.71
45 BuildRequires:  automake >= 1.6
46 BuildRequires:  bzip2-devel >= 1.0
47 BuildRequires:  gettext-tools >= 0.21
48 BuildRequires:  libbfio-devel >= %{libbfio_ver}
49 BuildRequires:  libcaes-devel >= %{libcaes_ver}
50 BuildRequires:  libcdata-devel >= %{libcdata_ver}
51 BuildRequires:  libcdatetime-devel >= %{libcdatetime_ver}
52 BuildRequires:  libcerror-devel >= %{libcerror_ver}
53 BuildRequires:  libcfile-devel >= %{libcfile_ver}
54 BuildRequires:  libclocale-devel >= %{libclocale_ver}
55 BuildRequires:  libcnotify-devel >= %{libcnotify_ver}
56 BuildRequires:  libcpath-devel >= %{libcpath_ver}
57 BuildRequires:  libcsplit-devel >= %{libcsplit_ver}
58 BuildRequires:  libcthreads-devel >= %{libcthreads_ver}
59 BuildRequires:  libfcache-devel >= %{libfcache_ver}
60 BuildRequires:  libfdata-devel >= %{libfdata_ver}
61 BuildRequires:  libfdatetime-devel >= %{libfdatetime_ver}
62 BuildRequires:  libfguid-devel >= %{libfguid_ver}
63 BuildRequires:  libfuse-devel >= 2.6
64 BuildRequires:  libfvalue-devel >= %{libfvalue_ver}
65 BuildRequires:  libhmac-devel >= %{libhmac_ver}
66 BuildRequires:  libodraw-devel >= %{libodraw_ver}
67 BuildRequires:  libsmdev-devel >= %{libsmdev_ver}
68 BuildRequires:  libsmraw-devel >= %{libsmraw_ver}
69 BuildRequires:  libuna-devel >= %{libuna_ver}
70 BuildRequires:  libtool >= 2:2
71 BuildRequires:  libuuid-devel >= 2.20
72 BuildRequires:  openssl-devel >= 1.0
73 %{?with_python2:BuildRequires:  python-devel >= 1:2.5}
74 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
75 BuildRequires:  zlib-devel >= 1.2.5
76 Requires:       bzip2 >= 1.0
77 Requires:       libbfio >= %{libbfio_ver}
78 Requires:       libcaes >= %{libcaes_ver}
79 Requires:       libcdata >= %{libcdata_ver}
80 Requires:       libcerror >= %{libcerror_ver}
81 Requires:       libcfile >= %{libcfile_ver}
82 Requires:       libclocale >= %{libclocale_ver}
83 Requires:       libcnotify >= %{libcnotify_ver}
84 Requires:       libcpath >= %{libcpath_ver}
85 Requires:       libcsplit >= %{libcsplit_ver}
86 Requires:       libcthreads >= %{libcthreads_ver}
87 Requires:       libfcache >= %{libfcache_ver}
88 Requires:       libfdata >= %{libfdata_ver}
89 Requires:       libfdatetime >= %{libfdatetime_ver}
90 Requires:       libfguid >= %{libfguid_ver}
91 Requires:       libfvalue >= %{libfvalue_ver}
92 Requires:       libhmac >= %{libhmac_ver}
93 Requires:       libuna >= %{libuna_ver}
94 Requires:       zlib >= 1.2.5
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %description
98 libewf is a library for support of the Expert Witness Compression
99 Format (EWF). It allows you to read media information of EWF files in
100 the SMART (EWF-S01) format and the EnCase (EWF-E01) format, and to
101 read files created by EnCase 1 to 6, linen and FTK Imager.
102
103 %description -l pl.UTF-8
104 libewf to biblioteka obsługująca format kompresji EWF (Expert Witness
105 Compression Format). Pozwala odczytywać informacje z plików EWF w
106 formacie SMART (EWF-S01) i EnCase (EWF-E01) oraz czytać pliki
107 utworzone przez EnCase w wersji 1 do 6, linen i FTK Imager.
108
109 %package devel
110 Summary:        Header files for libewf library
111 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libewf
112 Group:          Development/Libraries
113 Requires:       %{name} = %{version}-%{release}
114 Requires:       bzip2-devel >= 1.0
115 Requires:       libbfio-devel >= %{libbfio_ver}
116 Requires:       libcaes-devel >= %{libcaes_ver}
117 Requires:       libcdata-devel >= %{libcdata_ver}
118 Requires:       libcerror-devel >= %{libcerror_ver}
119 Requires:       libcfile-devel >= %{libcfile_ver}
120 Requires:       libclocale-devel >= %{libclocale_ver}
121 Requires:       libcnotify-devel >= %{libcnotify_ver}
122 Requires:       libcpath-devel >= %{libcpath_ver}
123 Requires:       libcsplit-devel >= %{libcsplit_ver}
124 Requires:       libcthreads-devel >= %{libcthreads_ver}
125 Requires:       libfcache-devel >= %{libfcache_ver}
126 Requires:       libfdata-devel >= %{libfdata_ver}
127 Requires:       libfdatetime-devel >= %{libfdatetime_ver}
128 Requires:       libfguid-devel >= %{libfguid_ver}
129 Requires:       libfvalue-devel >= %{libfvalue_ver}
130 Requires:       libhmac-devel >= %{libhmac_ver}
131 Requires:       libuna-devel >= %{libuna_ver}
132 Requires:       openssl-devel >= 1.0
133 Requires:       zlib-devel >= 1.2.5
134
135 %description devel
136 Header files for libewf library.
137
138 %description devel -l pl.UTF-8
139 Pliki nagłówkowe biblioteki libewf.
140
141 %package static
142 Summary:        Static libewf library
143 Summary(pl.UTF-8):      Statyczna biblioteka libewf
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}-%{release}
146
147 %description static
148 Static libewf library.
149
150 %description static -l pl.UTF-8
151 Statyczna biblioteka libewf.
152
153 %package tools
154 Summary:        Tools to support the Expert Witness Compression Format
155 Summary(pl.UTF-8):      Narzędzia obsługujące format Expert Witness Compression Format
156 Group:          Applications/File
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       libcdatetime >= %{libcdatetime_ver}
159 Requires:       libfuse >= 2.6
160 Requires:       libodraw >= %{libodraw_ver}
161 Requires:       libsmdev >= %{libsmdev_ver}
162 Requires:       libsmraw >= %{libsmraw_ver}
163 Requires:       libuuid >= 2.20
164
165 %description tools
166 Tools to support the Expert Witness Compression Format.
167
168 %description tools -l pl.UTF-8
169 Narzędzia obsługujące format Expert Witness Compression Format.
170
171 %package -n python-pyewf
172 Summary:        Python 2 bindings for libewf library
173 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki libewf
174 Group:          Libraries/Python
175 Requires:       %{name} = %{version}-%{release}
176
177 %description -n python-pyewf
178 Python 2 bindings for libewf library.
179
180 %description -n python-pyewf -l pl.UTF-8
181 Wiązania Pythona 2 do biblioteki libewf.
182
183 %package -n python3-pyewf
184 Summary:        Python 3 bindings for libewf library
185 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki libewf
186 Group:          Libraries/Python
187 Requires:       %{name} = %{version}-%{release}
188
189 %description -n python3-pyewf
190 Python 3 bindings for libewf library.
191
192 %description -n python3-pyewf -l pl.UTF-8
193 Wiązania Pythona 3 do biblioteki libewf.
194
195 %prep
196 %setup -q
197
198 %build
199 %{__gettextize}
200 %{__libtoolize}
201 %{__aclocal}
202 %{__autoconf}
203 %{__autoheader}
204 %{__automake}
205 %configure \
206         %{?with_python2:--enable-python2} \
207         %{?with_python3:--enable-python3}
208 %{__make}
209
210 %install
211 rm -rf $RPM_BUILD_ROOT
212
213 %{__make} install \
214         DESTDIR=$RPM_BUILD_ROOT
215
216 # obsoleted by pkg-config
217 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libewf.la
218
219 %if %{with python2}
220 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/pyewf.{la,a}
221 %endif
222 %if %{with python3}
223 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/pyewf.{la,a}
224 %endif
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %post   -p /sbin/ldconfig
230 %postun -p /sbin/ldconfig
231
232 %files
233 %defattr(644,root,root,755)
234 %doc AUTHORS COPYING ChangeLog NEWS
235 %attr(755,root,root) %{_libdir}/libewf.so.*.*.*
236 %attr(755,root,root) %ghost %{_libdir}/libewf.so.3
237
238 %files devel
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_libdir}/libewf.so
241 %{_includedir}/libewf
242 %{_includedir}/libewf.h
243 %{_pkgconfigdir}/libewf.pc
244 %{_mandir}/man3/libewf.3*
245
246 %files static
247 %defattr(644,root,root,755)
248 %{_libdir}/libewf.a
249
250 %files tools
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_bindir}/ewfacquire
253 %attr(755,root,root) %{_bindir}/ewfacquirestream
254 %attr(755,root,root) %{_bindir}/ewfdebug
255 %attr(755,root,root) %{_bindir}/ewfexport
256 %attr(755,root,root) %{_bindir}/ewfinfo
257 %attr(755,root,root) %{_bindir}/ewfmount
258 %attr(755,root,root) %{_bindir}/ewfrecover
259 %attr(755,root,root) %{_bindir}/ewfverify
260 %{_mandir}/man1/ewfacquire.1*
261 %{_mandir}/man1/ewfacquirestream.1*
262 %{_mandir}/man1/ewfexport.1*
263 %{_mandir}/man1/ewfinfo.1*
264 %{_mandir}/man1/ewfmount.1*
265 %{_mandir}/man1/ewfrecover.1*
266 %{_mandir}/man1/ewfverify.1*
267
268 %if %{with python2}
269 %files -n python-pyewf
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{py_sitedir}/pyewf.so
272 %endif
273
274 %if %{with python3}
275 %files -n python3-pyewf
276 %defattr(644,root,root,755)
277 %attr(755,root,root) %{py3_sitedir}/pyewf.so
278 %endif
This page took 0.105189 seconds and 3 git commands to generate.