]> git.pld-linux.org Git - packages/libetonyek.git/blob - libetonyek.spec
b1b6c837e88b7f27ba797c1ccb11115ee1d2ec78
[packages/libetonyek.git] / libetonyek.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library and tools for reading and converting Apple Keynote presentations
6 Summary(pl.UTF-8):      Biblioteka i narzędzia do odczytu i konwersji prezentacji Apple Keynote
7 Name:           libetonyek
8 Version:        0.1.1
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 Source0:        http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.xz
13 # Source0-md5:  7adbc34bb4a33e26688c862e154a0d29
14 URL:            http://www.freedesktop.org/wiki/Software/libetonyek/
15 BuildRequires:  boost-devel
16 BuildRequires:  doxygen
17 BuildRequires:  gperf
18 BuildRequires:  librevenge-devel >= 0.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libxml2-devel >= 2.0
21 BuildRequires:  pkgconfig >= 1:0.20
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 libetonyek is a library and a set of tools for reading and converting
29 Apple Keynote presentations. The library tries to extract the most
30 important parts of version 2 format of Keynote (version 1 is not
31 supported yet, but it should be in the future). See FEATURES for what
32 is currently supported.
33
34 %description -l pl.UTF-8
35 libetonyek to biblioteka i zestaw narzędzi do odczytu i konwersji
36 prezentacji Apple Keynote. Biblioteka próbuje wydobyć najważniejsze
37 części formatu Keynote w wersji 2 (wersja 1 nie jest jeszcze
38 obsługiwana, ale powinna być w przyszłości). Informacje o
39 obsługiwanych elementach można znaleźć w pliku FEATURES.
40
41 %package devel
42 Summary:        Header files for libetonyek library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libetonyek
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       librevenge-devel >= 0.0
47 Requires:       libstdc++-devel
48 Requires:       libxml2-devel >= 2.0
49 Requires:       zlib-devel
50
51 %description devel
52 Header files for libetonyek library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki libetonyek.
56
57 %package static
58 Summary:        Static libetonyek library
59 Summary(pl.UTF-8):      Statyczna biblioteka libetonyek
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static libetonyek library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libetonyek.
68
69 %package apidocs
70 Summary:        libetonyek API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki libetonyek
72 Group:          Documentation
73
74 %description apidocs
75 API documentation for libetonyek library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki libetonyek.
79
80 %package tools
81 Summary:        Tools to transform Apple Keynote presentations into other formats
82 Summary(pl.UTF-8):      Programy przekształcania prezentacji Apple Keynote do innych formatów
83 Group:          Applications/Publishing
84 Requires:       %{name} = %{version}-%{release}
85
86 %description tools
87 Tools to transform Apple Keynote presentations into other formats.
88 Currently supported: XHTML, raw.
89
90 %description tools -l pl.UTF-8
91 Narzędzia do przekształcania prezentacji Apple Keynote do innych
92 formatów. Aktualnie obsługiwane są XHTML i format surowy.
93
94 %prep
95 %setup -q
96
97 %build
98 %configure \
99         --disable-silent-rules \
100         %{?with_static_libs:--enable-static}
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 # obsoleted by pkg-config
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libetonyek-*.la
112 # packaged as %doc in -apidocs
113 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libetonyek
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog FEATURES NEWS README TODO
124 %attr(755,root,root) %{_libdir}/libetonyek-0.1.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libetonyek-0.1.so.1
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libetonyek-0.1.so
130 %{_includedir}/libetonyek-0.1
131 %{_pkgconfigdir}/libetonyek-0.1.pc
132
133 %if %{with static_libs}
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libetonyek-0.1.a
137 %endif
138
139 %files apidocs
140 %defattr(644,root,root,755)
141 %doc docs/doxygen/html/*
142
143 %files tools
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/key2raw
146 %attr(755,root,root) %{_bindir}/key2text
147 %attr(755,root,root) %{_bindir}/key2xhtml
148 %attr(755,root,root) %{_bindir}/numbers2csv
149 %attr(755,root,root) %{_bindir}/numbers2raw
150 %attr(755,root,root) %{_bindir}/numbers2text
151 %attr(755,root,root) %{_bindir}/pages2html
152 %attr(755,root,root) %{_bindir}/pages2raw
153 %attr(755,root,root) %{_bindir}/pages2text
This page took 0.070909 seconds and 2 git commands to generate.