]> git.pld-linux.org Git - packages/libepoxy.git/blob - libepoxy.spec
- unconditional noarch subpackages
[packages/libepoxy.git] / libepoxy.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  tests           # test suite
5 %bcond_without  static_libs     # static library build
6
7 Summary:        Epoxy - GL dispatch library
8 Summary(pl.UTF-8):      Epoxy - biblioteka do przekazywania funkcji GL
9 Name:           libepoxy
10 Version:        1.5.5
11 Release:        1
12 License:        MIT
13 Group:          Libraries
14 ##Source0Download: https://github.com/anholt/libepoxy/releases
15 #Source0:       https://github.com/anholt/libepoxy/releases/download/v1.4/%{name}-%{version}.tar.xz
16 Source0:        https://download.gnome.org/sources/libepoxy/1.5/%{name}-%{version}.tar.xz
17 # Source0-md5:  516ff05a42157c86e32c6598321737af
18 URL:            https://github.com/anholt/libepoxy
19 %{?with_tests:BuildRequires:    Mesa-khrplatform-devel}
20 BuildRequires:  Mesa-libEGL-devel
21 BuildRequires:  Mesa-libGL-devel
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  meson
24 BuildRequires:  ninja >= 1.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  python3 >= 1:3
27 BuildRequires:  rpmbuild(macros) >= 1.752
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xorg-lib-libX11-devel
30 BuildRequires:  xorg-util-util-macros >= 1.8
31 BuildRequires:  xz
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Epoxy is a library for handling OpenGL function pointer management for
36 you.
37
38 %description -l pl.UTF-8
39 Epoxy to biblioteka do obsługi zarządzania wskaźnikami do funkcji
40 OpenGL.
41
42 %package devel
43 Summary:        Development files for libepoxy
44 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libepoxy
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 This package contains the header files for developing applications
50 that use libepoxy.
51
52 %description devel -l pl.UTF-8
53 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
54 wykorzystujących bibliotekę libepoxy.
55
56 %package static
57 Summary:        Static libepoxy library
58 Summary(pl.UTF-8):      Statyczna biblioteka libepoxy
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libepoxy library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka libepoxy.
67
68 %package apidocs
69 Summary:        API documentation for libepoxy library
70 Summary(pl.UTF-8):      Dokumentacja API biblioteki libepoxy
71 Group:          Documentation
72 BuildArch:      noarch
73
74 %description apidocs
75 API documentation for libepoxy library.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API biblioteki libepoxy.
79
80 %prep
81 %setup -q
82
83 %build
84 %meson build \
85         %{!?with_static_libs:--default-library=shared} \
86         %{?with_apidocs:-Ddocs=true} \
87         %{!?with_tests:-Dtests=false}
88
89 %ninja_build -C build
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %ninja_install -C build
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc COPYING README.md
105 %attr(755,root,root) %{_libdir}/libepoxy.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libepoxy.so.0
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libepoxy.so
111 %{_includedir}/epoxy
112 %{_pkgconfigdir}/epoxy.pc
113
114 %if %{with static_libs}
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libepoxy.a
118 %endif
119
120 %if %{with apidocs}
121 %files apidocs
122 %defattr(644,root,root,755)
123 %{_docdir}/epoxy
124 %endif
This page took 0.09202 seconds and 3 git commands to generate.