]> git.pld-linux.org Git - packages/libechonest.git/blob - libechonest.spec
BR pkgconfig
[packages/libechonest.git] / libechonest.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests. tests need active internet connection
4
5 Summary:        C++ wrapper for the Echo Nest API
6 Name:           libechonest
7 Version:        2.1.0
8 Release:        1
9 License:        GPL v2+
10 Source0:        http://files.lfranchi.com/%{name}-%{version}.tar.bz2
11 # Source0-md5:  96d98dbc5b3b155b277a9901d1133c5e
12 Group:          Libraries
13 URL:            https://projects.kde.org/projects/playground/libs/libechonest
14 BuildRequires:  QtNetwork-devel
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig
17 BuildRequires:  qjson-devel
18 BuildRequires:  qt4-build
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 libechonest is a collection of C++/Qt classes designed to make a
24 developer's life easy when trying to use the APIs provided by The Echo
25 Nest.
26
27 %package        devel
28 Summary:        Development files for %{name}
29 Requires:       %{name} = %{version}-%{release}
30
31 %description    devel
32 The %{name}-devel package contains libraries and header files for
33 developing applications that use %{name}.
34
35 %prep
36 %setup -q
37
38 %build
39 install -d %{_target_platform}
40 cd %{_target_platform}
41 %cmake ..
42 %{__make}
43
44 %if %{with tests}
45 export PKG_CONFIG_PATH=$RPM_BUILD_ROOT%{_npkgconfigdir}:$RPM_BUILD_ROOT%{_pkgconfigdir}
46 test "$(pkg-config --modversion libechonest)" = "%{version}"
47 %{__make} test
48 %endif
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 %{__make} -C %{_target_platform} install/fast \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS COPYING README TODO
64 %attr(755,root,root) %{_libdir}/libechonest.so.*.*.*
65 # yes, SONAME is "libechonest.so.2.1"
66 %ghost %{_libdir}/libechonest.so.2.1
67
68 %files devel
69 %defattr(644,root,root,755)
70 %{_includedir}/echonest/
71 %{_libdir}/libechonest.so
72 %{_pkgconfigdir}/libechonest.pc
This page took 0.081664 seconds and 4 git commands to generate.