]> git.pld-linux.org Git - packages/libechonest.git/blob - libechonest.spec
fix tests, but they hung
[packages/libechonest.git] / libechonest.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests. tests need active internet connection
4
5 Summary:        C++ wrapper for the Echo Nest API
6 Name:           libechonest
7 Version:        2.1.0
8 Release:        1
9 License:        GPL v2+
10 Source0:        http://files.lfranchi.com/%{name}-%{version}.tar.bz2
11 # Source0-md5:  96d98dbc5b3b155b277a9901d1133c5e
12 Group:          Libraries
13 URL:            https://projects.kde.org/projects/playground/libs/libechonest
14 BuildRequires:  QtNetwork-devel
15 BuildRequires:  cmake
16 BuildRequires:  pkgconfig
17 BuildRequires:  qjson-devel
18 BuildRequires:  qt4-build
19 BuildRequires:  rpmbuild(macros) >= 1.605
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # Unresolved symbol __stack_chk_fail in libechonest.so.2.1.0
23 %ifarch i486
24 %define skip_post_check_so      libechonest.so.%{version}
25 %endif
26
27 %description
28 libechonest is a collection of C++/Qt classes designed to make a
29 developer's life easy when trying to use the APIs provided by The Echo
30 Nest.
31
32 %package        devel
33 Summary:        Development files for %{name}
34 Requires:       %{name} = %{version}-%{release}
35
36 %description    devel
37 The %{name}-devel package contains libraries and header files for
38 developing applications that use %{name}.
39
40 %prep
41 %setup -q
42
43 %build
44 install -d %{_target_platform}
45 cd %{_target_platform}
46 %cmake ..
47 %{__make}
48
49 %if %{with tests}
50 export PKG_CONFIG_PATH=$(pwd)
51 test "$(pkg-config --modversion libechonest)" = "%{version}"
52 %{__make} test
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %{__make} -C %{_target_platform} install/fast \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHORS COPYING README TODO
69 %attr(755,root,root) %{_libdir}/libechonest.so.*.*.*
70 # yes, SONAME is "libechonest.so.2.1"
71 %ghost %{_libdir}/libechonest.so.2.1
72
73 %files devel
74 %defattr(644,root,root,755)
75 %{_includedir}/echonest/
76 %{_libdir}/libechonest.so
77 %{_pkgconfigdir}/libechonest.pc
This page took 0.291597 seconds and 4 git commands to generate.