]> git.pld-linux.org Git - packages/libebml.git/blob - libebml.spec
up to 1.4.3
[packages/libebml.git] / libebml.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Extensible Binary Meta Language access library
6 Summary(pl.UTF-8):      Biblioteka dostępu rozszerzalnego metajęzyka binarnego
7 Name:           libebml
8 Version:        1.4.3
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        https://dl.matroska.org/downloads/libebml/%{name}-%{version}.tar.xz
13 # Source0-md5:  de037ddb4908f92866e7ce76869ddba1
14 URL:            https://www.matroska.org/
15 BuildRequires:  cmake >= 3.1.2
16 BuildRequires:  gcc >= 6:5
17 BuildRequires:  libstdc++-devel >= 6:4.7
18 BuildRequires:  rpmbuild(macros) >= 1.605
19 BuildRequires:  tar >= 1:1.22
20 BuildRequires:  xz
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Extensible Binary Meta Language access library is a library for
25 reading and writing files with the Extensible Binary Meta Language, a
26 binary pendant to XML.
27
28 %description -l pl.UTF-8
29 Biblioteka rozszerzalnego metajęzyka binarnego (Extensible Binary Meta
30 Language, w skrócie EBML) umożliwia czytanie i zapisywanie plików w
31 tym metajęzyku, będącym binarnym uzupełnieniem XML-a.
32
33 %package devel
34 Summary:        Header files for Extensible Binary Meta Language library
35 Summary(pl.UTF-8):      Nagłówki biblioteki rozszerzalnego metajęzyka binarnego
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       libstdc++-devel >= 6:4.7
39
40 %description devel
41 Header files for Extensible Binary Meta Language library.
42
43 %description devel -l pl.UTF-8
44 Nagłówki biblioteki rozszerzalnego metajęzyka binarnego.
45
46 %package static
47 Summary:        Static version of Extensible Binary Meta Language library
48 Summary(pl.UTF-8):      Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static version of Extensible Binary Meta Language library.
54
55 %description static -l pl.UTF-8
56 Statyczna wersja biblioteki rozszerzalnego metajęzyka binarnego.
57
58 %prep
59 %setup -q
60
61 %build
62 # .pc file generation expects relative CMAKE_INSTALL_{INCLUDE,LIB}DIR
63 %if %{with static_libs}
64 install -d build-static
65 cd build-static
66 %cmake .. \
67         -DBUILD_SHARED_LIBS:BOOL=OFF \
68         -DCMAKE_INSTALL_INCLUDEDIR=include \
69         -DCMAKE_INSTALL_LIBDIR=%{_lib}
70
71 %{__make}
72 cd ..
73 %endif
74
75 install -d build
76 cd build
77 %cmake .. \
78         -DCMAKE_INSTALL_INCLUDEDIR=include \
79         -DCMAKE_INSTALL_LIBDIR=%{_lib}
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with static_libs}
87 %{__make} -C build-static install \
88         DESTDIR=$RPM_BUILD_ROOT
89 %endif
90
91 %{__make} -C build install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc NEWS.md README.md
103 %attr(755,root,root) %{_libdir}/libebml.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libebml.so.5
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libebml.so
109 %{_includedir}/ebml
110 %{_pkgconfigdir}/libebml.pc
111 %{_libdir}/cmake/EBML
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libebml.a
117 %endif
This page took 0.059166 seconds and 3 git commands to generate.