]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
icu rebuild
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_with     experimental    # with experimental HTML
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
7 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
8 Name:           libe-book
9 Version:        0.1.3
10 Release:        9
11 License:        LGPL v2.1+ or MPL v2.0+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
14 # Source0-md5:  2956f1c5e7950b0018979a132165da8b
15 Patch0:         %{name}-missing.patch
16 Patch1:         icu68.patch
17 URL:            http://libebook.sourceforge.net/
18 BuildRequires:  boost-devel
19 BuildRequires:  cppunit-devel
20 BuildRequires:  doxygen
21 BuildRequires:  gperf
22 %{?with_experimental:BuildRequires:     libCSS-devel >= 0.6.0}
23 %{?with_experimental:BuildRequires:     libhubbub-devel >= 0.3.0}
24 BuildRequires:  libicu-devel
25 BuildRequires:  liblangtag-devel
26 %{?with_experimental:BuildRequires:     libmspack-devel}
27 BuildRequires:  libparserutils-devel
28 BuildRequires:  librevenge-devel >= 0.0
29 BuildRequires:  libstdc++-devel >= 6:4.7
30 BuildRequires:  libwapcaplet-devel
31 BuildRequires:  libxml2-devel >= 2.0
32 BuildRequires:  pkgconfig >= 1:0.20
33 BuildRequires:  rpm-build >= 4.6
34 BuildRequires:  rpmbuild(macros) >= 1.527
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 BuildRequires:  zlib-devel
38 %{?with_experimental:Requires:  libCSS >= 0.6.0}
39 %{?with_experimental:Requires:  libhubbub >= 0.3.0}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 libe-book is a library and a set of tools for reading and converting
44 various non-HTML reflowable e-book formats.
45
46 Currently supported are:
47 - eReader .pdb
48 - FictionBook v. 2 (including zipped files)
49 - PalmDoc Ebook
50 - Plucker .pdb
51 - QiOO (mobile format, for java-enabled cellphones)
52 - TCR (simple compressed text format)
53 - TealDoc
54 - zTXT
55 - ZVR (simple compressed text format)
56
57 %description -l pl.UTF-8
58 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
59 różnych nie-HTML-owych, tekstowych formatów e-booków.
60
61 Obecnie obsługiwane są:
62 - eReader .pdb
63 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
64 - PalmDoc Ebook
65 - Plucker .pdb
66 - QiOO (format przenośny, dla telefonów z Javą)
67 - TCR (prosty skompresowany format tekstowy)
68 - TealDoc
69 - zTXT
70 - ZVR (prosty skompresowany format tekstowy)
71
72 %package devel
73 Summary:        Header files for libe-book library
74 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 %{?with_experimental:Requires:  libCSS-devel >= 0.6.0}
78 %{?with_experimental:Requires:  libhubbub-devel >= 0.3.0}
79 Requires:       libicu-devel
80 Requires:       liblangtag-devel
81 %{?with_experimental:Requires:  libmspack-devel}
82 Requires:       librevenge-devel >= 0.0
83 Requires:       libstdc++-devel >= 6:4.7
84 Requires:       libxml2-devel >= 2.0
85 Requires:       zlib-devel
86
87 %description devel
88 Header files for libe-book library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki libe-book.
92
93 %package static
94 Summary:        Static libe-book library
95 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
96 Group:          Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 Static libe-book library.
101
102 %description static -l pl.UTF-8
103 Statyczna biblioteka libe-book.
104
105 %package apidocs
106 Summary:        libe-book API documentation
107 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
108 Group:          Documentation
109 BuildArch:      noarch
110
111 %description apidocs
112 API documentation for libe-book library.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki libe-book.
116
117 %package tools
118 Summary:        Tools to transform e-books into other formats
119 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
120 Group:          Applications/Publishing
121 Requires:       %{name} = %{version}-%{release}
122
123 %description tools
124 Tools to transform e-books into other formats. Currently supported:
125 HTML, text, raw.
126
127 %description tools -l pl.UTF-8
128 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
129 obsługiwane są HTML, tekst i format surowy.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 %build
137 export CXXFLAGS="%{rpmcxxflags} -Wno-unused-function"
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         %{__enable_disable experimental} \
145         --disable-silent-rules \
146         %{?with_static_libs:--enable-static}
147 %{__make}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 # obsoleted by pkg-config
156 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
157 # packaged as %doc in -apidocs
158 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog NEWS README TODO
169 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
171 %{?with_experimental:%{_datadir}/libe-book}
172
173 %files devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
176 %{_includedir}/libe-book-0.1
177 %{_pkgconfigdir}/libe-book-0.1.pc
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libe-book-0.1.a
183 %endif
184
185 %files apidocs
186 %defattr(644,root,root,755)
187 %doc docs/doxygen/html/*
188
189 %files tools
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_bindir}/ebook2html
192 %attr(755,root,root) %{_bindir}/ebook2raw
193 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.091577 seconds and 4 git commands to generate.