]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
- updated to 0.1.0 (now librevenge based; new soname, 0.0.x left on libe-book-0.0...
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
6 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
7 Name:           libe-book
8 Version:        0.1.0
9 Release:        1
10 License:        LGPL v2.1+ or MPL v2.0+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
13 # Source0-md5:  0a49e90b46193c1ae1e55ff0486b5090
14 URL:            http://libebook.sourceforge.net/
15 BuildRequires:  boost-devel
16 BuildRequires:  doxygen
17 BuildRequires:  gperf
18 BuildRequires:  libCSS-devel >= 0.3.0
19 BuildRequires:  libhubbub-devel >= 0.3.0
20 BuildRequires:  libicu-devel
21 BuildRequires:  libmspack-devel
22 BuildRequires:  libparserutils-devel
23 BuildRequires:  librevenge-devel >= 0.0
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libwapcaplet-devel
26 BuildRequires:  libxml2-devel >= 2.0
27 BuildRequires:  pkgconfig >= 1:0.20
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRequires:  zlib-devel
31 Requires:       libwpd >= 0.9.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libe-book is a library and a set of tools for reading and converting
36 various non-HTML reflowable e-book formats.
37
38 Currently supported are:
39 - eReader .pdb
40 - FictionBook v. 2 (including zipped files)
41 - PalmDoc Ebook
42 - Plucker .pdb
43 - QiOO (mobile format, for java-enabled cellphones)
44 - TCR (simple compressed text format)
45 - TealDoc
46 - zTXT
47 - ZVR (simple compressed text format)
48
49 %description -l pl.UTF-8
50 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
51 różnych nie-HTML-owych, tekstowych formatów e-booków.
52
53 Obecnie obsługiwane są:
54 - eReader .pdb
55 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
56 - PalmDoc Ebook
57 - Plucker .pdb
58 - QiOO (format przenośny, dla telefonów z Javą)
59 - TCR (prosty skompresowany format tekstowy)
60 - TealDoc
61 - zTXT
62 - ZVR (prosty skompresowany format tekstowy)
63
64 %package devel
65 Summary:        Header files for libe-book library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Requires:       libCSS-devel >= 0.3.0
70 Requires:       libhubbub-devel >= 0.3.0
71 Requires:       libicu-devel
72 Requires:       libmspack-devel
73 Requires:       librevenge-devel >= 0.0
74 Requires:       libstdc++-devel
75 Requires:       libxml2-devel >= 2.0
76 Requires:       zlib-devel
77
78 %description devel
79 Header files for libe-book library.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe biblioteki libe-book.
83
84 %package static
85 Summary:        Static libe-book library
86 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static libe-book library.
92
93 %description static -l pl.UTF-8
94 Statyczna biblioteka libe-book.
95
96 %package apidocs
97 Summary:        libe-book API documentation
98 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
99 Group:          Documentation
100
101 %description apidocs
102 API documentation for libe-book library.
103
104 %description apidocs -l pl.UTF-8
105 Dokumentacja API biblioteki libe-book.
106
107 %package tools
108 Summary:        Tools to transform e-books into other formats
109 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
110 Group:          Applications/Publishing
111 Requires:       %{name} = %{version}-%{release}
112
113 %description tools
114 Tools to transform e-books into other formats. Currently supported:
115 HTML, text, raw.
116
117 %description tools -l pl.UTF-8
118 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
119 obsługiwane są HTML, tekst i format surowy.
120
121 %prep
122 %setup -q
123
124 %build
125 %configure \
126         --enable-experimental \
127         --disable-silent-rules \
128         %{?with_static_libs:--enable-static}
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 # obsoleted by pkg-config
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
139 # packaged as %doc in -apidocs
140 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
152 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
153 %{_datadir}/libe-book
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
158 %{_includedir}/libe-book-0.1
159 %{_pkgconfigdir}/libe-book-0.1.pc
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libe-book-0.1.a
165 %endif
166
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc docs/doxygen/html/*
170
171 %files tools
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_bindir}/ebook2html
174 %attr(755,root,root) %{_bindir}/ebook2raw
175 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.07966 seconds and 3 git commands to generate.