]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
- icu 67 rebuild
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_with     experimental    # with experimental HTML
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
7 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
8 Name:           libe-book
9 Version:        0.1.3
10 Release:        4
11 License:        LGPL v2.1+ or MPL v2.0+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
14 # Source0-md5:  2956f1c5e7950b0018979a132165da8b
15 Patch0:         %{name}-missing.patch
16 URL:            http://libebook.sourceforge.net/
17 BuildRequires:  boost-devel
18 BuildRequires:  cppunit-devel
19 BuildRequires:  doxygen
20 BuildRequires:  gperf
21 %{?with_experimental:BuildRequires:     libCSS-devel >= 0.6.0}
22 %{?with_experimental:BuildRequires:     libhubbub-devel >= 0.3.0}
23 BuildRequires:  libicu-devel
24 BuildRequires:  liblangtag-devel
25 %{?with_experimental:BuildRequires:     libmspack-devel}
26 BuildRequires:  libparserutils-devel
27 BuildRequires:  librevenge-devel >= 0.0
28 BuildRequires:  libstdc++-devel >= 6:4.7
29 BuildRequires:  libwapcaplet-devel
30 BuildRequires:  libxml2-devel >= 2.0
31 BuildRequires:  pkgconfig >= 1:0.20
32 BuildRequires:  rpmbuild(macros) >= 1.527
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  zlib-devel
36 %{?with_experimental:Requires:  libCSS >= 0.6.0}
37 %{?with_experimental:Requires:  libhubbub >= 0.3.0}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 libe-book is a library and a set of tools for reading and converting
42 various non-HTML reflowable e-book formats.
43
44 Currently supported are:
45 - eReader .pdb
46 - FictionBook v. 2 (including zipped files)
47 - PalmDoc Ebook
48 - Plucker .pdb
49 - QiOO (mobile format, for java-enabled cellphones)
50 - TCR (simple compressed text format)
51 - TealDoc
52 - zTXT
53 - ZVR (simple compressed text format)
54
55 %description -l pl.UTF-8
56 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
57 różnych nie-HTML-owych, tekstowych formatów e-booków.
58
59 Obecnie obsługiwane są:
60 - eReader .pdb
61 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
62 - PalmDoc Ebook
63 - Plucker .pdb
64 - QiOO (format przenośny, dla telefonów z Javą)
65 - TCR (prosty skompresowany format tekstowy)
66 - TealDoc
67 - zTXT
68 - ZVR (prosty skompresowany format tekstowy)
69
70 %package devel
71 Summary:        Header files for libe-book library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 %{?with_experimental:Requires:  libCSS-devel >= 0.6.0}
76 %{?with_experimental:Requires:  libhubbub-devel >= 0.3.0}
77 Requires:       libicu-devel
78 Requires:       liblangtag-devel
79 %{?with_experimental:Requires:  libmspack-devel}
80 Requires:       librevenge-devel >= 0.0
81 Requires:       libstdc++-devel >= 6:4.7
82 Requires:       libxml2-devel >= 2.0
83 Requires:       zlib-devel
84
85 %description devel
86 Header files for libe-book library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki libe-book.
90
91 %package static
92 Summary:        Static libe-book library
93 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static libe-book library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka libe-book.
102
103 %package apidocs
104 Summary:        libe-book API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
106 Group:          Documentation
107 %if "%{_rpmversion}" >= "5"
108 BuildArch:      noarch
109 %endif
110
111 %description apidocs
112 API documentation for libe-book library.
113
114 %description apidocs -l pl.UTF-8
115 Dokumentacja API biblioteki libe-book.
116
117 %package tools
118 Summary:        Tools to transform e-books into other formats
119 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
120 Group:          Applications/Publishing
121 Requires:       %{name} = %{version}-%{release}
122
123 %description tools
124 Tools to transform e-books into other formats. Currently supported:
125 HTML, text, raw.
126
127 %description tools -l pl.UTF-8
128 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
129 obsługiwane są HTML, tekst i format surowy.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134
135 %build
136 export CXXFLAGS="%{rpmcxxflags} -Wno-unused-function"
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         %{__enable_disable experimental} \
144         --disable-silent-rules \
145         %{?with_static_libs:--enable-static}
146 %{__make}
147
148 %install
149 rm -rf $RPM_BUILD_ROOT
150
151 %{__make} install \
152         DESTDIR=$RPM_BUILD_ROOT
153
154 # obsoleted by pkg-config
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
156 # packaged as %doc in -apidocs
157 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post   -p /sbin/ldconfig
163 %postun -p /sbin/ldconfig
164
165 %files
166 %defattr(644,root,root,755)
167 %doc AUTHORS ChangeLog NEWS README TODO
168 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
170 %{?with_experimental:%{_datadir}/libe-book}
171
172 %files devel
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
175 %{_includedir}/libe-book-0.1
176 %{_pkgconfigdir}/libe-book-0.1.pc
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libe-book-0.1.a
182 %endif
183
184 %files apidocs
185 %defattr(644,root,root,755)
186 %doc docs/doxygen/html/*
187
188 %files tools
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_bindir}/ebook2html
191 %attr(755,root,root) %{_bindir}/ebook2raw
192 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.110474 seconds and 3 git commands to generate.