]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
492d89c9f1371d0ee9425d32f33a921c2e5c61bd
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
6 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
7 Name:           libe-book
8 Version:        0.0.3
9 Release:        1
10 License:        LGPL v2.1+ or MPL v2.0+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
13 # Source0-md5:  cd3d71e8ad6df3d815ae977ec1ba667c
14 URL:            http://libebook.sourceforge.net/
15 BuildRequires:  boost-devel
16 BuildRequires:  doxygen
17 BuildRequires:  gperf
18 BuildRequires:  libicu-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libwpd-devel >= 0.9.5
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig >= 1:0.20
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26 Requires:       libwpd >= 0.9.5
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libe-book is a library and a set of tools for reading and converting
31 various non-HTML reflowable e-book formats.
32
33 Currently supported are:
34 - eReader .pdb
35 - FictionBook v. 2 (including zipped files)
36 - PalmDoc Ebook
37 - Plucker .pdb
38 - QiOO (mobile format, for java-enabled cellphones)
39 - TCR (simple compressed text format)
40 - TealDoc
41 - zTXT
42 - ZVR (simple compressed text format)
43
44 %description -l pl.UTF-8
45 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
46 różnych nie-HTML-owych, tekstowych formatów e-booków.
47
48 Obecnie obsługiwane są:
49 - eReader .pdb
50 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
51 - PalmDoc Ebook
52 - Plucker .pdb
53 - QiOO (format przenośny, dla telefonów z Javą)
54 - TCR (prosty skompresowany format tekstowy)
55 - TealDoc
56 - zTXT
57 - ZVR (prosty skompresowany format tekstowy)
58
59 %package devel
60 Summary:        Header files for libe-book library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       libstdc++-devel
65 Requires:       libwpd-devel >= 0.9.5
66 Requires:       zlib-devel
67
68 %description devel
69 Header files for libe-book library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki libe-book.
73
74 %package static
75 Summary:        Static libe-book library
76 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static libe-book library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libe-book.
85
86 %package apidocs
87 Summary:        libe-book API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for libe-book library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki libe-book.
96
97 %prep
98 %setup -q
99
100 %build
101 %configure \
102         --disable-silent-rules \
103         %{?with_static_libs:--enable-static}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 # obsoleted by pkg-config
113 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
114 # packaged as %doc in -apidocs
115 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README TODO
126 %attr(755,root,root) %{_bindir}/ebook2html
127 %attr(755,root,root) %{_bindir}/ebook2raw
128 %attr(755,root,root) %{_bindir}/ebook2text
129 %attr(755,root,root) %{_libdir}/libe-book-0.0.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.0.so.0
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libe-book-0.0.so
135 %{_includedir}/libe-book-0.0
136 %{_pkgconfigdir}/libe-book-0.0.pc
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libe-book-0.0.a
142 %endif
143
144 %files apidocs
145 %defattr(644,root,root,755)
146 %doc docs/doxygen/html/*
This page took 0.396687 seconds and 2 git commands to generate.