]> git.pld-linux.org Git - packages/libdsm.git/blob - libdsm.spec
3262faef562cfb1123d8db8a324d35233145f38b
[packages/libdsm.git] / libdsm.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        Minimalist and read-only SMB client library
7 Summary(pl.UTF-8):      Minimalistyczna biblioteka klienta SMB (tylko do odczytu)
8 Name:           libdsm
9 Version:        0.3.2
10 Release:        1
11 License:        LGPL v2.1+ or commercial
12 Group:          Libraries
13 #Source0Download: https://github.com/videolabs/libdsm/releases
14 Source0:        https://github.com/videolabs/libdsm/releases/download/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  f369fed56ec61f08951363157b45c276
16 URL:            https://videolabs.github.io/libdsm/
17 #BuildRequires: autoconf >= 2.53
18 #BuildRequires: automake >= 1:1.6
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libbsd-devel
21 BuildRequires:  libtasn1-devel >= 3.0
22 #BuildRequires: libtool >= 2:2
23 Requires:       libtasn1 >= 3.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 lib Defective SMb (libDSM) is a SMB protocol client implementation in
28 pure old C, with a lot less features than Samba but with a much
29 simpler, and a more permissive license (currently LGPL + proprietary).
30
31 %description -l pl.UTF-8
32 lib Defective SMb (libDSM) to implementacja klienta protokołu SMB w
33 czystym, starym C. Ma o wiele mniej możliwości niż Samba, ale jest
34 dużo prostsza i ma luźniejszą licencję (obecnie LGPL z opcją
35 komercyjną).
36
37 %package devel
38 Summary:        Header files for liBDSM library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki liBDSM
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libtasn1-devel >= 3.0
43
44 %description devel
45 Header files for liBDSM library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki liBDSM.
49
50 %package static
51 Summary:        Static liBDSM library
52 Summary(pl.UTF-8):      Statyczna biblioteka liBDSM
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static liBDSM library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka liBDSM.
61
62 %package apidocs
63 Summary:        API documentation for liBDSM library
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki liBDSM
65 Group:          Documentation
66
67 %description apidocs
68 API documentation for liBDSM library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki liBDSM.
72
73 %prep
74 %setup -q
75
76 %{__sed} -ne '1,/^===/ p' COPYING > LICENSE
77
78 %build
79 %configure \
80         --disable-silent-rules \
81         %{!?with_static_libs:--disable-static}
82 %{__make}
83
84 %if %{with apidocs}
85 %{__make} doc
86 %endif
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 # obsoleted by pkgconfig
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdsm.la
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc AUTHORS LICENSE NEWS
106 %attr(755,root,root) %{_bindir}/dsm
107 %attr(755,root,root) %{_bindir}/dsm_discover
108 %attr(755,root,root) %{_bindir}/dsm_inverse
109 %attr(755,root,root) %{_bindir}/dsm_lookup
110 %attr(755,root,root) %{_libdir}/libdsm.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libdsm.so.3
112
113 %files devel
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{_libdir}/libdsm.so
116 %{_includedir}/bdsm
117 %{_pkgconfigdir}/libdsm.pc
118
119 %if %{with static_libs}
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libdsm.a
123 %endif
124
125 %if %{with apidocs}
126 %files apidocs
127 %defattr(644,root,root,755)
128 %doc doc/html/*
129 %endif
This page took 0.076933 seconds and 2 git commands to generate.