]> git.pld-linux.org Git - packages/libdmtx.git/blob - libdmtx.spec
- new URLs, updated to 0.7.5
[packages/libdmtx.git] / libdmtx.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        Library for working with Data Matrix 2D bar-codes
6 Summary(pl.UTF-8):      Biblioteka do pracy z kodami paskowymi Data Matrix 2D
7 Name:           libdmtx
8 Version:        0.7.5
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/dmtx/libdmtx/releases
13 Source0:        https://github.com/dmtx/libdmtx/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  82edcd68e9f4fa779f5f7573baf2a9f5
15 URL:            https://github.com/dmtx/libdmtx
16 BuildRequires:  ImageMagick-devel
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpmbuild(macros) >= 1.219
22 %if %{with tests}
23 BuildRequires:  OpenGL-GLU-devel
24 BuildRequires:  SDL_image-devel
25 BuildRequires:  libpng-devel
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 libdmtx is open source software for reading and writing Data Matrix 2D
31 bar-codes on Linux, Unix, OS X, Windows, and mobile devices. At its
32 core libdmtx is a shared library, allowing C/C++ programs to use its
33 capabilities without restrictions or overhead.
34
35 The included utility programs, dmtxread and dmtxwrite, provide the
36 official interface to libdmtx from the command line, and also serve as
37 a good reference for programmers who wish to write their own programs
38 that interact with libdmtx.
39
40 %description -l pl.UTF-8
41 libdmtx to mające otwarte źródła oprogramowanie do odczytu i zapisu
42 kodów paskowych Data Matrix 3D pod Linuksem, Uniksem, OS X, Windows i
43 na platformach mobilnych. Główną częścią jest biblioteka
44 współdzielona, pozwalająca programom w C/C++ korzystać ze swoich
45 możliwości bez ograniczeń czy narzutów.
46
47 Załączone programy użytkowe - dmtxread i dmtxwrite - udostępniają
48 oficjalny interfejs libdmtx z poziomu linii poleceń, a także służą
49 jako dobre przykłady dla programistów chcących pisać własne programy
50 współpracujące z libdmtx.
51
52 %package devel
53 Summary:        Development files for libdmtx library
54 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libdmtx
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 This package contains the header files for developing applications
60 that use libdmtx.
61
62 %description devel -l pl.UTF-8
63 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
64 wykorzystujących bibliotekę libdmtx.
65
66 %prep
67 %setup -q
68
69 %build
70 %{__libtoolize}
71 %{__aclocal} -I m4
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --disable-static
77
78 %{__make}
79
80 %if %{with tests}
81 %{__make} check \
82         AM_CPPFLAGS+=-std=c99
83 ./test/simple_test/simple_test
84 %endif
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdmtx.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog KNOWNBUG LICENSE NEWS README README.linux TODO
102 %attr(755,root,root) %{_libdir}/libdmtx.so.*.*.*
103 %ghost %{_libdir}/libdmtx.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libdmtx.so
108 %{_includedir}/dmtx.h
109 %{_pkgconfigdir}/libdmtx.pc
110 %{_mandir}/man3/libdmtx.3*
This page took 0.048882 seconds and 3 git commands to generate.