]> git.pld-linux.org Git - packages/libdmapsharing.git/blob - libdmapsharing.spec
- up to 2.9.39, but still doesn't build with current vala
[packages/libdmapsharing.git] / libdmapsharing.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # static library build
5
6 Summary:        A DMAP client and server library
7 Summary(pl.UTF-8):      Biblioteka klienta i serwera DMAP
8 Name:           libdmapsharing
9 Version:        2.9.39
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 #Source0Download: https://www.flyn.org/projects/libdmapsharing/download.html
14 Source0:        https://www.flyn.org/projects/libdmapsharing/%{name}-%{version}.tar.gz
15 # Source0-md5:  70eacb930147f703b39aa12c089d6ca1
16 Patch0:         floorf.patch
17 URL:            https://www.flyn.org/projects/libdmapsharing/index.html
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  avahi-glib-devel >= 0.6
21 BuildRequires:  gdk-pixbuf2-devel >= 2.0
22 BuildRequires:  glib2-devel >= 1:2.36
23 BuildRequires:  gobject-introspection-devel >= 1.30.0
24 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
25 BuildRequires:  gtk-doc >= 1.0
26 # noinst programs only
27 #BuildRequires: gtk+2-devel >= 2.0
28 #BuildRequires: libgee-devel >= 0.8
29 BuildRequires:  libsoup-devel >= 2.48.0
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig
32 # not needed for releases, noinst only
33 #BuildRequires: vala >= 1:0.11.4
34 BuildRequires:  zlib-devel
35 Requires:       avahi-glib >= 0.6
36 Requires:       glib2 >= 1:2.36
37 Requires:       libsoup >= 2.48.0
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 libdmapsharing is a library you may use to access and share DMAP (DAAP
42 & DPAP) content. The library is written in C using GObject and
43 libsoup.
44
45 The DMAP family of protocols are used by products such as iTunes(TM),
46 iPhoto(TM) and the Roku SoundBridge(TM) family to share content such
47 as music and photos.
48
49 %description -l pl.UTF-8
50 libdmapsharing to biblioteka służąca do dostępu i współdzielenia
51 treści DMAP (DAAP i DPAP). Biblioteka jest napisana w C z użyciem
52 bibliotek GObject i libsoup.
53
54 Rodzina protokołów DMAP jest wykorzystywana przez produkty takie jak
55 iTunes(TM), iPhoto(TM) oraz Roku SoundBridge do współdzielenia treści
56 takich jak muzyka czy zdjęcia.
57
58 %package devel
59 Summary:        Files needed to develop applications using libdmapsharing
60 Summary(pl.UTF-8):      Pliki niezbędne do tworzenia aplikacji wykorzystujących libdmapsharing
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       avahi-glib-devel >= 0.6
64 Requires:       gdk-pixbuf2-devel >= 2.0
65 Requires:       glib2-devel >= 1:2.36
66 Requires:       gstreamer-plugins-base-devel >= 1.0
67 Requires:       libsoup-devel >= 2.32.2
68
69 %description devel
70 libdmapsharing implements the DMAP protocols. This includes support
71 for DAAP and DPAP. This package provides the include files and other
72 resources needed for developing applications using libdmapsharing.
73
74 %description devel -l pl.UTF-8
75 libdmapsharing implementuje protokoły DMAP. Obejmuje obsługę DAAP i
76 DPAP. Ten pakiet zawiera pliki nagłówkowe i inne niezbędne do
77 tworzenia aplikacji wykorzystujących libdmapsharing.
78
79 %package static
80 Summary:        Static libdmapsharing library
81 Summary(pl.UTF-8):      Statyczna biblioteka libdmapsharing
82 Group:          Development/Libraries
83 Requires:       %{name}-devel = %{version}-%{release}
84
85 %description static
86 Static libdmapsharing library.
87
88 %description static -l pl.UTF-8
89 Statyczna biblioteka libdmapsharing.
90
91 %package apidocs
92 Summary:        libdmapsharing API documentation
93 Summary(pl.UTF-8):      Dokumentacja API biblioteki libdmapsharing
94 Group:          Documentation
95 %if "%{_rpmversion}" >= "5"
96 BuildArch:      noarch
97 %endif
98
99 %description apidocs
100 API documentation for libdmapsharing library.
101
102 %description apidocs -l pl.UTF-8
103 Dokumentacja API biblioteki libdmapsharing.
104
105 %package -n vala-libdmapsharing
106 Summary:        Vala API for libdmapsharing library
107 Summary(pl.UTF-8):      API języka Vala do biblioteki libdmapsharing
108 Group:          Development/Libraries
109 Requires:       %{name}-devel = %{version}-%{release}
110 Requires:       vala >= 1:0.11.4
111 %if "%{_rpmversion}" >= "5"
112 BuildArch:      noarch
113 %endif
114
115 %description -n vala-libdmapsharing
116 Vala API for libdmapsharing library.
117
118 %description -n vala-libdmapsharing -l pl.UTF-8
119 API języka Vala do biblioteki libdmapsharing.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --disable-silent-rules \
133         %{?with_static_libs:--enable-static} \
134         --with-html-dir=%{_gtkdocdir} \
135         --with-mdns=avahi
136
137 %{__make}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 %{__make} install \
142         INSTALL="install -p" \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdmapsharing-3.0.la
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README README-Memory TODO
156 %attr(755,root,root) %{_libdir}/libdmapsharing-3.0.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libdmapsharing-3.0.so.2
158 %{_libdir}/girepository-1.0/DMAP-3.0.typelib
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libdmapsharing-3.0.so
163 %{_includedir}/libdmapsharing-3.0
164 %{_datadir}/gir-1.0/DMAP-3.0.gir
165 %{_pkgconfigdir}/libdmapsharing-3.0.pc
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libdmapsharing-3.0.a
171 %endif
172
173 %if %{with apidocs}
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/libdmapsharing-3.0
177 %endif
178
179 %files -n vala-libdmapsharing
180 %defattr(644,root,root,755)
181 %{_datadir}/vala/vapi/libdmapsharing-3.0.vapi
This page took 0.103597 seconds and 3 git commands to generate.