]> git.pld-linux.org Git - packages/libdecaf.git/blob - libdecaf.spec
- added cmake patch, fix export file and include paths
[packages/libdecaf.git] / libdecaf.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Elliptic curve library
6 Summary(pl.UTF-8):      Biblioteka krzywych eliptycznych
7 Name:           libdecaf
8 Version:        1.0.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/ed448goldilocks/%{name}-%{version}.tgz
13 # Source0-md5:  48b57dc6ff6be56930f0be2a5722a70e
14 Patch0:         %{name}-cmake.patch
15 URL:            http://ed448goldilocks.sourceforge.net/
16 BuildRequires:  cmake >= 3.0
17 BuildRequires:  doxygen
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  python >= 1:2.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The libdecaf library is for elliptic curve research and practical
24 application. It currently supports Ed448-Goldilocks and Curve25519.
25
26 %description -l pl.UTF-8
27 Biblioteka libdecaf służy do badań i praktycznych zastosowań krzywych
28 eliptycznych. Obecnie obsługuje Ed448-Goldilocks oraz Curve25519.
29
30 %package devel
31 Summary:        Header files for decaf library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki decaf
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for decaf library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki decaf.
41
42 %package static
43 Summary:        Static decaf library
44 Summary(pl.UTF-8):      Statyczna biblioteka decaf
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static decaf library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka decaf.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57
58 %build
59 install -d build
60 cd build
61 %cmake .. \
62         %{!?with_static_libs:-DENABLE_STATIC=OFF}
63
64 %{__make} -j1
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} -C build install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post   -p /sbin/ldconfig
76 %postun -p /sbin/ldconfig
77
78 %files
79 %defattr(644,root,root,755)
80 %doc HISTORY.txt LICENSE.txt README.md TODO.txt
81 %attr(755,root,root) %{_libdir}/libdecaf.so.0
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libdecaf.so
86 %{_includedir}/decaf
87 %{_includedir}/decaf.h
88 %{_includedir}/decaf.hxx
89 %dir %{_datadir}/decaf
90 %{_datadir}/decaf/cmake
91
92 %if %{with static_libs}
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/libdecaf.a
96 %endif
This page took 0.058298 seconds and 3 git commands to generate.