]> git.pld-linux.org Git - packages/libdecaf.git/blob - libdecaf.spec
81105840e4e33747995c9cdd31a667e9a0d0876f
[packages/libdecaf.git] / libdecaf.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Elliptic curve library
6 Summary(pl.UTF-8):      Biblioteka krzywych eliptycznych
7 Name:           libdecaf
8 Version:        1.0.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/ed448goldilocks/%{name}-%{version}.tgz
13 # Source0-md5:  48b57dc6ff6be56930f0be2a5722a70e
14 #Patch0:        %{name}-what.patch
15 URL:            http://ed448goldilocks.sourceforge.net/
16 BuildRequires:  cmake >= 3.0
17 BuildRequires:  doxygen
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  python >= 1:2.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The libdecaf library is for elliptic curve research and practical
24 application. It currently supports Ed448-Goldilocks and Curve25519.
25
26 %description -l pl.UTF-8
27 Biblioteka libdecaf służy do badań i praktycznych zastosowań krzywych
28 eliptycznych. Obecnie obsługuje Ed448-Goldilocks oraz Curve25519.
29
30 %package devel
31 Summary:        Header files for decaf library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki decaf
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for decaf library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki decaf.
41
42 %package static
43 Summary:        Static decaf library
44 Summary(pl.UTF-8):      Statyczna biblioteka decaf
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static decaf library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka decaf.
53
54 %prep
55 %setup -q
56
57 %build
58 install -d build
59 cd build
60 %cmake .. \
61         %{!?with_static_libs:-DENABLE_STATIC=OFF}
62
63 %{__make} -j1
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc HISTORY.txt LICENSE.txt README.md TODO.txt
80 %attr(755,root,root) %{_libdir}/libdecaf.so.0
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libdecaf.so
85 %{_includedir}/decaf
86 %dir %{_datadir}/decaf
87 %{_datadir}/decaf/cmake
88
89 %if %{with static_libs}
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libdecaf.a
93 %endif
This page took 0.040892 seconds and 2 git commands to generate.