]> git.pld-linux.org Git - packages/libdc1394.git/blob - libdc1394.spec
BR SDL-devel
[packages/libdc1394.git] / libdc1394.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     v4l1    # build with Video4Linux 1.x API (dropped in linux kernel 2.6.38)
5
6 Summary:        Library for 1394 Digital Camera Specification
7 Summary(pl.UTF-8):      Biblioteka dla specyfikacji Kamera Cyfrowa 1394
8 Name:           libdc1394
9 Version:        2.2.1
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libdc1394/%{name}-%{version}.tar.gz
14 # Source0-md5:  5c4b78bb8265d6dc971433ec1da381ab
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-ac.patch
17 # libdc1394-2.1.2 vs libdc1394_avt-2.1.2 diff (http://www.alliedvisiontec.com/fileadmin/content/PDF/Software/AVT_software/zip_files/AVTFire4Linux3v0.src.tar/libdc1394_avt-2.1.2.tar.gz)
18 Patch2:         %{name}-avt.patch
19 URL:            http://damien.douxchamps.net/ieee1394/libdc1394/
20 BuildRequires:  SDL-devel
21 BuildRequires:  autoconf >= 2.60
22 BuildRequires:  automake >= 1:1.9.6
23 BuildRequires:  libraw1394-devel >= 1.2.0
24 BuildRequires:  libtool
25 BuildRequires:  libusb-devel >= 1.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.583
28 BuildRequires:  xorg-lib-libX11-devel
29 BuildRequires:  xorg-lib-libXext-devel
30 BuildRequires:  xorg-lib-libXv-devel
31 Requires:       libraw1394 >= 1.2.0
32 Requires:       libusb >= 1.0
33 Provides:       libdc1394(avt) = %{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %ifarch x32
37 # Unresolved symbols pthread_join pthread_create on x32
38 %define         skip_post_check_so      libdc1394.so
39 %endif
40
41 %description
42 libdc1394 is a library that is intended to provide a high level
43 programming interface for application developers who wish to control
44 IEEE 1394 based cameras that conform to the 1394-based Digital Camera
45 Specification (found at http://www.1394ta.org/).
46
47 %description -l pl.UTF-8
48 libdc1394 jest biblioteką, której założeniem jest dostarczenie
49 interfejsu wysokiego poziomu dla twórców oprogramowania pragnących
50 sterować kamerami skonstruowanymi w oparciu o IEEE 1394 zgodnie ze
51 specyfikacją Kamera Cyfrowa 1394 (dostępną pod
52 http://www.1394ta.org/).
53
54 %package devel
55 Summary:        libdc1394 header files
56 Summary(pl.UTF-8):      Pliki nagłówkowe libdc1394
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libraw1394-devel >= 1.2.0
60 Requires:       libusb-devel >= 1.0
61 Provides:       libdc1394-devel(avt) = %{version}-%{release}
62
63 %description devel
64 libdc1394 header files.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe libdc1394.
68
69 %package static
70 Summary:        Static libdc1394 library
71 Summary(pl.UTF-8):      Statyczna biblioteka libdc1394
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74 Provides:       libdc1394-static(avt) = %{version}-%{release}
75
76 %description static
77 Static libdc1394 library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka libdc1394.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{!?with_static_libs:--disable-static}
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 # man pages for noinst examples
105 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dc1394_multiview,grab_{color,gray,partial}_image}.1
106 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/avt_singleview.1
107
108 %if %{without v4l1}
109 # dc1394_vloopback not built if !HAVE_VIDEODEV, remove man page as well
110 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dc1394_vloopback.1
111 %endif
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS ChangeLog NEWS README
122 %attr(755,root,root) %{_bindir}/dc1394_reset_bus
123 %attr(755,root,root) %{_libdir}/libdc1394.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libdc1394.so.22
125 %{_mandir}/man1/dc1394_reset_bus.1*
126 %if %{with v4l1}
127 %attr(755,root,root) %{_bindir}/dc1394_vloopback
128 %{_mandir}/man1/dc1394_vloopback.1*
129 %endif
130
131 %files devel
132 %defattr(644,root,root,755)
133 %attr(755,root,root) %{_libdir}/libdc1394.so
134 %{_libdir}/libdc1394.la
135 %{_includedir}/dc1394
136 %{_pkgconfigdir}/libdc1394-2.pc
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libdc1394.a
142 %endif
This page took 0.105129 seconds and 3 git commands to generate.