]> git.pld-linux.org Git - packages/libdatrie.git/blob - libdatrie.spec
70cbb30f3c2431f3c22ed2c8f78de4314d8571eb
[packages/libdatrie.git] / libdatrie.spec
1 Summary:        Double-Array Trie library
2 Summary(pl.UTF-8):      Biblioteka dwutablicowego trie
3 Name:           libdatrie
4 Version:        0.2.12
5 Release:        1
6 License:        LGPL v2.1
7 Group:          Libraries
8 Source0:        https://linux.thai.net/pub/thailinux/software/libthai/%{name}-%{version}.tar.xz
9 # Source0-md5:  b2243d583e25925200c134fad9f2fb50
10 URL:            https://linux.thai.net/projects/datrie
11 BuildRequires:  doxygen >= 1:1.8.8
12 BuildRequires:  tar >= 1:1.22
13 BuildRequires:  xz
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 datrie is an implementation of double-array structure for representing
18 trie, as proposed by Junichi Aoe.
19
20 Trie is a kind of digital search tree, an efficient indexing method
21 with O(1) time complexity for searching. Comparably as efficient as
22 hashing, trie also provides flexibility on incremental matching and
23 key spelling manipulation. This makes it ideal for lexical analyzers,
24 as well as spelling dictionaries.
25
26 %description -l pl.UTF-8
27 datrie to implementacja struktury dwutablicowej do reprezentowania
28 trie, zaproponowanej przez Junichi Aoe.
29
30 Trie to rodzaj binarnego drzewa wyszukiwań, czyli wydajnej metody
31 indeksowania ze złożonością czasową wyszukiwania O(1). Porównując trie
32 jest tak wydajne jak haszowanie, ale zapewnia też elastyczność
33 przyrostowego dopasowywania i manipulacji pisownią klucza. To czyni je
34 idealnym dla analizatorów leksykalnych, a także sprawdzania pisowni.
35
36 %package devel
37 Summary:        Header files for datrie library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki datrie
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for datrie library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki datrie.
47
48 %package static
49 Summary:        Static datrie library
50 Summary(pl.UTF-8):      Statyczna biblioteka datrie
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static datrie library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka datrie.
59
60 %prep
61 %setup -q
62
63 %build
64 %configure
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 # packaged as %doc
74 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/{datrie,libdatrie}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog NEWS README
85 %attr(755,root,root) %{_bindir}/trietool
86 %attr(755,root,root) %{_bindir}/trietool-0.2
87 %attr(755,root,root) %{_libdir}/libdatrie.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libdatrie.so.1
89 %{_mandir}/man1/trietool.1*
90 %{_mandir}/man1/trietool-0.2.1*
91
92 %files devel
93 %defattr(644,root,root,755)
94 %doc doc/html/* README.migration
95 %attr(755,root,root) %{_libdir}/libdatrie.so
96 %{_libdir}/libdatrie.la
97 %{_includedir}/datrie
98 %{_pkgconfigdir}/datrie-0.2.pc
99
100 %files static
101 %defattr(644,root,root,755)
102 %{_libdir}/libdatrie.a
This page took 0.040153 seconds and 2 git commands to generate.