]> git.pld-linux.org Git - packages/libdap.git/blob - libdap.spec
944041c43f7316c25e77057f01b60c622a086312
[packages/libdap.git] / libdap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform tests
4 #
5 Summary:        OPeNDAP C++ implementation of the Data Access Protocol
6 Summary(pl.UTF-8):      OPeNDAP - implementacja w C++ protokołu DAP (Data Access Protocol)
7 Name:           libdap
8 Version:        3.17.3
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://www.opendap.org/pub/source/%{name}-%{version}.tar.gz
13 # Source0-md5:  511074909a0c58a4e0669449188f1102
14 URL:            http://opendap.org/
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake
17 BuildRequires:  bison >= 3.0
18 %{?with_tests:BuildRequires:    cppunit-devel >= 1.12.0}
19 BuildRequires:  curl-devel >= 7.19.0
20 BuildRequires:  flex
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  libuuid-devel
24 BuildRequires:  libxml2-devel >= 1:2.7.0
25 BuildRequires:  pkgconfig
26 Requires:       curl >= 7.19.0
27 Requires:       libxml2 >= 1:2.7.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This package contains the OPeNDAP C++ implementation of the Data
32 Access Protocol version 2 (DAP2) with some extensions that will be
33 part of DAP3.
34
35 The DAP2 is used to provide a uniform way of accessing a variety of
36 different types of data across the Internet. It was originally part of
37 the DODS and then NVODS projects. The focus of those projects was
38 access to Earth-Science data, so much of the software developed using
39 the DAP2 to date has centered on that discipline. However, the DAP2
40 data model is very general (and similar to a modern structured
41 programming language) so it can be applied to a wide variety of
42 fields.
43
44 %description -l pl.UTF-8
45 Ten pakiet zawiera OPeNDAP - implementację w C++ protokołu dostępu do
46 danych Data Access Protocol w wersji 2 (DAP2) z pewnymi
47 rozszerzeniami, które będą częścią DAP3.
48
49 DAP2 ma za zadanie udostępnienie jednolitego sposobu dostępu do wielu
50 różnych rodzajów danych w Internecie. Był oryginalnie częścią
51 projektów DODS, a następnie NVODS. Projekty te skupiały się na
52 dostępie do danych Earth-Science, więc większość programów
53 tworzonych przy użyciu DAP2 była związana z tą dyscypliną nauki.
54 Jednak model danych DAP2 jest bardzo ogólny (i podobny do
55 współczesnych strukturalnych języków programowania), więc może
56 dotyczyć wielu różnych dziedzin.
57
58 %package devel
59 Summary:        Header files for OPeNDAP library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki OPeNDAP
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       curl-devel >= 7.19.0
64 Requires:       libstdc++-devel
65 Requires:       libuuid-devel
66 Requires:       libxml2-devel >= 1:2.7.0
67
68 %description devel
69 Header files for OPeNDAP library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki OPeNDAP.
73
74 %package static
75 Summary:        Static OPeNDAP library
76 Summary(pl.UTF-8):      Statyczna biblioteka OPeNDAP
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static OPeNDAP library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka OPeNDAP.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I conf -I gl/m4
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure
96 %{__make}
97
98 %{?with_tests:%{__make} check}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # obsoleted by pkg-config
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdap*.la
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc COPYRIGHT_* NEWS README*
118 %attr(755,root,root) %{_bindir}/getdap
119 %attr(755,root,root) %{_bindir}/getdap4
120 %attr(755,root,root) %{_libdir}/libdap.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libdap.so.23
122 %attr(755,root,root) %{_libdir}/libdapclient.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libdapclient.so.6
124 %attr(755,root,root) %{_libdir}/libdapserver.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libdapserver.so.7
126 %{_mandir}/man1/getdap.1*
127 %{_mandir}/man1/getdap4.1*
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/dap-config
132 %attr(755,root,root) %{_bindir}/dap-config-pkgconfig
133 %attr(755,root,root) %{_libdir}/libdap.so
134 %attr(755,root,root) %{_libdir}/libdapclient.so
135 %attr(755,root,root) %{_libdir}/libdapserver.so
136 %{_libdir}/libtest-types.a
137 %{_includedir}/libdap
138 %{_pkgconfigdir}/libdap.pc
139 %{_pkgconfigdir}/libdapclient.pc
140 %{_pkgconfigdir}/libdapserver.pc
141 %{_aclocaldir}/libdap.m4
142 %{_mandir}/man1/dap-config.1*
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libdap.a
147 %{_libdir}/libdapclient.a
148 %{_libdir}/libdapserver.a
This page took 0.060021 seconds and 2 git commands to generate.