]> git.pld-linux.org Git - packages/libcroco.git/blob - libcroco.spec
- updated to 0.6.11
[packages/libcroco.git] / libcroco.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 %define         mver    0.6
6 Summary:        A CSS2 parsing library
7 Summary(pl.UTF-8):      Biblioteka analizująca CSS2
8 Name:           libcroco
9 Version:        0.6.11
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libcroco/0.6/%{name}-%{version}.tar.xz
14 # Source0-md5:  dabc1911dfbfa85f8e6859ca47863168
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.13
17 BuildRequires:  glib2-devel >= 1:2.12.0
18 BuildRequires:  gtk-doc >= 1.0
19 BuildRequires:  gtk-doc-automake >= 1.0
20 BuildRequires:  libtool >= 2:2.0
21 BuildRequires:  libxml2-devel >= 1:2.6.26
22 BuildRequires:  pkgconfig >= 1:0.8
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       glib2 >= 1:2.12.0
26 Requires:       libxml2 >= 1:2.6.26
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 CSS2 parsing and manipulation library for GNOME.
31
32 %description -l pl.UTF-8
33 Biblioteka analizująca i obrabiająca CSS2 dla GNOME.
34
35 %package devel
36 Summary:        Header files for developing with libcroco
37 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia programów używających libcroco
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       glib2-devel >= 1:2.12.0
41 Requires:       libxml2-devel >= 1:2.6.26
42
43 %description devel
44 This package provides the necessary header files files to allow you to
45 develop with libcroco.
46
47 %description devel -l pl.UTF-8
48 Ten pakiet dostarcza pliki nagłówkowe potrzebne do tworzenia
49 oprogramowania korzystającego z libcroco.
50
51 %package static
52 Summary:        Static version of libcroco library
53 Summary(pl.UTF-8):      Statyczna wersja biblioteki libcroco
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static version of libcroco library.
59
60 %description static -l pl.UTF-8
61 Statyczna wersja biblioteki libcroco.
62
63 %prep
64 %setup -q
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__autoheader}
71 %{__automake}
72 %configure \
73         --disable-silent-rules \
74         %{!?with_static_libs:--disable-static} \
75         --with-html-dir=%{_gtkdocdir}
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 install docs/examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS ChangeLog NEWS README TODO
96 %attr(755,root,root) %{_bindir}/csslint-%{mver}
97 %attr(755,root,root) %{_libdir}/libcroco-%{mver}.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libcroco-%{mver}.so.3
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc docs/usage.txt
103 %attr(755,root,root) %{_bindir}/croco-%{mver}-config
104 %attr(755,root,root) %{_libdir}/libcroco-%{mver}.so
105 %{_includedir}/libcroco-%{mver}
106 %{_libdir}/libcroco-%{mver}.la
107 %{_pkgconfigdir}/libcroco-%{mver}.pc
108 %{_examplesdir}/%{name}-%{version}
109 %{_gtkdocdir}/libcroco
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libcroco-%{mver}.a
115 %endif
This page took 0.068235 seconds and 3 git commands to generate.