]> git.pld-linux.org Git - packages/libconfini.git/blob - libconfini.spec
447ec826d8aa47c044608c7cec72772d9d632bda
[packages/libconfini.git] / libconfini.spec
1 Summary:        simple INI parsing library
2 Summary(pl.UTF-8):      prosta biblioteka analizy plików INI
3 Name:           libconfini
4 Version:        1.8.2
5 Release:        1
6 License:        GPL v3
7 Group:          Libraries
8 Source0:        https://github.com/madmurphy/libconfini/archive/%{version}.tar.gz
9 # Source0-md5:  c52e06253ff9f4cf4cb66cc43d13553c
10 URL:            https://madmurphy.github.io/libconfini/html/index.html
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  intltool
14 BuildRequires:  libtool
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 libconfini is the ultimate and most consistent INI file parser library
19 written in C. It focuses on standardization and parsing exactness and
20 is at ease with almost every type of file containing key/value pairs.
21
22 The library is fast and suitable for embedded systems. Its algorithms
23 are written from scratch and do not depend on any external library,
24 except for the C standard headers stdio.h, stdlib.h and stdint.h.
25
26 Rather than storing the parsed data, libconfini gives the developer
27 the freedom to choose what to do with them through a custom callback
28 invoked for each INI node read. The API has been designed to be
29 powerful, flexible and simple to use.
30
31 With libconfini you will find in INI files the same serialization
32 power you would normally find in other heavily structured formats
33 (such as JXON, YAML, TOML), but with the advantage of using the most
34 human-readable configuration format ever invented (thanks to their
35 informal status, INI files are indeed more fluid and human-readable
36 than formats explicitly designed with this purpose, such as YAML and
37 TOML).
38
39 %description -l pl.UTF-8
40 libconfini to najlepsza i najbardziej spójna biblioteka analizatorów
41 plików INI napisana w języku C. Skupia się ona na standaryzacji i
42 analizie dokładności i jest łatwa w prawie każdym typie pliku
43 zawierającego pary klucz / wartość.
44
45 Biblioteka jest szybka i odpowiednia dla systemów wbudowanych. Jego
46 algorytmy są napisane od podstaw i nie zależą od żadnej zewnętrznej
47 biblioteki, z wyjątkiem standardowych nagłówków C stdio.h, stdlib.h i
48 stdint.h.
49
50 Zamiast przechowywać przeanalizowane dane, libconfini daje
51 programistom swobodę wyboru, co z nimi zrobić za pomocą
52 niestandardowego wywołania zwrotnego wywoływanego dla każdego
53 czytanego węzła INI. Interfejs API został zaprojektowany tak, aby był
54 wydajny, elastyczny i prosty w użyciu.
55
56 Z libconfini znajdziesz w plikach INI tę samą moc serializacji, jaką
57 zwykle można znaleźć w innych silnie ustrukturyzowanych formatach
58 (takich jak JXON, YAML, TOML), ale z zaletą użycia najbardziej
59 czytelnego formatu konfiguracji, jaki kiedykolwiek wymyślono (dzięki
60 ich status nieformalny, pliki INI są rzeczywiście bardziej płynne i
61 czytelne dla człowieka niż formaty wyraźnie zaprojektowane w tym celu,
62 takie jak YAML i TOML).
63
64 %package devel
65 Summary:        Header files for %{name} library
66 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description devel
71 Header files for %{name} library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki %{name}.
75
76 %package static
77 Summary:        Static %{name} library
78 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static %{name} library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka %{name}.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96 %configure
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog* MANUAL.md NEWS RATIONALE.md README* examples/ docs/html docs/manual.html
116 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.0
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/%{name}.so
122 %{_mandir}/man3/IniDispatch.3*
123 %{_mandir}/man3/IniFormat.3*
124 %{_mandir}/man3/IniStatistics.3*
125 %{_mandir}/man3/confini.h.3*
126 %{_mandir}/man3/libconfini.3*
127 %{_libdir}/libconfini.la
128 %{_includedir}/confini.h
129 %{_pkgconfigdir}/libconfini-1.8.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/%{name}.a
This page took 0.049792 seconds and 2 git commands to generate.