]> git.pld-linux.org Git - packages/libcmrt.git/blob - libcmrt.spec
- rel up due to libva soname change
[packages/libcmrt.git] / libcmrt.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C for Media Runtime - media GPU kernel manager for Intel GPUs
6 Summary(pl.UTF-8):      C for Media Runtime - zarządca jąder GPU dla układów Intela
7 Name:           libcmrt
8 Version:        1.0.5
9 Release:        4
10 License:        MIT
11 Group:          Libraries
12 Source0:        https://github.com/01org/cmrt/archive/%{version}.tar.gz
13 # Source0-md5:  9a1afc0c0b24f4bac6c629aa5a57e41e
14 Patch0:         x32.patch
15 URL:            https://github.com/01org/cmrt
16 BuildRequires:  libdrm-devel >= 2.4.23
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libva-devel >= 1.2.0
19 BuildRequires:  pkgconfig
20 BuildRequires:  pkgconfig(libva) >= 0.34
21 Requires:       libdrm >= 2.4.23
22 Requires:       libva >= 1.2.0
23 ExclusiveArch:  %{ix86} %{x8664} x32
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 One solution to expose Intel's Gen GPU's high performance through high
28 level language.
29
30 Features:
31 - Interface between host program and driver
32 - Manage Gen device
33 - Manage surfaces
34 - Manage media GPU kernels
35 - Manage events
36 - Manage threads
37 - Manage execution
38 - Prepare media GPU kernel arguments
39 - Transfer data between system and GPU memory
40 - Report errors
41
42 %description -l pl.UTF-8
43 Rozwiązanie mające na celu udostępnienie wysokiej wydajności
44 procesorów graficznych (GPU) Intel Gen poprzez język wysokopoziomowy.
45
46 Możliwości:
47 - interfejs między programem hostującym a sterownikiem
48 - zarządzanie urządzeniem Gen
49 - zarządzanie powierzchniami
50 - zarządzanie jądrami GPU
51 - zarządzanie zdarzeniami
52 - zarządzanie wątkami
53 - zarządzanie wykonywaniem
54 - przygotowywanie argumentów dla jąder GPU
55 - przesyłanie pamięci między pamięcią systemową a GPU
56 - raportowanie błędów
57
58 %package devel
59 Summary:        Header files for CMRT library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMRT
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libdrm-devel >= 2.4.23
64 Requires:       libva-devel >= 1.2.0
65
66 %description devel
67 Header files for CMRT library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki CMRT.
71
72 %package static
73 Summary:        Static CMRT library
74 Summary(pl.UTF-8):      Statyczna biblioteka CMRT
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static CMRT library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka CMRT.
83
84 %prep
85 %setup -q -n cmrt-%{version}
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --disable-silent-rules \
96         %{?with_static_libs:--enable-static}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 # obsoleted by pkg-config
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcmrt.la
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS COPYING NEWS
118 %attr(755,root,root) %{_libdir}/libcmrt.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libcmrt.so.1
120 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cmrt.conf
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libcmrt.so
125 %{_includedir}/cm_rt*.h
126 %{_pkgconfigdir}/cmrt.pc
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libcmrt.a
132 %endif
This page took 0.060808 seconds and 3 git commands to generate.