]> git.pld-linux.org Git - packages/libcmis.git/blob - libcmis.spec
412bab7c74c207543c814eaf8ef3ffb4117733f0
[packages/libcmis.git] / libcmis.spec
1 #
2 # Conditonal build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A C++ client library for the CMIS interface
6 Summary(pl.UTF-8):     Biblioteka klienta C++ dla inferfejsu CMIS
7 Name:           libcmis
8 Version:        0.2.3
9 Release:        2
10 License:        GPL v2+ or LGPL v2+ or MPL v1.1
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
13 # Source0-md5:  0d2dcdfbf28d6208751b33057f5361f0
14 URL:            http://sourceforge.net/projects/libcmis/
15 BuildRequires:  boost-devel
16 BuildRequires:  curl-devel >= 7.12.3
17 BuildRequires:  docbook2X
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libxml2-devel >= 2.0
20 BuildRequires:  pkgconfig
21 Requires:       curl-libs >= 7.12.3
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 LibCMIS is a C++ client library for the CMIS interface. This allows
26 C++ applications to connect to any ECM behaving as a CMIS server like
27 Alfresco, Nuxeo for the open source ones.
28
29 %description -l pl.UTF-8
30 LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona 
31 aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
32 serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
33 o otwartych źródłach).
34
35 %package devel
36 Summary:        Development files for CMIS library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMIS
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       boost-devel
41 Requires:       curl-devel >= 7.12.3
42 Requires:       libstdc++-devel
43 Requires:       libxml2-devel >= 2.0
44
45 %description devel
46 This package contains the header files for developing applications
47 that use CMIS library.
48
49 %description devel -l pl.UTF-8
50 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
51 bibliotece CMIS
52
53 %package static
54 Summary:        Static CMIS library
55 Summary(pl.UTF-8):      Statyczna biblioteka CMIS
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static CMIS library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka CMIS.
64
65 %package tools
66 Summary:        Command line tool to access CMIS
67 Summary(pl.UTF-8):      Narzędzie wiersza poleceń dla CMIS
68 Group:          Applications/Publishing
69 Requires:       %{name} = %{version}-%{release}
70
71 %description tools
72 This package contains a tool for accessing CMIS from the command line.
73
74 %description tools -l pl.UTF-8
75 Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
76 poleceń.
77
78 %prep
79 %setup -q
80 sed -i -e 's/docbook-to-man/docbook2X2man/' configure
81
82 %build
83 %configure \
84         %{!?with_static_libs:--disable-static} \
85         --disable-tests \
86         --disable-werror
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 cp -p %{name}-0.2.pc %{buildroot}/%{_libdir}/pkgconfig
99
100 # obsoleted by pkg-config
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS ChangeLog NEWS README
112 %attr(755,root,root) %{_libdir}/%{name}-0.2.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libcmis-0.2.so.2
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/%{name}-0.2.so
118 %{_includedir}/%{name}-0.2
119 %{_pkgconfigdir}/libcmis-0.2.pc
120
121 %if %{with static_libs}
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libcmis-0.2.a
125 %endif
126
127 %files tools
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/cmis-client
130 %{_mandir}/man1/cmis-client.1*
This page took 0.106293 seconds and 2 git commands to generate.