]> git.pld-linux.org Git - packages/libcineon.git/blob - libcineon.spec
noarch apidocs
[packages/libcineon.git] / libcineon.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4
5 %define subver  svn13
6 Summary:        Cineon Image Format reader/writer library
7 Summary(pl.UTF-8):      Biblioteka do odczytu/zapisu obrazów w formacie Cineon
8 Name:           libcineon
9 Version:        0.1
10 Release:        2
11 License:        BSD
12 Group:          Libraries
13 # svn checkout http://libcineon.googlecode.com/svn/trunk/ libcineon
14 Source0:        %{name}-%{subver}.tar.xz
15 # Source0-md5:  b2956588f890e86a89a8ce26facac956
16 Patch0:         %{name}-shared.patch
17 Patch1:         %{name}-missing.patch
18 URL:            http://code.google.com/p/libcineon/
19 BuildRequires:  autoconf >= 2.61
20 BuildRequires:  automake
21 %{?with_apidocs:BuildRequires:  doxygen}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Cineon image format reader/writer library written in portable C++,
30 forked off of OpenDPX (<http://dpx.googlecode.com/>).
31
32 %description -l pl.UTF-8
33 Biblioteka do odczytu/zapisu obrazów w formacie Cineon. Jest napisana
34 w przenośnym C++, pierwotny kod wywodzi się z projektu OpenDPX
35 (<http://dpx.googlecode.com/>).
36
37 %package devel
38 Summary:        Header files for Cineon library
39 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Cineon
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 Header files for Cineon library.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe biblioteki Cineon.
48
49 %package static
50 Summary:        Static Cineon library
51 Summary(pl.UTF-8):      Statyczna biblioteka Cineon
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static Cineon library.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka Cineon.
60
61 %package apidocs
62 Summary:        Cineon API documentation
63 Summary(pl.UTF-8):      Dokumentacja API biblioteki Cineon
64 Group:          Documentation
65 %if "%{_rpmversion}" >= "5"
66 BuildArch:      noarch
67 %endif
68
69 %description apidocs
70 API and internal documentation for Cineon library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki Cineon.
74
75 %prep
76 %setup -q -n %{name}
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoconf}
84 %{__automake}
85 %configure \
86         --enable-shared
87 %{__make}
88
89 %if %{with apidocs}
90 cd doc
91 doxygen
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS COPYING README
109 %attr(755,root,root) %{_bindir}/cineon2tiff
110 %attr(755,root,root) %{_bindir}/cineonheader
111 %attr(755,root,root) %{_libdir}/libcineon.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libcineon.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libcineon.so
117 %{_libdir}/libcineon.la
118 %{_includedir}/Cineon*.h
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libcineon.a
123
124 %if %{with apidocs}
125 %files apidocs
126 %defattr(644,root,root,755)
127 %doc doc/html/*.{css,html,js,png}
128 %endif
This page took 0.077022 seconds and 3 git commands to generate.