]> git.pld-linux.org Git - packages/libchipcard.git/blob - libchipcard.spec
3e219e60142cdc5cf843d200bb991fb6840aa43e
[packages/libchipcard.git] / libchipcard.spec
1 # TODO:
2 # - revise split (e.g. which data should go to -tools)
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # static library
6 #
7 Summary:        A library for easy access to smart cards (chipcards)
8 Summary(pl.UTF-8):      Biblioteka łatwego dostępu do kart procesorowych
9 Name:           libchipcard
10 Version:        5.0.4
11 Release:        1
12 License:        LGPL v2.1 with OpenSSL linking exception
13 Group:          Libraries
14 #Source0Download: https://www.aquamaniac.de/sites/download/packages.php
15 Source0:        https://www.aquamaniac.de/sites/download/download.php?package=02&release=200&file=01&dummy=/%{name}-%{version}.tar.gz
16 # Source0-md5:  f26766f5e699899ed8b2b6e6b188de73
17 URL:            https://www.aquamaniac.de/sites/libchipcard/
18 BuildRequires:  autoconf >= 2.60
19 BuildRequires:  automake
20 BuildRequires:  gwenhywfar-devel >= 4.0.0
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  pcsc-lite-devel >= 1.6.2
24 BuildRequires:  pkgconfig
25 BuildRequires:  which
26 BuildRequires:  zlib-devel
27 Requires:       gwenhywfar >= 4.0.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 libchipcard allows easy access to smart cards. It provides basic
32 access to memory and processor cards and has special support for
33 German medical cards, German "GeldKarte" and HBCI (homebanking) cards
34 (both type 0 and type 1). It accesses the readers via CTAPI or IFD
35 interfaces and has successfully been tested with Towitoko, Kobil, SCM,
36 Orga, Omnikey and Reiner-SCT readers.
37
38 %description -l pl.UTF-8
39 libchipcard pozwala na łatwy dostęp do kart procesorowych. Daje
40 podstawowy dostęp do kart pamięciowych i procesorowych, ma także
41 specjalną obsługę niemieckich kart medycznych, niemieckich kart
42 "GeldKarte" oraz kart HBCI (do homebankingu, zarówno typu 0 jak i 1).
43 Z czytnikami komunikuje się poprzez interfejs CTAPI lub IFD, była
44 testowana z czytnikami Towitoko, Kobil, SCM, Orga, Omnikey i
45 Reiner-SCT.
46
47 %package devel
48 Summary:        Header files for libchipcard
49 Summary(pl.UTF-8):      Pliki nagłówkowe libchipcard
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       gwenhywfar-devel >= 4.0.0
53 Requires:       pcsc-lite-devel >= 1.6.2
54 Requires:       zlib-devel
55
56 %description devel
57 This package contains libchipcard-config and header files for writing
58 programs using LibChipCard.
59
60 %description devel -l pl.UTF-8
61 Ten pakiet zawiera libchipcard-config oraz pliki nagłówkowe do
62 tworzenia programów używających LibChipCard.
63
64 %package static
65 Summary:        Static libchipcard library
66 Summary(pl.UTF-8):      Statyczna biblioteka libchipcard
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static libchipcard library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka libchipcard.
75
76 %package tools
77 Summary:        Terminal tools and daemons for libchipcard
78 Summary(pl.UTF-8):      Narzędzia terminalowe i demony dla libchipcard
79 Group:          Applications
80 Requires(post,preun):   /sbin/chkconfig
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       rc-scripts
83
84 %description tools
85 This package contains the terminal tools and daemons for libchipcard.
86 The most important daemon here is chipcardd which is needed to access
87 local card readers.
88
89 %description tools -l pl.UTF-8
90 Ten pakiet zawiera narzędzia terminalowe oraz demony dla libchipcard,
91 w tym najważniejszego demona, chipcardd, potrzebnego do dostępu do
92 lokalnych czytników kart.
93
94 %prep
95 %setup -q
96
97 %build
98 %{__libtoolize}
99 %{__aclocal} -I m4
100 %{__autoconf}
101 %{__autoheader}
102 %{__automake}
103 %configure \
104         %{!?with_static_libs:--disable-static} \
105         --with-init-script-dir=/etc/rc.d/init.d \
106         --with-pcsc-libs=%{_libdir}
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__mv} $RPM_BUILD_ROOT%{_sysconfdir}/chipcard/chipcardc.conf{.default,}
117 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/chipcard/chipcardc.conf.example \
118         $RPM_BUILD_ROOT%{_libdir}/*.la \
119         $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/ct/*.la
120 %if %{with static_libs}
121 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gwenhywfar/plugins/*/ct/*.a
122 %endif
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TODO doc/{CERTIFICATES,CONFIG,IPCCOMMANDS} etc/*.conf.*
133 %attr(755,root,root) %{_libdir}/libchipcard.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libchipcard.so.6
135 %dir %{_datadir}/chipcard
136 %dir %{_datadir}/chipcard/drivers
137 %{_datadir}/chipcard/drivers/*.xml
138 %dir %{_datadir}/chipcard/apps
139 %dir %{_datadir}/chipcard/cards
140 %{_datadir}/chipcard/apps/*.xml
141 %{_datadir}/chipcard/cards/*.xml
142 %dir %{_datadir}/chipcard/cards/cyberjack_pcsc
143 %{_datadir}/chipcard/cards/cyberjack_pcsc/*.xml
144 %dir %{_datadir}/chipcard/cards/generic_pcsc
145 %{_datadir}/chipcard/cards/generic_pcsc/*.xml
146 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/ct/ddvcard.so
147 %{_libdir}/gwenhywfar/plugins/*/ct/ddvcard.xml
148 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/ct/starcoscard.so
149 %{_libdir}/gwenhywfar/plugins/*/ct/starcoscard.xml
150 %attr(755,root,root) %{_libdir}/gwenhywfar/plugins/*/ct/zkacard.so
151 %{_libdir}/gwenhywfar/plugins/*/ct/zkacard.xml
152 # used by libchipcardc
153 %dir %{_sysconfdir}/chipcard
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/chipcard/chipcardc.conf
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/chipcard-config
159 %attr(755,root,root) %{_libdir}/libchipcard.so
160 %{_includedir}/libchipcard5
161 %{_aclocaldir}/chipcard.m4
162
163 %if %{with static_libs}
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libchipcard.a
167 %endif
168
169 %files tools
170 %defattr(644,root,root,755)
171 %attr(755,root,root) %{_bindir}/cardcommander
172 %attr(755,root,root) %{_bindir}/chipcard-tool
173 %attr(755,root,root) %{_bindir}/geldkarte
174 %attr(755,root,root) %{_bindir}/kvkcard
175 %attr(755,root,root) %{_bindir}/memcard
This page took 0.034597 seconds and 2 git commands to generate.