]> git.pld-linux.org Git - packages/libcdio.git/blob - libcdio.spec
- updated to 1.0.0 (note: new libcdio soname)
[packages/libcdio.git] / libcdio.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # disable features to able to build without circular dependencies
4 %bcond_without  cddb            # build cd-info without CDDB lookups (for bootstrap)
5 %bcond_without  static_libs     # don't build static library
6 %bcond_without  vcd             # build cd-info without VCD support (for bootstrap) (affects only *-utils, not libraries)
7
8 %if %{with bootstrap}
9 %undefine       with_cddb
10 %undefine       with_vcd
11 %endif
12
13 Summary:        GNU Compact Disc Input, Output and Control Library
14 Summary(pl.UTF-8):      Biblioteka GNU do obsługi wejścia, wyjścia i sterowania czytnikiem CD
15 Name:           libcdio
16 Version:        1.0.0
17 Release:        1
18 License:        GPL v3+
19 Group:          Libraries
20 Source0:        http://ftp.gnu.org/gnu/libcdio/%{name}-%{version}.tar.bz2
21 # Source0-md5:  9f66508a03f58ddddba4104e378cd54c
22 Patch0:         %{name}-info.patch
23 # http://git.savannah.gnu.org/cgit/libcdio.git/patch/?id=4305bc1e093e4341aeddb857bd1e6203228000cb
24 Patch1:         %{name}-cddb-fix.patch
25 URL:            http://www.gnu.org/software/libcdio/
26 BuildRequires:  autoconf >= 2.61
27 BuildRequires:  automake >= 1:1.8.3
28 # for AM_ICONV and config.rpath
29 BuildRequires:  gettext-tools >= 0.14
30 BuildRequires:  help2man
31 %{?with_cddb:BuildRequires:     libcddb-devel >= 1.0.1}
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtool >= 2:1.5
34 BuildRequires:  ncurses-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  sed >= 4.0
37 BuildRequires:  texinfo
38 %{?with_vcd:BuildRequires:      vcdimager-devel >= 0.7.21}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This library is to encapsulate CD-ROM reading and control.
43 Applications wishing to be oblivious of the OS- and device-dependent
44 properties of a CD-ROM can use this library.
45
46 Some support for disk image types like BIN/CUE and NRG is available,
47 so applications that use this library also have the ability to read
48 disc images as though they were CD's.
49
50 Immediate uses are VCDImager, a navigation-capable Video CD plugin
51 and CD-DA plugin for the media player xine.
52
53 A sample utility, cd-info which displayings CD info is included in
54 utils subpackage.
55
56 %description -l pl.UTF-8
57 Ta biblioteka obudowuje czynności odczytu i sterowania czytnikami
58 CD-ROM. Aplikacje chcące zapomnieć o zależnych od systemu lub
59 urządzenia własnościach CD-ROM-u mogą używać tej biblioteki.
60
61 Dostępna jest pewna obsługa obrazów dysków typu BIN/CUE czy NRG, więc
62 aplikacje używające tej biblioteki mogą czytać także takie obrazy
63 dysków tak jakby były płytami.
64
65 Biblioteka jest używana bezpośrednio w VCDImagerze, wtyczce z
66 nawigacją do Video CD oraz wtyczce CD-DA dla odtwarzacza multimediów
67 xine.
68
69 W podpakiecie utils załączone jest przykładowe narzędzie cd-info
70 służące do wyświetlania informacji o płytach kompaktowych.
71
72 %package devel
73 Summary:        Header files for libcdio libraries
74 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libcdio
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description devel
79 Header files for libcdio libraries.
80
81 %description devel -l pl.UTF-8
82 Pliki nagłówkowe bibliotek libcdio.
83
84 %package static
85 Summary:        Static libcdio libraries
86 Summary(pl.UTF-8):      Statyczne biblioteki libcdio
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89
90 %description static
91 Static libcdio libraries.
92
93 %description static -l pl.UTF-8
94 Statyczne biblioteki libcdio.
95
96 %package c++
97 Summary:        C++ libcdio libraries
98 Summary(pl.UTF-8):      Biblioteki C++ libcdio
99 Group:          Libraries
100 Requires:       %{name} = %{version}-%{release}
101
102 %description c++
103 C++ libcdio libraries.
104
105 %description c++ -l pl.UTF-8
106 Biblioteki C++ libcdio.
107
108 %package c++-devel
109 Summary:        Header files for C++ libcdio libraries
110 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek C++ libcdio
111 Group:          Development/Libraries
112 Requires:       %{name}-c++ = %{version}-%{release}
113 Requires:       %{name}-devel = %{version}-%{release}
114 Requires:       libstdc++-devel
115
116 %description c++-devel
117 Header files for C++ libcdio libraries.
118
119 %description c++-devel -l pl.UTF-8
120 Pliki nagłówkowe bibliotek C++ libcdio.
121
122 %package c++-static
123 Summary:        Static C++ libcdio libraries
124 Summary(pl.UTF-8):      Statyczne biblioteki C++ libcdio
125 Group:          Development/Libraries
126 Requires:       %{name}-c++-devel = %{version}-%{release}
127
128 %description c++-static
129 Static C++ libcdio libraries.
130
131 %description c++-static -l pl.UTF-8
132 Statyczne biblioteki C++ libcdio.
133
134 %package utils
135 Summary:        libcdio utilities: cd-info, cd-read
136 Summary(pl.UTF-8):      Narzędzia używające libcdio: cd-info, cd-read
137 Group:          Applications
138 Requires:       %{name} = %{version}-%{release}
139
140 %description utils
141 libcdio utilities: cd-info, cd-read.
142
143 %description utils -l pl.UTF-8
144 Narzędzia używające libcdio: cd-info, cd-read.
145
146 %prep
147 %setup -q
148 %patch0 -p1
149 %patch1 -p1
150
151 %{__sed} -i 's, example$,,' Makefile.am
152
153 %build
154 cp -f /usr/share/gettext/config.rpath .
155
156 %{__libtoolize}
157 %{__aclocal}
158 %{__autoconf}
159 %{__autoheader}
160 %{__automake}
161 CPPFLAGS="%{rpmcppflags} -I/usr/include/ncurses"
162 %configure \
163         --disable-silent-rules \
164         --enable-cd-info-linux \
165         --enable-maintainer-mode \
166         --enable-rock \
167         %{!?with_cddb:--disable-cddb} \
168         %{!?with_vcd:--disable-vcd-info} \
169         %{!?with_static_libs:--disable-static}
170
171 %{__make}
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT
178
179 # obsoleted by pkg-config
180 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post   -p /sbin/ldconfig
186 %postun -p /sbin/ldconfig
187
188 %post   devel -p /sbin/postshell
189 -/usr/sbin/fix-info-dir -c %{_infodir}
190
191 %postun devel -p /sbin/postshell
192 -/usr/sbin/fix-info-dir -c %{_infodir}
193
194 %post   c++ -p /sbin/ldconfig
195 %postun c++ -p /sbin/ldconfig
196
197 %files
198 %defattr(644,root,root,755)
199 %doc AUTHORS ChangeLog NEWS README THANKS TODO
200 %attr(755,root,root) %{_libdir}/libcdio.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libcdio.so.17
202 %attr(755,root,root) %{_libdir}/libiso9660.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libiso9660.so.10
204 %attr(755,root,root) %{_libdir}/libudf.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libudf.so.0
206
207 %files devel
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_libdir}/libcdio.so
210 %attr(755,root,root) %{_libdir}/libiso9660.so
211 %attr(755,root,root) %{_libdir}/libudf.so
212 %{_includedir}/cdio
213 %{_pkgconfigdir}/libcdio.pc
214 %{_pkgconfigdir}/libiso9660.pc
215 %{_pkgconfigdir}/libudf.pc
216 %{_infodir}/libcdio.info*
217
218 %if %{with static_libs}
219 %files static
220 %defattr(644,root,root,755)
221 %{_libdir}/libcdio.a
222 %{_libdir}/libiso9660.a
223 %{_libdir}/libudf.a
224 %endif
225
226 %files c++
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libcdio++.so.*.*.*
229 %attr(755,root,root) %ghost %{_libdir}/libcdio++.so.0
230 %attr(755,root,root) %{_libdir}/libiso9660++.so.*.*.*
231 %attr(755,root,root) %ghost %{_libdir}/libiso9660++.so.0
232
233 %files c++-devel
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_libdir}/libcdio++.so
236 %attr(755,root,root) %{_libdir}/libiso9660++.so
237 %{_includedir}/cdio++
238 %{_pkgconfigdir}/libcdio++.pc
239 %{_pkgconfigdir}/libiso9660++.pc
240
241 %if %{with static_libs}
242 %files c++-static
243 %defattr(644,root,root,755)
244 %{_libdir}/libcdio++.a
245 %{_libdir}/libiso9660++.a
246 %endif
247
248 %files utils
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_bindir}/cd-drive
251 %attr(755,root,root) %{_bindir}/cd-info
252 %attr(755,root,root) %{_bindir}/cd-read
253 %attr(755,root,root) %{_bindir}/cdda-player
254 %attr(755,root,root) %{_bindir}/cdinfo-linux
255 %attr(755,root,root) %{_bindir}/iso-info
256 %attr(755,root,root) %{_bindir}/iso-read
257 %attr(755,root,root) %{_bindir}/mmc-tool
258 %{_mandir}/man1/cd-drive.1*
259 %{_mandir}/man1/cd-info.1*
260 %{_mandir}/man1/cd-read.1*
261 %{_mandir}/man1/iso-info.1*
262 %{_mandir}/man1/iso-read.1*
This page took 0.087023 seconds and 3 git commands to generate.