]> git.pld-linux.org Git - packages/libbtctl.git/blob - libbtctl.spec
noarch apidoc
[packages/libbtctl.git] / libbtctl.spec
1 #
2 # todo:
3 # - mono bindings (build crashes on ppc)
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # disable gtk-doc
7 %bcond_without  static_libs     # don't build static library
8
9 Summary:        Bluetooth GObject based library
10 Summary(pl.UTF-8):      Biblioteka do programowania urządzeń Bluetooth
11 Name:           libbtctl
12 Version:        0.10.0
13 Release:        9
14 License:        GPL
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libbtctl/0.10/%{name}-%{version}.tar.bz2
17 # Source0-md5:  83d5f90efb2b26d1bd12a668940d02ba
18 Patch0:         %{name}-make-jN.patch
19 Patch1:         %{name}-newapi.patch
20 URL:            http://usefulinc.com/software/gnome-bluetooth/
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake
23 BuildRequires:  bluez-libs-devel >= 2.25
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  gettext-tools
26 BuildRequires:  glib2-devel >= 1:2.12.4
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  libtool
30 BuildRequires:  openobex-devel >= 1.2
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-devel >= 1:2.3
33 BuildRequires:  python-pygtk-devel >= 2.10.3
34 BuildRequires:  rpm-pythonprov
35 Requires:       bluez-libs >= 2.25
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This package contains a library to control Bluetooth devices.
40
41 %description -l pl.UTF-8
42 Ten pakiet zawiera bibliotekę do kontrolowania urządzeń Bluetooth.
43
44 %package devel
45 Summary:        Header files for libbtctl library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbtctl
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       bluez-libs-devel >= 2.25
50 Requires:       glib2-devel >= 1:2.12.4
51 Requires:       openobex-devel >= 1.2
52
53 %description devel
54 Header files for libbtctl library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libbtctl.
58
59 %package static
60 Summary:        Static libbtctl library
61 Summary(pl.UTF-8):      Statyczna biblioteka libbtctl
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libbtctl library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libbtctl.
70
71 %package -n python-btctl
72 Summary:        Python bindings for libbtctl library
73 Summary(pl.UTF-8):      Wiązania dla języka Python biblioteki libbtctl
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       python-libs
77
78 %description -n python-btctl
79 Static libbtctl library.
80
81 %description -n python-btctl -l pl.UTF-8
82 Wiązania dla języka Python biblioteki libbtctl.
83
84 %package apidocs
85 Summary:        libbtctl API documentation
86 Summary(pl.UTF-8):      Dokumentacja API libbtctl
87 Group:          Documentation
88 Requires:       gtk-doc-common
89 %if "%{_rpmversion}" >= "5"
90 BuildArch:      noarch
91 %endif
92
93 %description apidocs
94 libbtctl API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API libbtctl.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoheader}
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         --disable-mono \
112         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
113         --with-html-path=%{_gtkdocdir} \
114         %{!?with_static_libs:--disable-static}
115 %{__make} \
116         pydir=%{py_sitedir}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         HTML_DIR=%{_gtkdocdir} \
124         pydir=%{py_sitedir}
125
126 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
127
128 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
129
130 %find_lang %{name}
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog README
141 %attr(755,root,root) %{_libdir}/libbtctl.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libbtctl.so.4
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libbtctl.so
147 %{_libdir}/libbtctl.la
148 %{_includedir}/%{name}
149 %{_pkgconfigdir}/libbtctl.pc
150
151 %if %{with static_libs}
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libbtctl.a
155 %endif
156
157 %files -n python-btctl
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py_sitedir}/btctl.so
160
161 %if %{with apidocs}
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/libbtctl
165 %endif
This page took 0.156192 seconds and 3 git commands to generate.