]> git.pld-linux.org Git - packages/libbtctl.git/blob - libbtctl.spec
09e48bcfdf6a7c8f5c04c72a8b29f26a6d5c708f
[packages/libbtctl.git] / libbtctl.spec
1 #
2 # todo:
3 # - mono bindings (build crashes on ppc)
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # disable gtk-doc
7 %bcond_without  static_libs     # don't build static library
8 #
9 Summary:        Bluetooth GObject based library
10 Summary(pl.UTF-8):      Biblioteka do programowania urządzeń Bluetooth
11 Name:           libbtctl
12 Version:        0.10.0
13 Release:        8
14 License:        GPL
15 Group:          Libraries
16 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libbtctl/0.10/%{name}-%{version}.tar.bz2
17 # Source0-md5:  83d5f90efb2b26d1bd12a668940d02ba
18 Patch0:         %{name}-make-jN.patch
19 Patch1:         %{name}-newapi.patch
20 URL:            http://usefulinc.com/software/gnome-bluetooth/
21 BuildRequires:  autoconf >= 2.52
22 BuildRequires:  automake
23 BuildRequires:  bluez-libs-devel >= 2.25
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  gettext-tools
26 BuildRequires:  glib2-devel >= 1:2.12.4
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.7}
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  libtool
30 BuildRequires:  openobex-devel >= 1.2
31 BuildRequires:  pkgconfig
32 BuildRequires:  python-devel >= 1:2.3
33 BuildRequires:  python-pygtk-devel >= 2.10.3
34 BuildRequires:  rpm-pythonprov
35 Requires:       bluez-libs >= 2.25
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 This package contains a library to control Bluetooth devices.
40
41 %description -l pl.UTF-8
42 Ten pakiet zawiera bibliotekę do kontrolowania urządzeń Bluetooth.
43
44 %package devel
45 Summary:        Header files for libbtctl library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbtctl
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       bluez-libs-devel >= 2.25
50 Requires:       glib2-devel >= 1:2.12.4
51 Requires:       openobex-devel >= 1.2
52
53 %description devel
54 Header files for libbtctl library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki libbtctl.
58
59 %package static
60 Summary:        Static libbtctl library
61 Summary(pl.UTF-8):      Statyczna biblioteka libbtctl
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libbtctl library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka libbtctl.
70
71 %package -n python-btctl
72 Summary:        Python bindings for libbtctl library
73 Summary(pl.UTF-8):      Wiązania dla języka Python biblioteki libbtctl
74 Group:          Libraries/Python
75 Requires:       %{name} = %{version}-%{release}
76 %pyrequires_eq  python-libs
77
78 %description -n python-btctl
79 Static libbtctl library.
80
81 %description -n python-btctl -l pl.UTF-8
82 Wiązania dla języka Python biblioteki libbtctl.
83
84 %package apidocs
85 Summary:        libbtctl API documentation
86 Summary(pl.UTF-8):      Dokumentacja API libbtctl
87 Group:          Documentation
88 Requires:       gtk-doc-common
89
90 %description apidocs
91 libbtctl API documentation.
92
93 %description apidocs -l pl.UTF-8
94 Dokumentacja API libbtctl.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 %{__libtoolize}
103 %{__aclocal}
104 %{__autoheader}
105 %{__autoconf}
106 %{__automake}
107 %configure \
108         --disable-mono \
109         --%{?with_apidocs:en}%{!?with_apidocs:dis}able-gtk-doc \
110         --with-html-path=%{_gtkdocdir} \
111         %{!?with_static_libs:--disable-static}
112 %{__make} \
113         pydir=%{py_sitedir}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         HTML_DIR=%{_gtkdocdir} \
121         pydir=%{py_sitedir}
122
123 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{la,a}
124
125 %{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}}
126
127 %find_lang %{name}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog README
138 %attr(755,root,root) %{_libdir}/libbtctl.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libbtctl.so.4
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libbtctl.so
144 %{_libdir}/libbtctl.la
145 %{_includedir}/%{name}
146 %{_pkgconfigdir}/libbtctl.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libbtctl.a
152 %endif
153
154 %files -n python-btctl
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{py_sitedir}/btctl.so
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/libbtctl
162 %endif
This page took 0.073234 seconds and 2 git commands to generate.