]> git.pld-linux.org Git - packages/libbluray.git/blob - libbluray.spec
121bd72c8c6425384b5bd638e36e9f481da4dff8
[packages/libbluray.git] / libbluray.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  java            # BD-Java
5 #
6 Summary:        Library to access Blu-Ray disks for video playback
7 Summary(pl.UTF-8):      Biblioteka dostępu do dysków Blu-Ray w celu odtwarzania filmów
8 Name:           libbluray
9 Version:        1.3.1
10 Release:        1
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        https://download.videolan.org/videolan/libbluray/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  55d69915d56d491637b8378ca54c3b7a
15 Patch0:         java.patch
16 URL:            http://www.videolan.org/developers/libbluray.html
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  fontconfig-devel
21 BuildRequires:  freetype-devel >= 2
22 BuildRequires:  libtool
23 BuildRequires:  libudfread-devel >= 1.1.1
24 BuildRequires:  libxml2-devel >= 1:2.6.0
25 BuildRequires:  pkgconfig
26 Requires:       libudfread >= 1.1.1
27 Requires:       libxml2 >= 1:2.6.0
28 %if %{with java}
29 BuildRequires:  ant
30 BuildRequires:  jdk >= 1.8
31 BuildRequires:  rpmbuild(macros) >= 1.527
32 Provides:       %{name}(jvm) = %{version}-%{release}
33 Suggests:       %{name}-java = %{version}-%{release}
34 %endif
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 This package is aiming to provide a full portable free open source
39 bluray library, which can be plugged into popular media players to
40 allow full bluray navigation and playback on Linux. It will eventually
41 be compatible with all current titles, and will be easily portable and
42 embeddable in standard players such as mplayer and vlc.
43
44 %description -l pl
45 Ten pakiet ma w zamierzeniu dostarczać w pełni przenośną,
46 wolnodostępną i mającą otwarte źródła biblioteką bluray, dającą się
47 wykorzystać w popularnych odtwarzaczach multimedialnych w celu
48 pełnej nawigacji i odtwarzania filmów pod Linuksem. Ostatecznie
49 powinna być kompatybilna ze wszystkimi bieżącymi tytułami, łatwo
50 przenośna i dająca się wbudować w standardowe odtwarzacze, takie jak
51 mplayer czy vlc.
52
53 %package devel
54 Summary:        Header files for libbluray library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbluray
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       fontconfig-devel
59 Requires:       freetype-devel >= 2
60 Requires:       libudfread-devel >= 1.1.1
61 Requires:       libxml2-devel >= 1:2.6.0
62
63 %description devel
64 Header files for libbluray library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki libbluray.
68
69 %package static
70 Summary:        Static libbluray library
71 Summary(pl.UTF-8):      Statyczna biblioteka libbluray
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libbluray library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libbluray.
80
81 %package java
82 Summary:        BD-Java support classes for libbluray
83 Summary(pl.UTF-8):      Klasy obsługujące BD-Java dla libbluray
84 Group:          Libraries/Java
85 Requires:       %{name}(jvm) = %{version}-%{release}
86 Requires:       jre
87
88 %description java
89 BD-Java support classes for libbluray.
90
91 %description java -l pl.UTF-8
92 Klasy obsługujące BD-Java dla libbluray.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97
98 %build
99 %{__libtoolize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         %{?with_java:JDK_HOME=%{_jvmdir}/java} \
106         %{!?with_java:--disable-bdjava-jar} \
107         --disable-silent-rules \
108         %{__enable_disable static_libs static}
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc ChangeLog README.md
129 %attr(755,root,root) %{_bindir}/bd_info
130 %attr(755,root,root) %{_bindir}/bd_list_titles
131 %attr(755,root,root) %{_bindir}/bd_splice
132 %attr(755,root,root) %{_libdir}/libbluray.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libbluray.so.2
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libbluray.so
138 %{_includedir}/libbluray
139 %{_pkgconfigdir}/libbluray.pc
140
141 %if %{with static_libs}
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libbluray.a
145 %endif
146
147 %if %{with java}
148 # NOTE: it's Java package loaded by libbluray itself, not Java API to libbluray
149 # thus -java instead of java- namespace.
150 %files java
151 %defattr(644,root,root,755)
152 %{_javadir}/libbluray-awt-j2se-%{version}.jar
153 %{_javadir}/libbluray-j2se-%{version}.jar
154 %endif
This page took 0.074022 seconds and 3 git commands to generate.