]> git.pld-linux.org Git - packages/libbluray.git/blob - libbluray.spec
00633e28aaa3357d74fd03eb4589bd52a051df78
[packages/libbluray.git] / libbluray.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  java            # BD-Java
5 #
6 Summary:        Library to access Blu-Ray disks for video playback
7 Summary(pl.UTF-8):      Biblioteka dostępu do dysków Blu-Ray w celu odtwarzania filmów
8 Name:           libbluray
9 Version:        0.7.0
10 Release:        2
11 License:        LGPL v2+
12 Group:          Libraries
13 Source0:        http://download.videolan.org/videolan/libbluray/%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  efad766330164f0c7c7cb18f66389870
15 URL:            http://www.videolan.org/developers/libbluray.html
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  doxygen
19 BuildRequires:  fontconfig-devel
20 BuildRequires:  freetype-devel >= 2
21 BuildRequires:  libtool
22 BuildRequires:  libxml2-devel >= 1:2.6.0
23 BuildRequires:  pkgconfig
24 Requires:       libxml2 >= 1:2.6.0
25 %if %{with java}
26 BuildRequires:  ant
27 BuildRequires:  jdk
28 Provides:       %{name}(jvm) = %{version}-%{release}
29 Suggests:       %{name}-java = %{version}-%{release}
30 %endif
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This package is aiming to provide a full portable free open source
35 bluray library, which can be plugged into popular media players to
36 allow full bluray navigation and playback on Linux. It will eventually
37 be compatible with all current titles, and will be easily portable and
38 embeddable in standard players such as mplayer and vlc.
39
40 %description -l pl
41 Ten pakiet ma w zamierzeniu dostarczać w pełni przenośną,
42 wolnodostępną i mającą otwarte źródła biblioteką bluray, dającą się
43 wykorzystać w popularnych odtwarzaczach multimedialnych w celu
44 pełnej nawigacji i odtwarzania filmów pod Linuksem. Ostatecznie
45 powinna być kompatybilna ze wszystkimi bieżącymi tytułami, łatwo
46 przenośna i dająca się wbudować w standardowe odtwarzacze, takie jak
47 mplayer czy vlc.
48
49 %package devel
50 Summary:        Header files for libbluray library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbluray
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       fontconfig-devel
55 Requires:       freetype-devel >= 2
56 Requires:       libxml2-devel >= 1:2.6.0
57
58 %description devel
59 Header files for libbluray library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki libbluray.
63
64 %package static
65 Summary:        Static libbluray library
66 Summary(pl.UTF-8):      Statyczna biblioteka libbluray
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static libbluray library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka libbluray.
75
76 %package java
77 Summary:        BD-Java support classes for libbluray
78 Summary(pl.UTF-8):      Klasy obsługujące BD-Java dla libbluray
79 Group:          Libraries/Java
80 Requires:       %{name}(jvm) = %{version}-%{release}
81 Requires:       jre
82
83 %description java
84 BD-Java support classes for libbluray.
85
86 %description java -l pl.UTF-8
87 Klasy obsługujące BD-Java dla libbluray.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         %{?with_java:JDK_HOME=%{_jvmdir}/java} \
100         %{?with_java:--enable-bdjava} \
101         --disable-silent-rules \
102         %{__enable_disable static_libs static}
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc ChangeLog README.txt
122 %attr(755,root,root) %{_bindir}/bd_info
123 %attr(755,root,root) %{_libdir}/libbluray.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libbluray.so.1
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libbluray.so
129 %{_includedir}/libbluray
130 %{_pkgconfigdir}/libbluray.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libbluray.a
136 %endif
137
138 %if %{with java}
139 # NOTE: it's Java package loaded by libbluray itself, not Java API to libbluray
140 # thus -java instead of java- namespace.
141 %files java
142 %defattr(644,root,root,755)
143 %{_javadir}/libbluray-j2se-%{version}.jar
144 %endif
This page took 0.046885 seconds and 2 git commands to generate.