]> git.pld-linux.org Git - packages/libbinio.git/blob - libbinio.spec
- dropped obsolete gcc4 patch
[packages/libbinio.git] / libbinio.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Binary I/O stream class library
6 Summary(pl.UTF-8):      Biblioteka klas C++ dla strumieniowych binarnych operacji I/O
7 Name:           libbinio
8 Version:        1.5
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 #Source0Download: https://github.com/adplug/libbinio/releases
13 Source0:        https://github.com/adplug/libbinio/releases/download/%{name}-%{version}/%{name}-%{version}.tar.bz2
14 # Source0-md5:  261046e16f74d1cdbf9aa6c78fa264e4
15 Patch0:         %{name}-infopage.patch
16 URL:            http://adplug.github.io/libbinio/
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  libtool >= 2:1.5
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  texinfo
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The binary I/O stream class library presents a platform-independent
26 way to access binary data streams in C++. The library is hardware
27 independent in the form that it transparently converts between the
28 different forms of machine-internal binary data representation. It
29 further employs no special I/O protocol and can be used on arbitrary
30 binary data sources.
31
32 %description -l pl.UTF-8
33 Biblioteka klas strumieniowych binarnych operacji wejścia/wyjścia
34 prezentuje niezależny od platformy sposób dostępu do binarnych
35 strumieni danych w C++. Biblioteka jest niezależna od sprzętu dzięki
36 temu, że w przezroczysty sposób wykonuje konwersję pomiędzy różnymi
37 postaciami reprezentacji danych binarnych w wewnętrznym formacie
38 maszyny. Co więcej, nie wykorzystuje żadnego specjalnego protokołu
39 wejścia/wyjścia i może być używana na dowolnych źródłach danych
40 binarnych.
41
42 %package devel
43 Summary:        Header files for libbinio library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbinio
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       libstdc++-devel
48
49 %description devel
50 Header files for libbinio library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki libbinio.
54
55 %package static
56 Summary:        Static libbinio library
57 Summary(pl.UTF-8):      Statyczna biblioteka libbinio
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static libbinio library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libbinio.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 %{__libtoolize}
73 %{__aclocal}
74 %{__autoconf}
75 %{__automake}
76 %configure \
77         %{!?with_static_libs:--disable-static}
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 # obsoleted by pkg-config
87 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbinio.la
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %post   devel -p /sbin/postshell
96 -/usr/sbin/fix-info-dir -c %{_infodir}
97
98 %postun devel -p /sbin/postshell
99 -/usr/sbin/fix-info-dir -c %{_infodir}
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog NEWS README
104 %attr(755,root,root) %{_libdir}/libbinio.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libbinio.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libbinio.so
110 %{_includedir}/libbinio
111 %{_pkgconfigdir}/libbinio.pc
112 %{_infodir}/libbinio.info*
113
114 %if %{with static_libs}
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libbinio.a
118 %endif
This page took 1.475065 seconds and 3 git commands to generate.