]> git.pld-linux.org Git - packages/libavtp.git/blob - libavtp.spec
- new
[packages/libavtp.git] / libavtp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        Implementation of Audio Video Transport Protocol (AVTP) specified in IEEE 1722-2016
6 Summary(pl.UTF-8):      Implementacja Audio Video Transport Protocol (AVTP) opisanego w IEEE 1722-2016
7 Name:           libavtp
8 Version:        0.2.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/Avnu/libavtp/releases
13 Source0:        https://github.com/Avnu/libavtp/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  f0b6ecb4cb5ab0d1226067efef7a5a2b
15 URL:            https://github.com/AVnu/libavtp
16 BuildRequires:  meson >= 0.46.0
17 BuildRequires:  ninja >= 1.8.2
18 BuildRequires:  rpmbuild(macros) >= 1.736
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Open source implementation of Audio Video Transport Protocol (AVTP)
23 specified in IEEE 1722-2016.
24
25 %description -l pl.UTF-8
26 Mająca otwarte źródła implementacja protokołu transmisji obrazu i
27 dźwięku AVTP (Audio Video Transport Protocol), opisanego w IEEE
28 1722-2016.
29
30 %package devel
31 Summary:        Header files for AVTP library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki AVTP
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35
36 %description devel
37 Header files for AVTP library.
38
39 %description devel -l pl.UTF-8
40 Pliki nagłówkowe biblioteki AVTP.
41
42 %package static
43 Summary:        Static AVTP library
44 Summary(pl.UTF-8):      Statyczna biblioteka AVTP
45 Group:          Development/Libraries
46 Requires:       %{name}-devel = %{version}-%{release}
47
48 %description static
49 Static AVTP library.
50
51 %description static -l pl.UTF-8
52 Statyczna biblioteka AVTP.
53
54 %prep
55 %setup -q
56
57 %build
58 %meson build \
59         %{!?with_static_libs:--default-library=shared} \
60         -Dtests=disabled
61
62 %ninja_build -C build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %ninja_install -C build
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post   -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files
76 %defattr(644,root,root,755)
77 %doc LICENSE README.md
78 %attr(755,root,root) %{_libdir}/libavtp.so.*.*.*
79 %attr(755,root,root) %ghost %{_libdir}/libavtp.so.0
80
81 %files devel
82 %defattr(644,root,root,755)
83 %attr(755,root,root) %{_libdir}/libavtp.so
84 %{_includedir}/avtp*.h
85 %{_pkgconfigdir}/avtp.pc
86
87 %if %{with static_libs}
88 %files static
89 %defattr(644,root,root,755)
90 %{_libdir}/libavtp.a
91 %endif
This page took 0.08341 seconds and 3 git commands to generate.