]> git.pld-linux.org Git - packages/libavif.git/blob - libavif.spec
- new
[packages/libavif.git] / libavif.spec
1 #
2 # Conditional build:
3 %bcond_without  aom             # AOM for encoding/decoding
4 %bcond_with     dav1d           # dav1d for decoding
5 %bcond_with     libgav1         # libgav1 for decoding
6 %bcond_with     rav1e           # rav1e for encoding
7 %bcond_with     svtav1          # SVT-AV1 for encoding
8 #
9 Summary:        Library for encoding and decoding .avif files
10 Summary(pl.UTF-8):      Biblioteka do kodowania i dekodowania plików .avif
11 Name:           libavif
12 Version:        0.9.2
13 Release:        1
14 License:        BSD
15 Group:          Libraries
16 #Source0Download: https://github.com/AOMediaCodec/libavif/releases
17 Source0:        https://github.com/AOMediaCodec/libavif/archive/v%{version}/%{name}-%{version}.tar.gz
18 # Source0-md5:  e7a0f29f783b9734c6c4aa21ecc3007e
19 URL:            https://github.com/AOMediaCodec/libavif
20 %{?with_aom:BuildRequires:      aom-devel}
21 BuildRequires:  cmake >= 3.5
22 %{?with_dav1d:BuildRequires:    dav1d-devel}
23 BuildRequires:  gcc >= 5:3.2
24 %{?with_libgav1:BuildRequires:  libgav1-devel}
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libyuv-devel >= 0.1755
28 %{?with_rav1e:BuildRequires:    rav1e-devel}
29 BuildRequires:  rpmbuild(macros) >= 1.745
30 %{?with_svtav1:BuildRequires:   svt-av1-devel}
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 This library aims to be a friendly, portable C implementation of the
36 AV1 Image File Format, as described here:
37 <https://aomediacodec.github.io/av1-avif/>.
38
39 %description -l pl.UTF-8
40 Ta biblioteka powstała jako przyjazna, przenośna implementacja w C
41 obsługa formatu obrazów AV1, opisanego w dokumencie
42 <https://aomediacodec.github.io/av1-avif/>.
43
44 %package devel
45 Summary:        Header files for libavif library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libavif
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for libavif library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki libavif.
55
56 %prep
57 %setup -q
58
59 %build
60 install -d build
61 cd build
62 %cmake .. \
63         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
64         %{?with_aom:-DAVIF_CODEC_AOM=ON} \
65         %{?with_dav1d:-DAVIF_CODEC_DAV1D=ON} \
66         %{?with_libgav1:-DAVIF_CODEC_LIBGAV1=ON} \
67         %{?with_rav1e:-DAVIF_CODEC_RAV1E=ON} \
68         %{?with_svtav1:-DAVIF_CODEC_SVT=ON}
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc CHANGELOG.md LICENSE README.md
87 %attr(755,root,root) %{_libdir}/libavif.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libavif.so.12
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libavif.so
93 %{_includedir}/avif
94 %{_pkgconfigdir}/libavif.pc
95 %{_libdir}/cmake/libavif
This page took 0.175041 seconds and 3 git commands to generate.