]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
afb0b9682379ca08581e521dc966425d529c5170
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4
5 Summary:        Multi-format archive and compression library
6 Summary(pl.UTF-8):      Biblioteka do archiwizacji i kompresji w wielu formatach
7 Name:           libarchive
8 Version:        3.3.3
9 Release:        2
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://www.libarchive.org/downloads/%{name}-%{version}.tar.gz
13 # Source0-md5:  4038e366ca5b659dae3efcc744e72120
14 Patch0:         %{name}-man_progname.patch
15 URL:            http://www.libarchive.org/
16 BuildRequires:  acl-devel
17 BuildRequires:  attr-devel
18 BuildRequires:  bzip2-devel
19 # for <ext2fs/ext2_fs.h>
20 BuildRequires:  e2fsprogs-devel
21 BuildRequires:  libxml2-devel >= 2
22 BuildRequires:  lz4-devel >= r131
23 BuildRequires:  lzo-devel >= 2
24 BuildRequires:  nettle-devel
25 BuildRequires:  pkgconfig
26 BuildRequires:  richacl-devel
27 BuildRequires:  xz-devel
28 BuildRequires:  zlib-devel
29 Requires:       lz4-libs >= r131
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Libarchive is a programming library that can create and read several
34 different streaming archive formats, including most popular TAR
35 variants, several CPIO formats, and both BSD and GNU ar variants. It
36 can also write SHAR archives and read ISO9660 CDROM images and ZIP
37 archives.
38
39 See README for complete format support.
40
41 %description -l pl.UTF-8
42 Libarchive to biblioteka potrafiąca tworzyć i odczytywać kilka różnych
43 formatów archiwów strumieniowych, w tym najbardziej popularne warianty
44 archiwów TAR, kilka formatów CPIO oraz warianty BSD oraz GNU archiwów
45 ar. Potrafi także zapisywać archiwa SHAR oraz odczytywać obrazy CDROM
46 ISO9660 i archiwa ZIP.
47
48 Pełny wykaz obsługiwanych formatów znajduje się w pliku README.
49
50 %package devel
51 Summary:        Header files for libarchive library
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55 Requires:       acl-devel
56 Requires:       attr-devel
57 Requires:       bzip2-devel
58 Requires:       libxml2-devel
59 Requires:       lz4-devel >= r131
60 Requires:       nettle-devel
61 Requires:       xz-devel
62 Requires:       zlib-devel
63
64 %description devel
65 Header files for libarchive library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki libarchive.
69
70 %package static
71 Summary:        Static libarchive library
72 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libarchive library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka libarchive.
81
82 %package -n bsdcat
83 Summary:        bsdcat - cat(1) implementation based on libarchive
84 Summary(pl.UTF-8):      bsdcat - implementacja programu cat(1) oparta na libarchive
85 Group:          Applications/Archiving
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n bsdcat
89 bsdcat - cat(1) implementation based on libarchive.
90
91 %description -n bsdcat -l pl.UTF-8
92 bsdcat - implementacja programu cat(1), oparta na libarchive.
93
94 %package -n bsdcpio
95 Summary:        bsdcpio - cpio(1) implementation based on libarchive
96 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
97 Group:          Applications/Archiving
98 Requires:       %{name} = %{version}-%{release}
99
100 %description -n bsdcpio
101 bsdcpio - cpio(1) implementation based on libarchive.
102
103 %description -n bsdcpio -l pl.UTF-8
104 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
105
106 %package -n bsdtar
107 Summary:        bsdtar - tar(1) implementation based on libarchive
108 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
109 Group:          Applications/Archiving
110 Requires:       %{name} = %{version}-%{release}
111
112 %description -n bsdtar
113 bsdtar - tar(1) implementation based on libarchive.
114
115 %description -n bsdtar -l pl.UTF-8
116 bsdtar - implementacja programu tar(1), oparta na libarchive.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121
122 %build
123 CPPFLAGS="%{rpmcppflags} -I/usr/include/lz4"
124 # disable openssl, nettle has all necessary functionality
125 %configure \
126         --disable-silent-rules \
127         --enable-bsdcat=shared \
128         --enable-bsdcpio=shared \
129         --enable-bsdtar=shared \
130         --enable-static%{!?with_static_libs:=no} \
131         --with-lzo2 \
132         --without-openssl
133 %{__make} -j1
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # obsoleted by pkg-config
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libarchive.la
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   -p /sbin/ldconfig
147 %postun -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc NEWS COPYING
152 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
153 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.13
154
155 %files devel
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libarchive.so
158 %{_includedir}/archive*.h
159 %{_mandir}/man3/archive_*.3*
160 %{_mandir}/man3/libarchive.3*
161 %{_mandir}/man3/libarchive_changes.3*
162 %{_mandir}/man3/libarchive_internals.3*
163 %{_mandir}/man5/libarchive-formats.5*
164 %{_mandir}/man5/cpio.5*
165 %{_mandir}/man5/mtree.5*
166 %{_mandir}/man5/tar.5*
167 %{_pkgconfigdir}/libarchive.pc
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libarchive.a
173 %endif
174
175 %files -n bsdcat
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_bindir}/bsdcat
178 %{_mandir}/man1/bsdcat.1*
179
180 %files -n bsdcpio
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/bsdcpio
183 %{_mandir}/man1/bsdcpio.1*
184
185 %files -n bsdtar
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/bsdtar
188 %{_mandir}/man1/bsdtar.1*
This page took 0.072294 seconds and 2 git commands to generate.