]> git.pld-linux.org Git - packages/libarchive.git/blob - libarchive.spec
- updated to 3.6.0
[packages/libarchive.git] / libarchive.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs # don't build static libraries
4
5 Summary:        Multi-format archive and compression library
6 Summary(pl.UTF-8):      Biblioteka do archiwizacji i kompresji w wielu formatach
7 Name:           libarchive
8 Version:        3.6.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 # see main page, downloads index may be out of date
13 #Source0Download: http://www.libarchive.org/
14 Source0:        http://www.libarchive.org/downloads/%{name}-%{version}.tar.xz
15 # Source0-md5:  93f96acdb9e7277278edb154e5d76e49
16 Patch0:         %{name}-man_progname.patch
17 URL:            http://www.libarchive.org/
18 BuildRequires:  acl-devel
19 BuildRequires:  attr-devel
20 BuildRequires:  bzip2-devel
21 # for <ext2fs/ext2_fs.h>
22 BuildRequires:  e2fsprogs-devel
23 BuildRequires:  libb2-devel
24 BuildRequires:  libxml2-devel >= 2
25 BuildRequires:  lz4-devel >= r131
26 BuildRequires:  lzo-devel >= 2
27 BuildRequires:  nettle-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  richacl-devel
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 BuildRequires:  xz-devel >= 1:5.2
33 BuildRequires:  zlib-devel
34 BuildRequires:  zstd-devel
35 Requires:       lz4-libs >= r131
36 Requires:       xz-libs >= 1:5.2
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Libarchive is a programming library that can create and read several
41 different streaming archive formats, including most popular TAR
42 variants, several CPIO formats, and both BSD and GNU ar variants. It
43 can also write SHAR archives and read ISO9660 CDROM images and ZIP
44 archives.
45
46 See README for complete format support.
47
48 %description -l pl.UTF-8
49 Libarchive to biblioteka potrafiąca tworzyć i odczytywać kilka różnych
50 formatów archiwów strumieniowych, w tym najbardziej popularne warianty
51 archiwów TAR, kilka formatów CPIO oraz warianty BSD oraz GNU archiwów
52 ar. Potrafi także zapisywać archiwa SHAR oraz odczytywać obrazy CDROM
53 ISO9660 i archiwa ZIP.
54
55 Pełny wykaz obsługiwanych formatów znajduje się w pliku README.
56
57 %package devel
58 Summary:        Header files for libarchive library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libarchive
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       acl-devel
63 Requires:       attr-devel
64 Requires:       bzip2-devel
65 Requires:       libb2-devel
66 Requires:       libxml2-devel
67 Requires:       lz4-devel >= r131
68 Requires:       nettle-devel
69 Requires:       richacl-devel
70 Requires:       xz-devel >= 1:5.2
71 Requires:       zlib-devel
72 Requires:       zstd-devel
73
74 %description devel
75 Header files for libarchive library.
76
77 %description devel -l pl.UTF-8
78 Pliki nagłówkowe biblioteki libarchive.
79
80 %package static
81 Summary:        Static libarchive library
82 Summary(pl.UTF-8):      Statyczna biblioteka libarchive
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static libarchive library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka libarchive.
91
92 %package -n bsdcat
93 Summary:        bsdcat - cat(1) implementation based on libarchive
94 Summary(pl.UTF-8):      bsdcat - implementacja programu cat(1) oparta na libarchive
95 Group:          Applications/Archiving
96 Requires:       %{name} = %{version}-%{release}
97
98 %description -n bsdcat
99 bsdcat - cat(1) implementation based on libarchive.
100
101 %description -n bsdcat -l pl.UTF-8
102 bsdcat - implementacja programu cat(1), oparta na libarchive.
103
104 %package -n bsdcpio
105 Summary:        bsdcpio - cpio(1) implementation based on libarchive
106 Summary(pl.UTF-8):      bsdcpio - implementacja programu cpio(1) oparta na libarchive
107 Group:          Applications/Archiving
108 Requires:       %{name} = %{version}-%{release}
109
110 %description -n bsdcpio
111 bsdcpio - cpio(1) implementation based on libarchive.
112
113 %description -n bsdcpio -l pl.UTF-8
114 bsdcpio - implementacja programu cpio(1), oparta na libarchive.
115
116 %package -n bsdtar
117 Summary:        bsdtar - tar(1) implementation based on libarchive
118 Summary(pl.UTF-8):      bsdtar - implementacja programu tar(1) oparta na libarchive
119 Group:          Applications/Archiving
120 Requires:       %{name} = %{version}-%{release}
121
122 %description -n bsdtar
123 bsdtar - tar(1) implementation based on libarchive.
124
125 %description -n bsdtar -l pl.UTF-8
126 bsdtar - implementacja programu tar(1), oparta na libarchive.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131
132 %build
133 CPPFLAGS="%{rpmcppflags} -I/usr/include/lz4"
134 # disable openssl, nettle has all necessary functionality
135 %configure \
136         --disable-silent-rules \
137         --enable-bsdcat=shared \
138         --enable-bsdcpio=shared \
139         --enable-bsdtar=shared \
140         --enable-static%{!?with_static_libs:=no} \
141         --with-lzo2 \
142         --without-openssl
143 %{__make}
144
145 %install
146 rm -rf $RPM_BUILD_ROOT
147 %{__make} install \
148         DESTDIR=$RPM_BUILD_ROOT
149
150 # obsoleted by pkg-config
151 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libarchive.la
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   -p /sbin/ldconfig
157 %postun -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc NEWS COPYING
162 %attr(755,root,root) %{_libdir}/libarchive.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libarchive.so.13
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libarchive.so
168 %{_includedir}/archive*.h
169 %{_mandir}/man3/archive_*.3*
170 %{_mandir}/man3/libarchive.3*
171 %{_mandir}/man3/libarchive_changes.3*
172 %{_mandir}/man3/libarchive_internals.3*
173 %{_mandir}/man5/libarchive-formats.5*
174 %{_mandir}/man5/cpio.5*
175 %{_mandir}/man5/mtree.5*
176 %{_mandir}/man5/tar.5*
177 %{_pkgconfigdir}/libarchive.pc
178
179 %if %{with static_libs}
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libarchive.a
183 %endif
184
185 %files -n bsdcat
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/bsdcat
188 %{_mandir}/man1/bsdcat.1*
189
190 %files -n bsdcpio
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/bsdcpio
193 %{_mandir}/man1/bsdcpio.1*
194
195 %files -n bsdtar
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/bsdtar
198 %{_mandir}/man1/bsdtar.1*
This page took 0.103016 seconds and 3 git commands to generate.