]> git.pld-linux.org Git - packages/libapparmor.git/blob - libapparmor.spec
c3b8a3b35568d7fb5ddd7ded693b22a70e744d5f
[packages/libapparmor.git] / libapparmor.spec
1 #
2 # Conditional build:
3 %bcond_without  ruby            # build without Ruby bindings
4 %bcond_with     python3         # build for Python3
5
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Library to provide key AppArmor symbols
8 Summary(pl.UTF-8):      Biblioteka udostępniająca kluczowe symbole AppArmor
9 Name:           libapparmor
10 Version:        2.10
11 Release:        1
12 Epoch:          1
13 License:        LGPL v2.1
14 Group:          Libraries
15 Source0:        http://launchpad.net/apparmor/2.10/%{version}/+download/apparmor-%{version}.tar.gz
16 # Source0-md5:  9fd9b6b3525882fdb9441d0f0a8f9162
17 URL:            http://apparmor.wiki.kernel.org/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake >= 1.4
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  libtool
23 BuildRequires:  perl-devel
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  pkgconfig
26 %if %{with python3}
27 BuildRequires:  python3-devel
28 %else
29 BuildRequires:  python-devel
30 %endif
31 BuildRequires:  rpmbuild(macros) >= 1.272
32 BuildRequires:  rpm-perlprov
33 BuildRequires:  rpm-pythonprov
34 %{?with_ruby:BuildRequires:     ruby-devel}
35 BuildRequires:  swig-perl
36 BuildRequires:  swig-python
37 %{?with_ruby:BuildRequires:     swig-ruby}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This package provides the libapparmor library, which contains the
42 change_hat(2) symbol, used for sub-process confinement by AppArmor.
43 Applications that wish to make use of change_hat(2) need to link
44 against this library. This package is part of a suite of tools that
45 used to be named SubDomain.
46
47 %description -l pl.UTF-8
48 Ten pakiet udostępnia bibliotekę libapparmor, zawierającą symbol
49 change_hat(2), używany do więzienia podprocesów przez AppArmor.
50 Aplikacje chcące używać change_hat(2) muszą być linkowane z tą
51 biblioteką. Ten pakiet jest częścią zestawu narzędzi nazywanego
52 SubDomain.
53
54 %package devel
55 Summary:        Header files for libapparmor library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libapparmor
57 Group:          Development/Libraries
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59
60 %description devel
61 This is the package containing the header files for libapparmor
62 library.
63
64 %description devel -l pl.UTF-8
65 Ten pakiet zawiera pliki nagłówkowe biblioteki libapparmor.
66
67 %package static
68 Summary:        Static libapparmor library
69 Summary(pl.UTF-8):      Statyczna biblioteka libapparmor
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static libapparmor library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libapparmor.
78
79 %package -n perl-LibAppArmor
80 Summary:        AppArmor Perl bindings
81 Summary(pl.UTF-8):      Dowiązania do AppArmor dla Perla
82 Summary(pt_BR.UTF-8):   Módulos Perl para acessar os recursos do AppArmor
83 Group:          Development/Languages/Perl
84 Obsoletes:      perl-apparmor
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86
87 %description -n perl-LibAppArmor
88 AppArmor Perl bindings.
89
90 %description -n perl-LibAppArmor -l pl.UTF-8
91 Dowiązania do AppArmor dla Perla.
92
93 %description -n perl-LibAppArmor -l pt_BR.UTF-8
94 Módulos Perl para acessar os recursos do AppArmor.
95
96 %package -n python-LibAppArmor
97 Summary:        AppArmor Python bindings
98 Summary(pl.UTF-8):      Dowiązania do AppArmor dla Pythona
99 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do AppArmor
100 Group:          Development/Languages/Python
101 %pyrequires_eq  python
102 Obsoletes:      python-apparmor
103 Requires:       %{name} = %{epoch}:%{version}-%{release}
104
105 %description -n python-LibAppArmor
106 AppArmor Python bindings.
107
108 %description -n python-LibAppArmor -l pl.UTF-8
109 Dowiązania do AppArmor dla Pythona.
110
111 %description -n python-LibAppArmor -l pt_BR.UTF-8
112 Módulos Python para acessar os recursos do AppArmor.
113
114 %package -n python3-LibAppArmor
115 Summary:        AppArmor Python bindings
116 Summary(pl.UTF-8):      Dowiązania do AppArmor dla Pythona
117 Summary(pt_BR.UTF-8):   Módulos Python para acessar os recursos do AppArmor
118 Group:          Development/Languages/Python
119 %pyrequires_eq  python3
120 Obsoletes:      python3-apparmor
121 Requires:       %{name} = %{epoch}:%{version}-%{release}
122
123 %description -n python3-LibAppArmor
124 AppArmor Python bindings.
125
126 %description -n python3-LibAppArmor -l pl.UTF-8
127 Dowiązania do AppArmor dla Pythona.
128
129 %description -n python3-LibAppArmor -l pt_BR.UTF-8
130 Módulos Python para acessar os recursos do AppArmor.
131
132 %package -n ruby-LibAppArmor
133 Summary:        AppArmor Ruby bindings
134 Summary(pl.UTF-8):      Dowiązania do AppArmor dla języka Ruby
135 Group:          Development/Languages
136 Obsoletes:      ruby-apparmor
137 Requires:       %{name} = %{epoch}:%{version}-%{release}
138 %{?ruby_mod_ver_requires_eq}
139
140 %description -n ruby-LibAppArmor
141 AppArmor Ruby bindings.
142
143 %description -n ruby-LibAppArmor -l pl.UTF-8
144 Dowiązania do AppArmor dla języka Ruby.
145
146 %prep
147 %setup -q -n apparmor-%{version}
148
149 %build
150 cd libraries/libapparmor
151 %{__libtoolize}
152 %{__aclocal}
153 %{__autoconf}
154 %{__automake}
155
156 %configure \
157 %if %{with python3}
158         PYTHON="%{__python3}" \
159 %endif
160         %{?with_ruby:--with-ruby} \
161         --with-python \
162         --with-perl
163
164 %{__make} -j1 \
165         CC="%{__cc}" \
166         CFLAGS="%{rpmcflags} -fPIC"
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170
171 %{__make} -j1 -C libraries/libapparmor install \
172         RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_vendorarchdir} \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 %py_postclean
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %post   -p /sbin/ldconfig
181 %postun -p /sbin/ldconfig
182
183 %files
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libapparmor.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libapparmor.so.1
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libapparmor.so
191 %{_libdir}/libapparmor.la
192 %{_includedir}/aalogparse
193 %{_includedir}/sys/apparmor.h
194 %{_includedir}/sys/apparmor_private.h
195 %{_pkgconfigdir}/libapparmor.pc
196 %{_mandir}/man2/aa_change_hat.2*
197 %{_mandir}/man2/aa_change_profile.2*
198 %{_mandir}/man2/aa_find_mountpoint.2*
199 %{_mandir}/man2/aa_getcon.2*
200 %{_mandir}/man2/aa_query_label.2*
201 %{_mandir}/man3/aa_features.3*
202 %{_mandir}/man3/aa_kernel_interface.3*
203 %{_mandir}/man3/aa_policy_cache.3*
204 %{_mandir}/man3/aa_splitcon.3*
205
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/libapparmor.a
209
210 %files -n perl-LibAppArmor
211 %defattr(644,root,root,755)
212 %{perl_vendorarch}/LibAppArmor.pm
213 %dir %{perl_vendorarch}/auto/LibAppArmor
214 %attr(755,root,root) %{perl_vendorarch}/auto/LibAppArmor/LibAppArmor.so
215
216 %if %{with python3}
217 %files -n python3-LibAppArmor
218 %defattr(644,root,root,755)
219 %dir %{py3_sitedir}/LibAppArmor
220 %attr(755,root,root) %{py3_sitedir}/LibAppArmor/_LibAppArmor.*.so
221 %{py3_sitedir}/LibAppArmor/__pycache__
222 %{py3_sitedir}/LibAppArmor/__init__.py
223 %{py3_sitedir}/LibAppArmor-*.egg-info
224 %else
225 %files -n python-LibAppArmor
226 %defattr(644,root,root,755)
227 %dir %{py_sitedir}/LibAppArmor
228 %attr(755,root,root) %{py_sitedir}/LibAppArmor/_LibAppArmor.so
229 %{py_sitedir}/LibAppArmor/__init__.py[co]
230 %{py_sitedir}/LibAppArmor-*.egg-info
231 %endif
232
233 %if %{with ruby}
234 %files -n ruby-LibAppArmor
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{ruby_vendorarchdir}/LibAppArmor.so
237 %endif
This page took 0.042234 seconds and 3 git commands to generate.