]> git.pld-linux.org Git - packages/libaec.git/blob - libaec.spec
- new
[packages/libaec.git] / libaec.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static libraries
4 #
5 Summary:        Adaptive Entropy Coding library
6 Summary(pl.UTF-8):      Biblioteka Adaptive Entropy Coding
7 Name:           libaec
8 Version:        0.3.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://www.dkrz.de/redmine/projects/aec/wiki/Downloads
13 Source0:        https://www.dkrz.de/redmine/attachments/download/453/%{name}-%{version}.tar.gz
14 # Source0-md5:  19c1211935d82d8b0bf581329634a6d7
15 URL:            https://www.dkrz.de/redmine/projects/aec/wiki
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Libaec provides fast lossless compression of 1 up to 32 bit wide
20 signed or unsigned integers (samples). The library achieves best
21 results for low entropy data as often encountered in space imaging
22 instrument data or numerical model output from weather or climate
23 simulations. While floating point representations are not directly
24 supported, they can also be efficiently coded by grouping exponents
25 and mantissa.
26
27 Libaec also includes a free drop-in replacement for the SZIP library.
28
29 %description -l pl.UTF-8
30 Libaec zapewnia szybką, bezstratną kompresję liczb całkowitych
31 (próbek) z lub bez znaku o rozmiarze od 1 do 32 bitów. Biblioteka
32 osiąga najlepsze wyniki dla danych o małej entropii, zwykle
33 spotykanych w danych z przyrządów pomiarowych albo modeli numerycznych
34 symulacji pogody lub klimatu. Mimo że reprezentacje zmiennoprzecinkowe
35 nie są bezpośrednio obsługiwane, mogą być wydajnie kodowane poprzez
36 grupowanie wykładników i mantys.
37
38 Libaec zawiera także wolnodostępny zamiennik biblioteki SZIP.
39
40 %package devel
41 Summary:        Header files for libaec library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libaec
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for libaec library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libaec.
51
52 %package static
53 Summary:        Static libaec library
54 Summary(pl.UTF-8):      Statyczna biblioteka libaec
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libaec library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libaec.
63
64 %package szip
65 Summary:        Free SZIP library replacement based on libaec
66 Summary(pl.UTF-8):      Wolnodostępny zamiennik biblioteki SZIP oparty na libaec
67 Group:          Libraries
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       szip = 2.0.0
70 Obsoletes:      szip < 2.2
71
72 %description szip
73 Free SZIP compression library replacement based on libaec.
74
75 %description szip -l pl.UTF-8
76 Wolnodostępny zamiennik biblioteki kompresji SZIP oparty na libaec.
77
78 %package szip-devel
79 Summary:        Free SZIP library replacement based on libaec - header file
80 Summary(pl.UTF-8):      Wolnodostępny zamiennik biblioteki SZIP oparty na libaec - plik nagłówkowy
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{version}-%{release}
83 Requires:       %{name}-szip = %{version}-%{release}
84 Provides:       szip-devel = 2.0.0
85 Obsoletes:      szip-devel < 2.2
86
87 %description szip-devel
88 Free SZIP compression library replacement based on libaec - header
89 file.
90
91 %description szip-devel -l pl.UTF-8
92 Wolnodostępny zamiennik biblioteki kompresji SZIP oparty na libaec -
93 plik nagłówkowy.
94
95 %package szip-static
96 Summary:        Free SZIP library replacement based on libaec - static library
97 Summary(pl.UTF-8):      Wolnodostępny zamiennik biblioteki SZIP oparty na libaec - biblioteka statyczna
98 Group:          Development/Libraries
99 Requires:       %{name}-szip-devel = %{version}-%{release}
100 Provides:       szip-static = 2.0.0
101 Obsoletes:      szip-static < 2.2
102
103 %description szip-static
104 Free SZIP compression library replacement based on libaec - static
105 library.
106
107 %description szip-static -l pl.UTF-8
108 Wolnodostępny zamiennik biblioteki kompresji SZIP oparty na libaec -
109 biblioteka statyczna.
110
111 %prep
112 %setup -q
113
114 %build
115 %configure \
116         %{!?with_static_libs:--disable-static}
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %post   szip -p /sbin/ldconfig
132 %postun szip -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING ChangeLog README README.SZIP doc/license.txt
137 %attr(755,root,root) %{_bindir}/aec
138 %attr(755,root,root) %{_libdir}/libaec.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libaec.so.0
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libaec.so
144 %{_libdir}/libaec.la
145 %{_includedir}/libaec.h
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libaec.a
151 %endif
152
153 %files szip
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libsz.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libsz.so.2
157
158 %files szip-devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libsz.so
161 %{_libdir}/libsz.la
162 %{_includedir}/szlib.h
163
164 %if %{with static_libs}
165 %files szip-static
166 %defattr(644,root,root,755)
167 %{_libdir}/libsz.a
168 %endif
This page took 0.106432 seconds and 3 git commands to generate.