]> git.pld-linux.org Git - packages/libabw.git/blob - libabw.spec
- updated to 0.1.0 (now librevenge based; new soname, 0.0.x left on libabw-0.0 branch)
[packages/libabw.git] / libabw.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define         apiversion      0.1
6 Summary:        A library for import of AbiWord files
7 Summary(pl.UTF-8):      Biblioteka do importowania plików AbiWorda
8 Name:           libabw
9 Version:        0.1.0
10 Release:        1
11 License:        MPL v2.0
12 Group:          Libraries
13 Source0:        http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.xz
14 # Source0-md5:  f29f5ad99b36635fb566c55327b1905e
15 URL:            http://www.freedesktop.org/wiki/Software/libabw/
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf >= 3.0.0
19 BuildRequires:  librevenge-devel >= 0.0
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libabw is a library for import of AbiWord files.
30
31 %description -l pl.UTF-8
32 libabw to biblioteka do importowania plików AbiWorda.
33
34 %package devel
35 Summary:        Development files for libabw
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libabw
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       librevenge-devel >= 0.0
40 Requires:       libstdc++-devel
41 Requires:       libxml2-devel >= 2.0
42 Requires:       zlib-devel
43
44 %description devel
45 This package contains the header files for developing applications
46 that use libabw.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera biblioteki i pliki nagłówkowe do tworzenia
50 aplikacji wykorzystujących bibliotekę libabw.
51
52 %package static
53 Summary:        Static libabw library
54 Summary(pl.UTF-8):      Statyczna biblioteka libabw
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libabw library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libabw.
63
64 %package apidocs
65 Summary:        API documentation for libabw library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki libabw
67 Group:          Documentation
68
69 %description apidocs
70 API documentation for libabw library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki libabw.
74
75 %package tools
76 Summary:        Tools to transform AbiWord files into other formats
77 Summary(pl.UTF-8):      Narzędzia do przekształcania plików AbiWorda do innych formatów
78 Group:          Applications/Publishing
79 Requires:       %{name} = %{version}-%{release}
80
81 %description tools
82 Tools to transform AbiWord files into other formats. Currently
83 supported: XHTML, raw, text.
84
85 %description tools -l pl.UTF-8
86 Narzędzia do przekształcania plików AbiWorda do innych formatów.
87 Obecnie obsługiwane są: XHTML, surowy, tekst.
88
89 %prep
90 %setup -q
91
92 %build
93 %configure \
94         --disable-silent-rules \
95         %{?with_static_libs:--enable-static}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
105
106 # we install API docs directly from build
107 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc CREDITS ChangeLog NEWS README
118 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libabw-%{apiversion}.so.1
120
121 %files devel
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so
124 %{_includedir}/libabw-%{apiversion}
125 %{_pkgconfigdir}/libabw-%{apiversion}.pc
126
127 %if %{with static_libs}
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/libabw-%{apiversion}.a
131 %endif
132
133 %files apidocs
134 %defattr(644,root,root,755)
135 %doc docs/doxygen/html/*
136
137 %files tools
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/abw2raw
140 %attr(755,root,root) %{_bindir}/abw2text
141 %attr(755,root,root) %{_bindir}/abw2html
This page took 0.090314 seconds and 3 git commands to generate.