]> git.pld-linux.org Git - packages/libSavitar.git/blob - libSavitar.spec
a1a0333ab4a8a688a182eafaf83ef4b65dc48142
[packages/libSavitar.git] / libSavitar.spec
1 Summary:        C++ implementation of 3mf loading with SIP Python bindings
2 Name:           libSavitar
3 Version:        2.7.0
4 Release:        4
5 License:        AGPLv3+
6 Group:          Libraries
7 Source0:        https://github.com/Ultimaker/libSavitar/archive/%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  584cd4f3dacdcdbe69edcd42b83a4c6c
9 Patch0:         no-pugixml.patch
10 Patch1:         system-pugixml.patch
11 Patch2:         lib-suffix.patch
12 Patch3:         PyQt5-sip.patch
13 URL:            https://github.com/Ultimaker/libSavitar
14 BuildRequires:  cmake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  pugixml-devel
17 BuildRequires:  python3-devel
18 BuildRequires:  python3-sip-devel
19 BuildRequires:  sip
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Savitar is a C++ implementation of 3mf loading with SIP Python
24 bindings. 3mf is a 3D printing file format.
25
26 %package devel
27 # The cmake scripts are BSD
28 Summary:        Development files for libsavitar
29 License:        AGPLv3+ and BSD
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Savitar is a C++ implementation of 3mf loading with SIP Python
35 bindings. 3mf is a 3D printing file format.
36
37 Development files.
38
39 %package -n python3-savitar
40 Summary:        Python 3 libSavitar bindings
41 Group:          Libraries/Python
42 Requires:       %{name} = %{version}-%{release}
43
44 %description -n python3-savitar
45 Savitar is a C++ implementation of 3mf loading with SIP Python
46 bindings. 3mf is a 3D printing file format.
47
48 The Python bindings.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55 %patch3 -p1
56
57 %build
58 mkdir build
59 cd build
60 %{cmake} .. \
61         -DCMAKE_SKIP_RPATH:BOOL=ON
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -C build install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(644,root,root,755)
78 %doc README.md
79 %attr(755,root,root) %{_libdir}/libSavitar.so.*.*.*
80 %attr(755,root,root) %ghost %{_libdir}/libSavitar.so.0
81
82 %files devel
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_libdir}/libSavitar.so
85 %{_includedir}/Savitar
86 %{_libdir}/cmake/Savitar
87
88 %files -n python3-savitar
89 %defattr(644,root,root,755)
90 %doc README.md
91 %attr(755,root,root) %{py3_sitedir}/Savitar.so
This page took 0.181118 seconds and 2 git commands to generate.