]> git.pld-linux.org Git - packages/libCSS.git/blob - libCSS.spec
- new
[packages/libCSS.git] / libCSS.spec
1 #
2 # TODO: avoid compilation in the install stage
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        CSS parser and selection engine
7 Name:           libCSS
8 Version:        0.2.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/libcss-%{version}-src.tar.gz
13 # Source0-md5:  e61700e0dce2a122d65b85dba04c4b40
14 URL:            http://www.netsurf-browser.org/projects/libcss/
15 BuildRequires:  libparserutils-devel >= 0.1.2
16 BuildRequires:  libwapcaplet-devel >= 0.2.0
17 BuildRequires:  netsurf-buildsystem
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 LibCSS is a CSS (Cascading Style Sheet) parser and selection engine,
22 written in C. It was developed as part of the NetSurf project and is
23 available for use by other software under the MIT licence. For further
24 details, see the readme.
25
26 Features
27
28 - Parses CSS, good and bad
29 - Simple C API
30 - Low memory usage
31 - Fast selection engine
32 - Portable
33 - Shared library
34
35 %package devel
36 Summary:        libCSS library headers
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libCSS
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 This is the libraries, include files and other resources you can use
43 to incorporate libCSS into applications.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe pozwalające na używanie biblioteki libCSS w swoich
47 programach.
48
49 %package static
50 Summary:        libCSS static libraries
51 Summary(pl.UTF-8):      Statyczne biblioteki libCSS
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 This is package with static libCSS libraries.
57
58 %description static -l pl.UTF-8
59 Statyczna biblioteka libCSS.
60
61 %prep
62 %setup -q -n libcss-%{version}
63
64 %build
65 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-shared Q='' \
66         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
67 %if %{with static_libs}
68 %{__make} PREFIX=%{_prefix} COMPONENT_TYPE=lib-static Q='' \
69         CFLAGS="%{rpmcflags} -Iinclude -Isrc" LDFLAGS="%{rpmldflags}"
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -j1 install \
76         DESTDIR=$RPM_BUILD_ROOT \
77         PREFIX=%{_prefix} \
78         COMPONENT_TYPE=lib-shared \
79         Q=''
80
81 %if %{with static_libs}
82 %{__make} -j1 install \
83         DESTDIR=$RPM_BUILD_ROOT \
84         PREFIX=%{_prefix} \
85         COMPONENT_TYPE=lib-static \
86         Q=''
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/lib*.so
102 %{_includedir}/libcss
103 %{_pkgconfigdir}/*pc
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/lib*.a
109 %endif
This page took 0.084775 seconds and 3 git commands to generate.