]> git.pld-linux.org Git - packages/letsencrypt.git/blob - letsencrypt.spec
up to 0.1.0, letsencrypt entered public beta
[packages/letsencrypt.git] / letsencrypt.spec
1 # TODO: finish, test
2 #
3 # Conditional build:
4 %bcond_without  doc             # don't build doc
5 %bcond_without  tests   # do not perform "make test"
6
7 Summary:        Let's Encrypt client
8 Name:           letsencrypt
9 Version:        0.1.0
10 Release:        0.1
11 License:        APL 2.0
12 Group:          Applications/Networking
13 Source0:        https://github.com/letsencrypt/letsencrypt/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  eb1208bcf5c33a6f030da9419718bf6b
15 URL:            https://letsencrypt.org/
16 BuildRequires:  python-modules
17 BuildRequires:  python-setuptools
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.612
20 %if %{with tests}
21 BuildRequires:  python-mock
22 BuildRequires:  python-pythondialog
23 BuildRequires:  python-zope.component
24 BuildRequires:  python-zope.interface
25 %endif
26 %if %{with doc}
27 BuildRequires:  python-repoze.sphinx.autointerfac
28 BuildRequires:  sphinx-pdg
29 %endif
30 Requires:       python-cryptography
31 Requires:       python-modules
32 Requires:       python-pyOpenSSL
33 Requires:       python-pytz
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Let's Encrypt Client is a tool to automatically receive and
39 install X.509 certificates to enable TLS on servers. The client will
40 interoperate with the Let's Encrypt CA which will be issuing
41 browser-trusted certificates for free.
42
43 %prep
44 %setup -q
45
46 %build
47 %{__python} setup.py build %{?with_tests:test}
48
49 %if %{with doc}
50 cd docs
51 %{__make} -j1 html
52 rm -r _build/html/_sources
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %{__python} setup.py \
58         build \
59         install --skip-build \
60         --optimize=2 \
61         --root=$RPM_BUILD_ROOT
62
63 %py_postclean
64
65 # don't package tests
66 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/letsencrypt/tests
67 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/letsencrypt/plugins/*_test.py*
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc {CHANGES,README}.rst CONTRIBUTING.md %{?with_doc:docs/_build/html/*}
75 %attr(755,root,root) %{_bindir}/letsencrypt
76 %attr(755,root,root) %{_bindir}/letsencrypt-renewer
77 %{py_sitescriptdir}/letsencrypt
78 %{py_sitescriptdir}/letsencrypt-%{version}*-py*.egg-info
This page took 0.345891 seconds and 4 git commands to generate.