]> git.pld-linux.org Git - packages/lemon.git/blob - lemon.spec
e67d114fa85976bfda60d25dc53828de83b28653
[packages/lemon.git] / lemon.spec
1 # TODO: coin support
2 #
3 # Conditional build:
4 %bcond_with     cplex           # CPLEX support [IBM proprietary]
5 %bcond_without  glpk            # GLPK support
6 %bcond_with     soplex          # SoPlex support
7 #
8 Summary:        Library of Efficient Models and Optimization in Networks
9 Summary(pl.UTF-8):      Biblioteka wydajnych modeli i optymalizacji w sieciach
10 Name:           lemon
11 Version:        1.3.1
12 Release:        1
13 License:        Boost v1.0
14 Group:          Libraries
15 Source0:        http://lemon.cs.elte.hu/pub/sources/%{name}-%{version}.tar.gz
16 # Source0-md5:  e89f887559113b68657eca67cf3329b5
17 URL:            http://lemon.cs.elte.hu/
18 BuildRequires:  cmake >= 2.8
19 BuildRequires:  doxygen
20 BuildRequires:  ghostscript
21 %{?with_glpk:BuildRequires:     glpk-devel >= 4.33}
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  python
24 %{?with_soplex:BuildRequires:   soplex-devel}
25 %{?with_glpk:Requires:  glpk >= 4.33}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 LEMON stands for Library for Efficient Modeling and Optimization in
30 Networks. It is a C++ template library providing efficient
31 implementations of common data structures and algorithms with focus on
32 combinatorial optimization tasks connected mainly with graphs and
33 networks.
34
35 %description -l pl.UTF-8
36 LEMON to skrót od Library for Efficient Modeling and Optimization in
37 Networks (biblioteka do wydajnego modelowania i optymalizacji w
38 sieciach). Jest to biblioteka szablonów C++ udostępniająca wydajne
39 implementacje popularnych struktur danych i algorytmów przeznaczonych
40 do zadań optymalizacji kombinatorycznej, związanych głównie z grafami
41 i sieciami.
42
43 %package devel
44 Summary:        Header files for LEMON library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LEMON
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libstdc++-devel
49 Obsoletes:      lemon-static
50
51 %description devel
52 Header files for LEMON library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki LEMON.
56
57 %package apidocs
58 Summary:        LEMON API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki LEMON
60 Group:          Documentation
61
62 %description apidocs
63 API documentation for LEMON library.
64
65 %description apidocs -l pl.UTF-8
66 Dokumentacja API biblioteki LEMON.
67
68 %prep
69 %setup -q
70
71 %build
72 install -d build
73 cd build
74 %cmake .. \
75         %{!?with_coin:-DLEMON_ENABLE_COIN=OFF} \
76         %{!?with_glpk:-DLEMON_ENABLE_GLPK=OFF} \
77         %{!?with_cplex:-DLEMON_ENABLE_ILOG=OFF} \
78         %{!?with_soplex:-DLEMON_ENABLE_SOPLEX=OFF}
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} -C build install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS LICENSE NEWS README
96 %attr(755,root,root) %{_bindir}/dimacs-solver
97 %attr(755,root,root) %{_bindir}/dimacs-to-lgf
98 %attr(755,root,root) %{_bindir}/lemon-0.x-to-1.x.sh
99 %attr(755,root,root) %{_bindir}/lgf-gen
100 %attr(755,root,root) %{_libdir}/libemon.so.%{version}
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libemon.so
105 %{_includedir}/lemon
106 %{_pkgconfigdir}/lemon.pc
107 %dir %{_datadir}/lemon
108 %{_datadir}/lemon/cmake
109
110 %files apidocs
111 %defattr(644,root,root,755)
112 %{_docdir}/lemon
This page took 0.055251 seconds and 2 git commands to generate.