]> git.pld-linux.org Git - packages/ldns.git/blob - ldns.spec
- updated to 1.6.16
[packages/ldns.git] / ldns.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  python          # Python modules
5 #
6 Summary:        ldns - a library with the aim to simplify DNS programing in C
7 Summary(pl.UTF-8):      ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
8 Name:           ldns
9 Version:        1.6.16
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
14 # Source0-md5:  9ab2b402127cf24dffefaacbb727cad7
15 URL:            http://www.nlnetlabs.nl/ldns/
16 BuildRequires:  autoconf >= 2.56
17 BuildRequires:  automake
18 BuildRequires:  doxygen
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel >= 1.0.0
21 %if %{with python}
22 BuildRequires:  python-devel >= 1:2.4.0
23 BuildRequires:  rpmbuild(macros) >= 1.219
24 BuildRequires:  swig-python
25 %endif
26 Requires:       openssl >= 1.0.0
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 ldns is a library with the aim to simplify DNS programing in C. It is
31 heavily based upon the Net::DNS module from perl.
32
33 %description -l pl.UTF-8
34 ldns jest biblioteka mającą na celu uproszczenie programowania
35 związanego z usługą DNS w C. Jest w dużym stopniu oparta na module
36 Perla Net::DNS.
37
38 %package devel
39 Summary:        Header files for ldns library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ldns
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       openssl-devel >= 1.0.0
44
45 %description devel
46 Header files for ldns library.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki ldns.
50
51 %package static
52 Summary:        Static ldns library
53 Summary(pl.UTF-8):      Statyczna biblioteka ldns
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static ldns library.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka ldns.
62
63 %package -n python-ldns
64 Summary:        Python interface do ldns library
65 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki ldns
66 Group:          Libraries/Python
67 Requires:       %{name} = %{version}-%{release}
68
69 %description -n python-ldns
70 Python interface do ldns library.
71
72 %description -n python-ldns -l pl.UTF-8
73 Pythonowy interfejs do biblioteki ldns.
74
75 %package -n drill
76 Summary:        drill - tool to get all sorts of information out of the DNS(SEC)
77 Summary(pl.UTF-8):      drill - narzędzie do pobierania dowolnych informacji z DNS(SEC)
78 Group:          Applications/Network
79 Requires:       %{name} = %{version}-%{release}
80
81 %description -n drill
82 drill is a tool to get all sorts of information out of the DNS. It is
83 specifically designed to be used with DNSSEC.
84
85 %description -n drill -l pl.UTF-8
86 drill to narzędzie do pobierania dowolnych informacji z DNS. Jest
87 zaprojektowane szczególnie z myślą o użyciu z DNSSEC.
88
89 %prep
90 %setup -q
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__autoheader}
97 %configure \
98         --enable-static%{!?with_static_libs:=no} \
99         --with-drill \
100         %{?with_python:--with-pyldns}
101 %{__make}
102 %{__make} doc
103
104 # change symlinks into .so redirects
105 cd doc/man/man3
106 for f in `find . -type l`; do
107         d=`readlink $f`
108         %{__rm} $f
109         echo ".so $d" > $f
110 done
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %if %{with python}
119 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.la
120 %if %{with static_libs}
121 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.a
122 %endif
123 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
124 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
125 %py_postclean
126 %endif
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc Changelog LICENSE README
137 %attr(755,root,root) %{_libdir}/libldns.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libldns.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc doc/{*.html,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle}
143 %attr(755,root,root) %{_bindir}/ldns-config
144 %attr(755,root,root) %{_libdir}/libldns.so
145 %{_libdir}/libldns.la
146 %{_includedir}/%{name}
147 %{_mandir}/man1/ldns-config.1*
148 %{_mandir}/man3/ldns_*.3*
149
150 %if %{with static_libs}
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libldns.a
154 %endif
155
156 %if %{with python}
157 %files -n python-ldns
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{py_sitedir}/_ldns.so*
160 %{py_sitedir}/ldns.py[co]
161 %{py_sitedir}/ldnsx.py[co]
162 %endif
163
164 %files -n drill
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/drill
167 %{_mandir}/man1/drill.1*
This page took 0.072163 seconds and 3 git commands to generate.