]> git.pld-linux.org Git - packages/ldns.git/blob - ldns.spec
db3da9abc4d1b617a9eb38b534d54e64c5f34b7d
[packages/ldns.git] / ldns.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 %bcond_without  python          # Python modules
5 #
6 Summary:        ldns - a library with the aim to simplify DNS programing in C
7 Summary(pl.UTF-8):      ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
8 Name:           ldns
9 Version:        1.6.15
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
14 # Source0-md5:  164d271350d832c45e4a9be4b9cb4206
15 Patch0:         %{name}-link.patch
16 URL:            http://www.nlnetlabs.nl/ldns/
17 BuildRequires:  autoconf >= 2.56
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel >= 1.0.0
22 %if %{with python}
23 BuildRequires:  python-devel >= 1:2.4.0
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 BuildRequires:  swig-python
26 %endif
27 Requires:       openssl >= 1.0.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 ldns is a library with the aim to simplify DNS programing in C. It is
32 heavily based upon the Net::DNS module from perl.
33
34 %description -l pl.UTF-8
35 ldns jest biblioteka mającą na celu uproszczenie programowania
36 związanego z usługą DNS w C. Jest w dużym stopniu oparta na module
37 Perla Net::DNS.
38
39 %package devel
40 Summary:        Header files for ldns library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ldns
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       openssl-devel >= 1.0.0
45
46 %description devel
47 Header files for ldns library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki ldns.
51
52 %package static
53 Summary:        Static ldns library
54 Summary(pl.UTF-8):      Statyczna biblioteka ldns
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static ldns library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka ldns.
63
64 %package -n python-ldns
65 Summary:        Python interface do ldns library
66 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki ldns
67 Group:          Libraries/Python
68 Requires:       %{name} = %{version}-%{release}
69
70 %description -n python-ldns
71 Python interface do ldns library.
72
73 %description -n python-ldns -l pl.UTF-8
74 Pythonowy interfejs do biblioteki ldns.
75
76 %package -n drill
77 Summary:        drill - tool to get all sorts of information out of the DNS(SEC)
78 Summary(pl.UTF-8):      drill - narzędzie do pobierania dowolnych informacji z DNS(SEC)
79 Group:          Applications/Network
80 Requires:       %{name} = %{version}-%{release}
81
82 %description -n drill
83 drill is a tool to get all sorts of information out of the DNS. It is
84 specifically designed to be used with DNSSEC.
85
86 %description -n drill -l pl.UTF-8
87 drill to narzędzie do pobierania dowolnych informacji z DNS. Jest
88 zaprojektowane szczególnie z myślą o użyciu z DNSSEC.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93
94 %build
95 %{__libtoolize}
96 %{__aclocal}
97 %{__autoconf}
98 %{__autoheader}
99 %configure \
100         --enable-static%{!?with_static_libs:=no} \
101         --with-drill \
102         %{?with_python:--with-pyldns}
103 %{__make}
104 %{__make} doc
105
106 # change symlinks into .so redirects
107 cd doc/man/man3
108 for f in `find . -type l`; do
109         d=`readlink $f`
110         %{__rm} $f
111         echo ".so $d" > $f
112 done
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %if %{with python}
121 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.la
122 %if %{with static_libs}
123 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.a
124 %endif
125 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
126 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
127 %py_postclean
128 %endif
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc Changelog LICENSE README
139 %attr(755,root,root) %{_libdir}/libldns.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libldns.so.1
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc doc/{*.html,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle}
145 %attr(755,root,root) %{_bindir}/ldns-config
146 %attr(755,root,root) %{_libdir}/libldns.so
147 %{_libdir}/libldns.la
148 %{_includedir}/%{name}
149 %{_mandir}/man1/ldns-config.1*
150 %{_mandir}/man3/ldns_*.3*
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libldns.a
156 %endif
157
158 %if %{with python}
159 %files -n python-ldns
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{py_sitedir}/_ldns.so*
162 %{py_sitedir}/ldns.py[co]
163 %{py_sitedir}/ldnsx.py[co]
164 %endif
165
166 %files -n drill
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_bindir}/drill
169 %{_mandir}/man1/drill.1*
This page took 0.05728 seconds and 2 git commands to generate.