]> git.pld-linux.org Git - packages/ldb.git/blob - ldb.spec
e3e168b8d29a40e00340b25c3edc23ede9140bd2
[packages/ldb.git] / ldb.spec
1 # TODO
2 # - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
3 %define         talloc_version  2:2.0.8
4 %define         tdb_version     2:1.2.12
5 %define         tevent_version  0.9.17
6 Summary:        LDAP-like embedded database
7 Summary(pl.UTF-8):      Wbudowana baza danych podobna do LDAP
8 Name:           ldb
9 Version:        1.1.16
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        http://samba.org/ftp/ldb/%{name}-%{version}.tar.gz
14 # Source0-md5:  60865c0b5704469ee2e59703087c8ec8
15 URL:            http://ldb.samba.org/
16 BuildRequires:  autoconf
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  libxslt
19 BuildRequires:  popt-devel
20 BuildRequires:  python-devel >= 1:2.4.2
21 BuildRequires:  python-talloc-devel >= %{talloc_version}
22 BuildRequires:  python-tdb >= %{tdb_version}
23 BuildRequires:  python-tevent >= %{tevent_version}
24 BuildRequires:  talloc-devel >= %{talloc_version}
25 BuildRequires:  tdb-devel >= %{tdb_version}
26 BuildRequires:  tevent-devel >= %{tevent_version}
27 Requires:       talloc >= %{talloc_version}
28 Requires:       tdb >= %{tdb_version}
29 Requires:       tevent >= %{tevent_version}
30 Provides:       libldb = %{version}-%{release}
31 Obsoletes:      libldb < 1.1.0-3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 An extensible library that implements an LDAP like API to access
36 remote LDAP servers, or use local tdb databases.
37
38 %description -l pl.UTF-8
39 Rozszerzalna biblioteka implementująca API podobne do LDAP pozwalające
40 na dostęp do zdalnych serwerów LDAP lub wykorzystanie lokalnych baz
41 danych tdb.
42
43 %package tools
44 Summary:        Tools to manage LDB files
45 Summary(pl.UTF-8):      Narzędzia do zarządzania plikami LDB
46 Group:          Applications/Databases
47 Requires:       %{name} = %{version}-%{release}
48
49 %description tools
50 Tools to manage LDB files.
51
52 %description tools -l pl.UTF-8
53 Narzędzia do zarządzania plikami LDB.
54
55 %package devel
56 Summary:        Header files for the LDB library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LDB
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       talloc-devel >= %{talloc_version}
61 Requires:       tdb-devel >= %{tdb_version}
62 Requires:       tevent-devel >= %{tevent_version}
63 Provides:       libldb-devel = %{version}-%{release}
64 Obsoletes:      libldb-devel < 1.1.0-3
65
66 %description devel
67 Header files needed to develop programs that link against the LDB
68 library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
72 bibliotekę LDB.
73
74 %package -n python-ldb
75 Summary:        Python bindings for the LDB library
76 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LDB
77 Group:          Libraries/Python
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       python-libs >= 1:2.4.2
80 Requires:       python-tdb >= %{tdb_version}
81 Obsoletes:      pyldb
82
83 %description -n python-ldb
84 Python bindings for the LDB library.
85
86 %description -n python-ldb -l pl.UTF-8
87 Wiązania Pythona do biblioteki LDB.
88
89 %package -n python-ldb-devel
90 Summary:        Development files for the Python bindings for the LDB library
91 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do biblioteki LDB
92 Group:          Development/Libraries
93 Requires:       python-ldb = %{version}-%{release}
94
95 %description -n python-ldb-devel
96 Development files for the Python bindings for the LDB library.
97
98 %description -n python-ldb-devel -l pl.UTF-8
99 Pliki programistyczne wiązań Pythona do biblioteki LDB.
100
101 %prep
102 %setup -q
103
104 %build
105 CC="%{__cc}" \
106 CFLAGS="%{rpmcflags}" \
107 LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
108 PYTHONDIR=%{py_sitedir} \
109 ./configure \
110         --prefix=%{_prefix} \
111         --libdir=%{_libdir} \
112         --with-modulesdir=%{_libdir}/ldb/modules \
113         --with-privatelibdir=%{_libdir}/ldb \
114         --bundled-libraries=NONE \
115         --disable-rpath \
116         --disable-rpath-install
117
118 %{__make} \
119         V=1
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 # Shared libraries need to be marked executable for
127 # rpmbuild to strip them and include them in debuginfo
128 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %post   -n python-ldb -p /sbin/ldconfig
137 %postun -n python-ldb -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libldb.so.1
143 %dir %{_libdir}/ldb
144 %dir %{_libdir}/ldb/modules
145 %dir %{_libdir}/ldb/modules/ldb
146 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
147
148 %files tools
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/ldbadd
151 %attr(755,root,root) %{_bindir}/ldbdel
152 %attr(755,root,root) %{_bindir}/ldbedit
153 %attr(755,root,root) %{_bindir}/ldbmodify
154 %attr(755,root,root) %{_bindir}/ldbrename
155 %attr(755,root,root) %{_bindir}/ldbsearch
156 %attr(755,root,root) %{_libdir}/ldb/libldb-cmdline.so
157 %{_mandir}/man1/ldbadd.1*
158 %{_mandir}/man1/ldbdel.1*
159 %{_mandir}/man1/ldbedit.1*
160 %{_mandir}/man1/ldbmodify.1*
161 %{_mandir}/man1/ldbrename.1*
162 %{_mandir}/man1/ldbsearch.1*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libldb.so
167 %{_includedir}/ldb_module.h
168 %{_includedir}/ldb_handlers.h
169 %{_includedir}/ldb_errors.h
170 %{_includedir}/ldb_version.h
171 %{_includedir}/ldb.h
172 %{_pkgconfigdir}/ldb.pc
173 %{_mandir}/man3/ldb.3*
174
175 %files -n python-ldb
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
179 %attr(755,root,root) %{py_sitedir}/ldb.so
180
181 %files -n python-ldb-devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libpyldb-util.so
184 %{_includedir}/pyldb.h
185 %{_pkgconfigdir}/pyldb-util.pc
This page took 0.07739 seconds and 2 git commands to generate.